summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 16:49:37 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:41 +0100
commitda0a306d29d1604bdbb957f33ce83fd658f9b042 (patch)
tree01ff1d3bd911b51d9b55c35132d5e46a8aac6f1e /net-print
parentmedia-libs/sdl2-gfx: drop no-op USE=static-libs (diff)
downloadgentoo-da0a306d29d1604bdbb957f33ce83fd658f9b042.tar.gz
gentoo-da0a306d29d1604bdbb957f33ce83fd658f9b042.tar.bz2
gentoo-da0a306d29d1604bdbb957f33ce83fd658f9b042.zip
net-print/cups-filters: drop no-op USE=static-libs, phase order, || die
We add --disable-static just to be sure though. We were already unconditionally deleting both .la and .a, so the USE flag did nothing. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/cups-filters-1.28.3.ebuild22
-rw-r--r--net-print/cups-filters/cups-filters-1.28.7.ebuild20
-rw-r--r--net-print/cups-filters/cups-filters-9999.ebuild22
3 files changed, 32 insertions, 32 deletions
diff --git a/net-print/cups-filters/cups-filters-1.28.3.ebuild b/net-print/cups-filters/cups-filters-1.28.3.ebuild
index d9d1f9e65e60..44bbe713db84 100644
--- a/net-print/cups-filters/cups-filters-1.28.3.ebuild
+++ b/net-print/cups-filters/cups-filters-1.28.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
RESTRICT="!test? ( test )"
@@ -81,13 +81,13 @@ src_configure() {
--with-pdftops=pdftops
--with-rcdir=no
--without-php
+ --disable-static
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
- $(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
@@ -100,21 +100,25 @@ src_compile() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_configure
perl-module_src_compile
- popd > /dev/null
+ popd > /dev/null || die
fi
}
+src_test() {
+ emake check
+}
+
src_install() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_install
perl_delete_localpod
- popd > /dev/null
+ popd > /dev/null || die
fi
if use postscript; then
@@ -136,10 +140,6 @@ src_install() {
systemd_dounit "${S}/utils/cups-browsed.service"
}
-src_test() {
- emake check
-}
-
pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
diff --git a/net-print/cups-filters/cups-filters-1.28.7.ebuild b/net-print/cups-filters/cups-filters-1.28.7.ebuild
index 37b780aabfce..44bbe713db84 100644
--- a/net-print/cups-filters/cups-filters-1.28.7.ebuild
+++ b/net-print/cups-filters/cups-filters-1.28.7.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
RESTRICT="!test? ( test )"
@@ -81,13 +81,13 @@ src_configure() {
--with-pdftops=pdftops
--with-rcdir=no
--without-php
+ --disable-static
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
- $(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
@@ -100,21 +100,25 @@ src_compile() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_configure
perl-module_src_compile
- popd > /dev/null
+ popd > /dev/null || die
fi
}
+src_test() {
+ emake check
+}
+
src_install() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_install
perl_delete_localpod
- popd > /dev/null
+ popd > /dev/null || die
fi
if use postscript; then
@@ -136,10 +140,6 @@ src_install() {
systemd_dounit "${S}/utils/cups-browsed.service"
}
-src_test() {
- emake check
-}
-
pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
index 90abc670cca8..ddd2623dced4 100644
--- a/net-print/cups-filters/cups-filters-9999.ebuild
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
RESTRICT="!test? ( test )"
@@ -79,13 +79,13 @@ src_configure() {
--with-pdftops=pdftops
--with-rcdir=no
--without-php
+ --disable-static
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
- $(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
@@ -98,21 +98,25 @@ src_compile() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_configure
perl-module_src_compile
- popd > /dev/null
+ popd > /dev/null || die
fi
}
+src_test() {
+ emake check
+}
+
src_install() {
default
if use perl; then
- pushd "${S}/scripting/perl" > /dev/null
+ pushd "${S}/scripting/perl" > /dev/null || die
perl-module_src_install
perl_delete_localpod
- popd > /dev/null
+ popd > /dev/null || die
fi
if use postscript; then
@@ -134,10 +138,6 @@ src_install() {
systemd_dounit "${S}/utils/cups-browsed.service"
}
-src_test() {
- emake check
-}
-
pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."