summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-10-23 15:14:11 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-23 15:14:11 +0200
commitea2e17d17a654bd503d75c8d8fb6c4e32b3df24c (patch)
tree38017400b0de11b5a418ce5d55cc2d99866ed83c /net-p2p
parentdev-python/imageio: Remove old (diff)
downloadgentoo-ea2e17d17a654bd503d75c8d8fb6c4e32b3df24c.tar.gz
gentoo-ea2e17d17a654bd503d75c8d8fb6c4e32b3df24c.tar.bz2
gentoo-ea2e17d17a654bd503d75c8d8fb6c4e32b3df24c.zip
net-p2p/{bitcoin-core,bitcoin-qt}: rename bitcoin-core[qt5 → gui]
As per PG 802 [1], rename the 'qt5' use flag to 'gui'. 1: https://projects.gentoo.org/qa/policy-guide/use-flags.html#pg0802 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild28
-rw-r--r--net-p2p/bitcoin-core/metadata.xml1
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild2
3 files changed, 15 insertions, 16 deletions
diff --git a/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild b/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
index 0ed41f21df48..f512f8f4c517 100644
--- a/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
+++ b/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
@@ -16,14 +16,14 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
# IUSE="+cli" doesn't work due to https://bugs.gentoo.org/831045#c3
-IUSE="+asm +berkdb +bitcoin-cli +daemon dbus examples +external-signer kde libs +man nat-pmp +qrcode qt5 +sqlite system-leveldb +system-libsecp256k1 systemtap test upnp zeromq"
+IUSE="+asm +berkdb +bitcoin-cli +daemon dbus examples +external-signer kde libs +man nat-pmp +qrcode gui +sqlite system-leveldb +system-libsecp256k1 systemtap test upnp zeromq"
RESTRICT="!test? ( test )"
REQUIRED_USE="
- dbus? ( qt5 )
- kde? ( qt5 )
- qrcode? ( qt5 )
- system-leveldb? ( || ( daemon qt5 ) )
+ dbus? ( gui )
+ kde? ( gui )
+ qrcode? ( gui )
+ system-leveldb? ( || ( daemon gui ) )
"
# dev-libs/univalue is now bundled, as upstream dropped support for system copy
# and their version in the Bitcoin repo has deviated a fair bit from upstream.
@@ -42,7 +42,7 @@ RDEPEND="
libs? ( !<net-libs/libbitcoinconsensus-25.0 )
nat-pmp? ( >=net-libs/libnatpmp-20220705:= )
qrcode? ( >=media-gfx/qrencode-4.1.1:= )
- qt5? (
+ gui? (
!<net-p2p/bitcoin-qt-25.0
>=dev-qt/qtcore-5.15.5:5
>=dev-qt/qtgui-5.15.5:5
@@ -66,11 +66,11 @@ BDEPEND="
acct-group/bitcoin
acct-user/bitcoin
)
- qt5? ( >=dev-qt/linguist-tools-5.15.5:5 )
+ gui? ( >=dev-qt/linguist-tools-5.15.5:5 )
test? ( ${PYTHON_DEPS} )
"
IDEPEND="
- qt5? ( dev-util/desktop-file-utils )
+ gui? ( dev-util/desktop-file-utils )
"
DOCS=(
@@ -116,7 +116,7 @@ src_prepare() {
sed -ne '/^ {/{h;:0;n;H;/^ }/!b0;g;\|"exec": *"\./bitcoin-util"|d};p' \
-i test/util/data/bitcoin-util-test.json || die
- sed -e 's/^\(complete -F _bitcoind\b\).*$/\1'"$(usev daemon ' bitcoind')$(usev qt5 ' bitcoin-qt')/" \
+ sed -e 's/^\(complete -F _bitcoind\b\).*$/\1'"$(usev daemon ' bitcoind')$(usev gui ' bitcoin-qt')/" \
-i contrib/completions/bash/bitcoind.bash-completion || die
}
@@ -146,7 +146,7 @@ src_configure() {
--disable-util-util
$(use_with libs)
$(use_with daemon)
- $(use_with qt5 gui qt5)
+ $(use_with gui)
$(use_with dbus qtdbus)
$(use_with system-leveldb)
$(use_with system-libsecp256k1)
@@ -168,7 +168,7 @@ src_install() {
newbashcomp contrib/completions/bash/bitcoin-tx.bash-completion bitcoin-tx
use bitcoin-cli && newbashcomp contrib/completions/bash/bitcoin-cli.bash-completion bitcoin-cli
- use daemon || use qt5 && newbashcomp contrib/completions/bash/bitcoind.bash-completion bitcoind
+ use daemon || use gui && newbashcomp contrib/completions/bash/bitcoind.bash-completion bitcoind
if use daemon ; then
insinto /etc/bitcoin
@@ -190,7 +190,7 @@ src_install() {
newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
fi
- if use qt5 ; then
+ if use gui ; then
insinto /usr/share/icons/hicolor/scalable/apps
newins src/qt/res/src/bitcoin.svg bitcoin128.svg
@@ -240,7 +240,7 @@ pkg_preinst() {
pkg_postinst() {
# we don't use xdg.eclass because it adds unconditional IDEPENDs
- if use qt5 ; then
+ if use gui ; then
xdg_desktop_database_update
xdg_icon_cache_update
fi
@@ -257,7 +257,7 @@ pkg_postinst() {
}
pkg_postrm() {
- if use qt5 ; then
+ if use gui ; then
xdg_desktop_database_update
xdg_icon_cache_update
fi
diff --git a/net-p2p/bitcoin-core/metadata.xml b/net-p2p/bitcoin-core/metadata.xml
index 3c0338bb1ad9..c5c7717fa5e5 100644
--- a/net-p2p/bitcoin-core/metadata.xml
+++ b/net-p2p/bitcoin-core/metadata.xml
@@ -18,7 +18,6 @@
<flag name="libs">Build and install libbitcoinconsensus</flag>
<flag name="nat-pmp">Enable NAT-PMP port forwarding</flag>
<flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
- <flag name="qt5">Build and install Bitcoin-Qt GUI</flag>
<flag name="sqlite">Support descriptor wallets in SQLite format</flag>
<flag name="system-leveldb">Link with virtual/bitcoin-leveldb rather than embedding an internal copy</flag>
<flag name="system-libsecp256k1">Link with dev-libs/libsecp256k1 rather than embedding an internal copy</flag>
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
index a879e99badc9..7f2c0a077ffd 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
@@ -13,6 +13,6 @@ IUSE="+asm +berkdb dbus +external-signer kde nat-pmp +qrcode +sqlite systemtap t
RESTRICT="!test? ( test )"
RDEPEND="
- ~net-p2p/bitcoin-core-${PV}[qt5,asm=,berkdb=,dbus=,external-signer=,kde=,nat-pmp=,qrcode=,sqlite=,systemtap=,test=,upnp=,zeromq=]
+ ~net-p2p/bitcoin-core-${PV}[gui,asm=,berkdb=,dbus=,external-signer=,kde=,nat-pmp=,qrcode=,sqlite=,systemtap=,test=,upnp=,zeromq=]
wallet? ( || ( ~net-p2p/bitcoin-core-${PV}[berkdb] ~net-p2p/bitcoin-core-${PV}[sqlite] ) )
"