summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-05-27 19:14:03 -0400
committerMike Gilbert <floppym@gentoo.org>2018-05-27 19:14:03 -0400
commit81c08d8e3979fc5ba5a87b7c031dec42bc68e2d4 (patch)
treed2d1ad6c8afe8b67d7f1bb6d83d72f11eaefdb59 /net-p2p
parentwww-plugins/chrome-binary-plugins: update dependencies (diff)
downloadgentoo-81c08d8e3979fc5ba5a87b7c031dec42bc68e2d4.tar.gz
gentoo-81c08d8e3979fc5ba5a87b7c031dec42bc68e2d4.tar.bz2
gentoo-81c08d8e3979fc5ba5a87b7c031dec42bc68e2d4.zip
net-p2p/transmission: bump to 2.94
Closes: https://bugs.gentoo.org/656586 Package-Manager: Portage-2.3.40_p4, Repoman-2.3.9_p236
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/Manifest1
-rw-r--r--net-p2p/transmission/transmission-2.94.ebuild163
2 files changed, 164 insertions, 0 deletions
diff --git a/net-p2p/transmission/Manifest b/net-p2p/transmission/Manifest
index 9768d963f686..ce243d76192d 100644
--- a/net-p2p/transmission/Manifest
+++ b/net-p2p/transmission/Manifest
@@ -1,2 +1,3 @@
DIST transmission-2.92.tar.xz 3378116 BLAKE2B 8929a2eab8a1617db44ca8a081fd7de786daef92e891ac86d4690451c0f4fa0d4e1ea03692c59babea6e9aee5dcfef57bd81e5c72a0bb4fe9efbd436ff006104 SHA512 4d99476bee88cedcc4238a0eee64a4089016933cbfc1cfb1cca023ad4ebcfe46375c9e7651a17af4aeaaf1feb19cbd8166aa56ef7992d9e745a7bbcbe8efca11
DIST transmission-2.93.tar.xz 3363868 BLAKE2B 786a8daec548d96b05d90c238cc7b67d402dc0d828860bb1a79b8059c687de309288be17fd12fd51abeafa28d9630fd19be9513c76cbf091f81ce9a181596042 SHA512 7565893f67fc10f1b683814fa4d365d841ec833bc8dfdab731432fe68f1a38daeb4c9100653763f16bfb4336fba11c9b0b9730a9817e17a140704a7c4aa5c087
+DIST transmission-2.94.tar.xz 3365952 BLAKE2B d0215a2c595dd3ebb2ed5c94cc3d380c78f62b98388557620534b88b9e2304bb6ac91960395541267f82d70800c4860d0e58125bca33dd158da992d19b4c0def SHA512 ee411743940f2897aa0bbc351ce79f11d860075d2e9e399d60301eae8cfc453e20426ef553fc62ee43019a07c052d512f5d7972cc4411fb57b1312c2c1558da7
diff --git a/net-p2p/transmission/transmission-2.94.ebuild b/net-p2p/transmission/transmission-2.94.ebuild
new file mode 100644
index 000000000000..37645783a92a
--- /dev/null
+++ b/net-p2p/transmission/transmission-2.94.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic gnome2-utils qmake-utils systemd user xdg-utils
+
+DESCRIPTION="A Fast, Easy and Free BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="https://github.com/transmission/transmission-releases/raw/master/${P}.tar.xz"
+
+# web/LICENSE is always GPL-2 whereas COPYING allows either GPL-2 or GPL-3 for the rest
+# transmission in licenses/ is for mentioning OpenSSL linking exception
+# MIT is in several libtransmission/ headers
+LICENSE="|| ( GPL-2 GPL-3 Transmission-OpenSSL-exception ) GPL-2 MIT"
+SLOT=0
+IUSE="ayatana gtk libressl lightweight systemd qt5 xfs"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
+
+RDEPEND=">=dev-libs/libevent-2.0.10:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-libs/libnatpmp
+ >=net-libs/miniupnpc-1.7:=
+ >=net-misc/curl-7.16.3[ssl]
+ sys-libs/zlib:=
+ gtk? (
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.4:3
+ ayatana? ( >=dev-libs/libappindicator-0.4.90:3 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ )
+ systemd? ( >=sys-apps/systemd-209:= )"
+DEPEND="${RDEPEND}
+ >=dev-libs/glib-2.32
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/os-headers
+ virtual/pkgconfig
+ qt5? ( dev-qt/linguist-tools:5 )
+ xfs? ( sys-fs/xfsprogs )"
+
+REQUIRED_USE="ayatana? ( gtk )"
+
+DOCS=( AUTHORS NEWS qt/README.txt )
+
+PATCHES=(
+ "${FILESDIR}"/libsystemd.patch
+)
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac || die
+
+ # Trick to avoid automagic dependency
+ if ! use ayatana ; then
+ sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac || die
+ fi
+
+ # http://trac.transmissionbt.com/ticket/4324
+ sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' libtransmission/Makefile.am || die
+
+ # Prevent m4_copy error when running aclocal
+ # m4_copy: won't overwrite defined macro: glib_DEFUN
+ rm m4/glib-gettext.m4 || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_xfs_xfs_h=$(usex xfs)
+
+ # https://bugs.gentoo.org/577528
+ append-lfs-flags
+
+ econf \
+ --enable-external-natpmp \
+ $(use_enable lightweight) \
+ $(use_with systemd systemd-daemon) \
+ $(use_with gtk)
+
+ if use qt5; then
+ pushd qt >/dev/null || die
+ eqmake5 qtr.pro
+ popd >/dev/null || die
+ fi
+}
+
+src_compile() {
+ emake
+
+ if use qt5; then
+ emake -C qt
+ $(qt5_get_bindir)/lrelease qt/translations/*.ts || die
+ fi
+}
+
+src_install() {
+ default
+
+ rm "${ED%/}"/usr/share/transmission/web/LICENSE || die
+
+ newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
+ newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon
+ systemd_dounit daemon/transmission-daemon.service
+ systemd_install_serviced "${FILESDIR}"/transmission-daemon.service.conf
+
+ if use qt5; then
+ pushd qt >/dev/null || die
+ emake INSTALL_ROOT="${ED%/}"/usr install
+
+ domenu transmission-qt.desktop
+
+ local res
+ for res in 16 22 24 32 48 64 72 96 128 192 256; do
+ doicon -s ${res} icons/hicolor/${res}x${res}/transmission-qt.png
+ done
+ doicon -s scalable icons/hicolor/scalable/transmission-qt.svg
+
+ insinto /usr/share/qt5/translations
+ doins translations/*.qm
+ popd >/dev/null || die
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+
+ enewgroup transmission
+ enewuser transmission -1 -1 /var/lib/transmission transmission
+
+ if [[ ! -e "${EROOT%/}"/var/lib/transmission ]]; then
+ mkdir -p "${EROOT%/}"/var/lib/transmission || die
+ chown transmission:transmission "${EROOT%/}"/var/lib/transmission || die
+ fi
+
+ elog "If you use transmission-daemon, please, set 'rpc-username' and"
+ elog "'rpc-password' (in plain text, transmission-daemon will hash it on"
+ elog "start) in settings.json file located at /var/lib/transmission/config or"
+ elog "any other appropriate config directory."
+ elog
+ elog "Since µTP is enabled by default, transmission needs large kernel buffers for"
+ elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
+ elog " net.core.rmem_max = 4194304"
+ elog " net.core.wmem_max = 1048576"
+ elog "and run sysctl -p"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}