summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-24 10:48:14 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-24 10:48:49 +0200
commit1968a7bbb830347f73a27c1b98eca3cd8bca9c1d (patch)
tree5064bef5e8a03c9ffc3c453c43540d33471e28b0 /net-p2p
parentsys-block/thin-provisioning-tools: arm stable wrt bug #619126 (diff)
downloadgentoo-1968a7bbb830347f73a27c1b98eca3cd8bca9c1d.tar.gz
gentoo-1968a7bbb830347f73a27c1b98eca3cd8bca9c1d.tar.bz2
gentoo-1968a7bbb830347f73a27c1b98eca3cd8bca9c1d.zip
net-p2p/ktorrent: Fixed compilation with cmake-3.11
commit permission kindly granted by asturm Closes: https://bugs.gentoo.org/650808 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/files/ktorrent-5.1.0-cmake-3.11.patch13
-rw-r--r--net-p2p/ktorrent/ktorrent-5.1.0.ebuild5
2 files changed, 17 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/files/ktorrent-5.1.0-cmake-3.11.patch b/net-p2p/ktorrent/files/ktorrent-5.1.0-cmake-3.11.patch
new file mode 100644
index 000000000000..c0b9167636a8
--- /dev/null
+++ b/net-p2p/ktorrent/files/ktorrent-5.1.0-cmake-3.11.patch
@@ -0,0 +1,13 @@
+https://docs.freebsd.org/cgi/getmsg.cgi?fetch=4423635+0+/usr/local/www/mailindex/archive/2018/svn-ports-all/20180415.svn-ports-all
+
+--- ktorrent-5.1.0/ktorrent/dialogs/torrentcreatordlg.h
++++ ktorrent-5.1.0/ktorrent/dialogs/torrentcreatordlg.h
+@@ -23,6 +23,8 @@
+ #define KT_TORRENTCREATORDLG_HH
+
+ #include <QDialog>
++#include <QTimer>
++
+ #include "ui_torrentcreatordlg.h"
+ #include <torrent/torrentcreator.h>
+
diff --git a/net-p2p/ktorrent/ktorrent-5.1.0.ebuild b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
index ef67d30802dc..567c2e977b4f 100644
--- a/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
+++ b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
@@ -78,7 +78,10 @@ RDEPEND="${COMMON_DEPEND}
!net-p2p/ktorrent:4
"
-PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-cmake-3.11.patch" #650808
+)
src_configure() {
local mycmakeargs=(