summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-03-15 20:53:29 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 20:36:44 +0200
commita2c99543bfd3245724e21089a617f28d828c5548 (patch)
tree9dfdc2ed107c3b2f1a0f5599940420c91682343c /net-misc
parentnet-misc/chrony: Run as non-root when USE=caps, revbump (diff)
downloadgentoo-a2c99543bfd3245724e21089a617f28d828c5548.tar.gz
gentoo-a2c99543bfd3245724e21089a617f28d828c5548.tar.bz2
gentoo-a2c99543bfd3245724e21089a617f28d828c5548.zip
net-misc/chrony: Enable seccomp filtering when USE=seccomp
We already have USE=seccomp but chronyd won't do anything unless -F is set to 1. We could also set -F -1 which will log any syscalls which would've been blocked but won't deny them. Also fixes systemd for previous commit. Bug: https://bugs.gentoo.org/711058 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/14973 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/chrony-3.5-r3.ebuild30
-rw-r--r--net-misc/chrony/chrony-4.0_pre1-r1.ebuild155
-rw-r--r--net-misc/chrony/chrony-9999.ebuild30
-rw-r--r--net-misc/chrony/files/chrony-3.5-r3-systemd-gentoo.patch12
-rw-r--r--net-misc/chrony/files/chronyd.conf2
5 files changed, 200 insertions, 29 deletions
diff --git a/net-misc/chrony/chrony-3.5-r3.ebuild b/net-misc/chrony/chrony-3.5-r3.ebuild
index 3f11f8dd951a..229f5b275068 100644
--- a/net-misc/chrony/chrony-3.5-r3.ebuild
+++ b/net-misc/chrony/chrony-3.5-r3.ebuild
@@ -12,8 +12,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="
- +adns caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc
- seccomp selinux
+ +adns +caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc
+ +seccomp selinux
"
REQUIRED_USE="
?? ( libedit readline )
@@ -42,7 +42,7 @@ S="${WORKDIR}/${P/_/-}"
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
- "${FILESDIR}"/${PN}-3.5-systemd-gentoo.patch
+ "${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
)
src_prepare() {
@@ -52,13 +52,20 @@ src_prepare() {
doc/* examples/* || die
# Copy for potential user fixup
- cp "${FILESDIR}"/chronyd.conf "$T"/chronyd.conf
+ cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+ cp examples/chronyd.service "${T}"/chronyd.service
# Set config for privdrop
if ! use caps; then
sed -i \
-e 's/-u ntp//' \
- "${T}"/chronyd.conf || die
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ fi
+
+ if ! use seccomp; then
+ sed -i \
+ -e 's/-F 1//' \
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
fi
}
@@ -135,16 +142,11 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_dounit examples/{chronyd,chrony-wait}.service
+ systemd_dounit "${T}"/chronyd.service
+ systemd_dounit examples/chrony-wait.service
systemd_enable_ntpunit 50-chrony chronyd.service
}
-pkg_preinst() {
- if use caps && has_version net-misc/chrony[-caps]; then
- elog "/run/chronyd needs ntp:ntp permissions; please check."
- elog "The safest option is reboot, but you may chown manually."
- elif ! use caps && has_version net-misc/chrony[caps]; then
- elog "/run/chronyd needs root:root permissions; please check."
- elog "The safest option is reboot, but you may chown manually."
- fi
+pkg_postinst() {
+ tmpfiles_process chronyd.conf
}
diff --git a/net-misc/chrony/chrony-4.0_pre1-r1.ebuild b/net-misc/chrony/chrony-4.0_pre1-r1.ebuild
new file mode 100644
index 000000000000..af44e0045233
--- /dev/null
+++ b/net-misc/chrony/chrony-4.0_pre1-r1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="https://chrony.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="
+ +adns +caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps readline +refclock +rtc
+ +seccomp +sechash selinux
+"
+REQUIRED_USE="
+ ?? ( libedit readline )
+ sechash? ( nettle )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ nettle? ( dev-libs/nettle )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+ seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="
+ ${CDEPEND}
+ caps? ( acct-group/ntp acct-user/ntp )
+ html? ( dev-ruby/asciidoctor )
+ pps? ( net-misc/pps-tools )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
+ "${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
+ doc/* examples/* || die
+
+ # Copy for potential user fixup
+ cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+ cp examples/chronyd.service "${T}"/chronyd.service
+
+ # Set config for privdrop
+ if ! use caps; then
+ sed -i \
+ -e 's/-u ntp//' \
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ fi
+
+ if ! use seccomp; then
+ sed -i \
+ -e 's/-F 1//' \
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local myconf=(
+ $(use_enable seccomp scfilter)
+ $(usex adns '' --disable-asyncdns)
+ $(usex caps '' --disable-linuxcaps)
+ $(usex cmdmon '' --disable-cmdmon)
+ $(usex ipv6 '' --disable-ipv6)
+ $(usex nettle '' --without-nettle)
+ $(usex ntp '' --disable-ntp)
+ $(usex phc '' --disable-phc)
+ $(usex pps '' --disable-pps)
+ $(usex refclock '' --disable-refclock)
+ $(usex rtc '' --disable-rtc)
+ $(usex sechash '' --disable-sechash)
+ ${CHRONY_EDITLINE}
+ ${EXTRA_ECONF}
+ --chronysockdir="${EPREFIX}/run/chrony"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --mandir="${EPREFIX}/usr/share/man"
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc/chrony"
+ --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
+ --without-nss
+ --without-tomcrypt
+ )
+
+ # print the ./configure call to aid in future debugging
+ echo bash ./configure "${myconf[@]}" >&2
+ bash ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake all docs $(usex html '' 'ADOC=true')
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
+ newconfd "${T}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ newtmpfiles - chronyd.conf <<<"d /run/chrony 0750 $(usex caps 'ntp ntp' 'root root')"
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+ systemd_dounit "${T}"/chronyd.service
+ systemd_dounit examples/chrony-wait.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}
+
+pkg_postinst() {
+ tmpfiles_process chronyd.conf
+}
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 5b03ec4fe426..543cabf61d5c 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -12,8 +12,8 @@ SLOT="0"
KEYWORDS=""
IUSE="
- +adns caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc
- seccomp selinux
+ +adns +caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc
+ +seccomp selinux
"
REQUIRED_USE="
?? ( libedit readline )
@@ -40,7 +40,7 @@ S="${WORKDIR}/${P/_/-}"
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
- "${FILESDIR}"/${PN}-3.5-systemd-gentoo.patch
+ "${FILESDIR}"/${PN}-3.5-r3-systemd-gentoo.patch
)
src_prepare() {
@@ -50,13 +50,20 @@ src_prepare() {
doc/* examples/* || die
# Copy for potential user fixup
- cp "${FILESDIR}"/chronyd.conf "$T"/chronyd.conf
+ cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+ cp examples/chronyd.service "${T}"/chronyd.service
# Set config for privdrop
if ! use caps; then
sed -i \
-e 's/-u ntp//' \
- "${T}"/chronyd.conf || die
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
+ fi
+
+ if ! use seccomp; then
+ sed -i \
+ -e 's/-F 1//' \
+ "${T}"/chronyd.conf "${T}"/chronyd.service || die
fi
}
@@ -131,16 +138,11 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_dounit examples/{chronyd,chrony-wait}.service
+ systemd_dounit "${T}"/chronyd.service
+ systemd_dounit examples/chrony-wait.service
systemd_enable_ntpunit 50-chrony chronyd.service
}
-pkg_preinst() {
- if use caps && has_version net-misc/chrony[-caps]; then
- elog "/run/chronyd needs ntp:ntp permissions; please check."
- elog "The safest option is reboot, but you may chown manually."
- elif ! use caps && has_version net-misc/chrony[caps]; then
- elog "/run/chronyd needs root:root permissions; please check."
- elog "The safest option is reboot, but you may chown manually."
- fi
+pkg_postinst() {
+ tmpfiles_process chronyd.conf
}
diff --git a/net-misc/chrony/files/chrony-3.5-r3-systemd-gentoo.patch b/net-misc/chrony/files/chrony-3.5-r3-systemd-gentoo.patch
new file mode 100644
index 000000000000..0ea3c921980b
--- /dev/null
+++ b/net-misc/chrony/files/chrony-3.5-r3-systemd-gentoo.patch
@@ -0,0 +1,12 @@
+--- a/examples/chronyd.service
++++ b/examples/chronyd.service
+@@ -8,8 +8,7 @@
+ [Service]
+ Type=forking
+ PIDFile=/run/chrony/chronyd.pid
+-EnvironmentFile=-/etc/sysconfig/chronyd
+-ExecStart=/usr/sbin/chronyd $OPTIONS
++ExecStart=/usr/sbin/chronyd -u ntp -F 1
+ PrivateTmp=yes
+ ProtectHome=yes
+ ProtectSystem=full
diff --git a/net-misc/chrony/files/chronyd.conf b/net-misc/chrony/files/chronyd.conf
index c641d985e562..c04f3525f0b7 100644
--- a/net-misc/chrony/files/chronyd.conf
+++ b/net-misc/chrony/files/chronyd.conf
@@ -9,4 +9,4 @@ CFGFILE="/etc/chrony/chrony.conf"
# The combination of "-s -r" allows chronyd to perform long term averaging of
# the gain or loss rate across system reboots and shutdowns.
-ARGS="-u ntp"
+ARGS="-u ntp -F 1"