summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-09-03 15:06:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-09-23 15:57:26 +0300
commit3c184492f29e585b4a0ca67ceafdf2372f9e5291 (patch)
treed54ab3d1995f3573013dcbf9d3c7aed2a5a2607d /net-misc
parentdev-perl/Crypt-OpenSSL-Random: Stabilize 0.170.0 ppc, #940149 (diff)
downloadgentoo-3c184492f29e585b4a0ca67ceafdf2372f9e5291.tar.gz
gentoo-3c184492f29e585b4a0ca67ceafdf2372f9e5291.tar.bz2
gentoo-3c184492f29e585b4a0ca67ceafdf2372f9e5291.zip
net-misc/httpie: add 3.2.3 fixing CVE-2023-48052
4 tests fail, like in 3.2.2 Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/httpie/Manifest1
-rw-r--r--net-misc/httpie/httpie-3.2.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/httpie/Manifest b/net-misc/httpie/Manifest
index 9e0e985fa467..3a5b01fbe23c 100644
--- a/net-misc/httpie/Manifest
+++ b/net-misc/httpie/Manifest
@@ -1,2 +1,3 @@
DIST httpie-3.2.1.gh.tar.gz 1276550 BLAKE2B 627aa3db762e9e407f882be2c4267f5227301b189695537e7ac69ff140d6d39292251e131f9b9e7761e904a736d112bb4c1f5c6708c1468c6309474ee8c140b6 SHA512 ffcf6050138c49d5acb01f214d9b3fee6c78502c4c6dc45a295bafc88aafd1789f97a69c922f6e093fb48a402c1f83a7fff5307849130df81c4bcb2d595a03bf
DIST httpie-3.2.2.gh.tar.gz 1279161 BLAKE2B aa5df73acbbe635fbfd3db458a2289042091a27d7b1791e9739874c1882e436814f74eec2b695f8acd76f9b9dd210f43dd9f8b7c0feea0cf4782b30f0e53b91a SHA512 5e95eba5a5ca8017dfd76ace525c57d2931d8918d51e84e8744eb9393cda5ae8e6cd6a1455c4aa82e50fa35edc35468a8b3582169c8f94858e61b09548cfa13d
+DIST httpie-3.2.3.gh.tar.gz 1279649 BLAKE2B 3404078512d9b61304560cf2226ed8837ab362f4627e73200d3379878f0ce52ca7c32160232f78544403cbe85d8ca6f5ad8f97d36fd04b1362d95d3e871581ab SHA512 0b44c15d42f73533a94f29e01c1465439cc937994deb8699135bcd56f77392ec0198c57d159f10295e3e0704dcdac486d6df4ce9f8478b914db300c92aaaf01d
diff --git a/net-misc/httpie/httpie-3.2.3.ebuild b/net-misc/httpie/httpie-3.2.3.ebuild
new file mode 100644
index 000000000000..ba88195f0cd2
--- /dev/null
+++ b/net-misc/httpie/httpie-3.2.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.io/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/httpie/cli/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/cli-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/multidict[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # https://github.com/httpie/cli/issues/1530
+ tests/test_compress.py::test_compress_form
+ tests/test_binary.py::TestBinaryResponseData
+
+ # Needs network
+ 'tests/test_cookie_on_redirects.py::test_explicit_user_set_cookie_in_session[remote_httpbin]'
+ 'tests/test_cookie_on_redirects.py::test_explicit_user_set_cookie[remote_httpbin]'
+ 'tests/test_cookie_on_redirects.py::test_explicit_user_set_headers[False-remote_httpbin]'
+ 'tests/test_cookie_on_redirects.py::test_explicit_user_set_headers[True-remote_httpbin]'
+ tests/test_cookie_on_redirects.py::test_saved_session_cookie_pool
+ tests/test_cookie_on_redirects.py::test_saved_session_cookies_on_different_domain
+ 'tests/test_cookie_on_redirects.py::test_saved_session_cookies_on_redirect[httpbin-httpbin-remote_httpbin-False]'
+ 'tests/test_cookie_on_redirects.py::test_saved_session_cookies_on_redirect[httpbin-remote_httpbin-httpbin-True]'
+ 'tests/test_cookie_on_redirects.py::test_saved_session_cookies_on_redirect[httpbin-remote_httpbin-remote_httpbin-False]'
+ 'tests/test_cookie_on_redirects.py::test_saved_user_set_cookie_in_session[remote_httpbin]'
+ 'tests/test_sessions.py::test_secure_cookies_on_localhost[remote_httpbin-expected_cookies1]'
+ tests/test_tokens.py::test_verbose_chunked
+ tests/test_uploads.py::test_chunked_form
+ tests/test_uploads.py::test_chunked_json
+ tests/test_uploads.py::test_chunked_raw
+ tests/test_uploads.py::test_chunked_stdin
+ tests/test_uploads.py::test_chunked_stdin_multiple_chunks
+ tests/test_uploads.py::TestMultipartFormDataFileUpload::test_multipart_chunked
+ tests/test_uploads.py::TestRequestBodyFromFilePath::test_request_body_from_file_by_path_chunked
+)
+
+EPYTEST_IGNORE=(
+ # Assumes installation in a clean venv
+ tests/test_plugins_cli.py
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}