summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmas Spann <zappel@simple-co.de>2024-08-01 00:04:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-01 00:13:27 +0200
commit1d56842c5963b4e1902ce5097d0603012d2ad987 (patch)
tree62fdb34b53b8a8d57e44453f97d44861e6b63025 /net-misc
parentnet-vpn/fp: fix drop empty IUSE (diff)
downloadgentoo-1d56842c5963b4e1902ce5097d0603012d2ad987.tar.gz
gentoo-1d56842c5963b4e1902ce5097d0603012d2ad987.tar.bz2
gentoo-1d56842c5963b4e1902ce5097d0603012d2ad987.zip
net-misc/croc: add 10.0.11
Signed-off-by: Armas Spann <zappel@simple-co.de> Closes: https://github.com/gentoo/gentoo/pull/37890 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-10.0.11.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index cb05f3bc5710..2d6f4f30c518 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,3 +1,5 @@
+DIST croc-10.0.11-deps.tar.xz 41579476 BLAKE2B 2323f1886cb8c4c6f11d406f97ff420c38af185e65572e2c9e37d3095eee1909253c73aec1bcc9015c87b06648e9a1f5ea5818492c3f1c96962944175c5f89db SHA512 5fe825a66ce745eff41c77643c594ad3406d25e8079405b34110d96dc33ac015dd68528071d8354bb44fdf68247915365f530ccc10743d014e4d6bf96d1803b9
+DIST croc-10.0.11.tar.gz 575860 BLAKE2B cd0c43adcf509edb009a28ba7bfc871a6280e8ce4d4f529502ee2ff1547e957e551ea8184ff24c1097050cc7fd449f399b2849c4803b27d82b5b1e72bde5c9f1 SHA512 1cdfc5823e29406ec92ad4b24526e30032b89787d77382a0179c558cb2f0dd99556d93c7523ebfbb1dd4cac15ec596b3ddd0ce58ac5b9491f34b94436a20fbef
DIST croc-9.6.15-deps.tar.xz 30217856 BLAKE2B 87c34fa60f0bda194ca022648be2ce11da7b4b9a3f3a5f5b16a5127d5b25197ec99bdba1ef388c38b9e632ed4ef0f89a68e3b58368d9df7b07a1f3129b2b9145 SHA512 caa944dc9e8fb0d4883f4447c979282826e2364fe8b196e412861189953c23a09b6de38306aa00eabfeeb12fb4d3ab9e9794494da8ece10c3ee5a0cd72161d17
DIST croc-9.6.15.tar.gz 512614 BLAKE2B 2a87593b5d944c2b5ea970d30f0b64b2a8325cca672421aaa58e6fd07e440aad88de6acad564fcb9963256a9f499421dd9343f51395babd724deeffe875cc6f7 SHA512 8ae76dc5029e7adc809b0083e147c57c7249e9fbb07f263a0b10d21539ebfc69c5d9d8e60811cca06bbb313ec9a3a143baaef73f77ca599dc102626dc9fccf29
DIST croc-9.6.17-deps.tar.xz 29935608 BLAKE2B 1bdcd2e86f09f3a112faa9f671705a5cabb3f6d9037ba71f0947ee2ce3863d840a8e6847167017c7e02de422900bfbfc8ca285933dd23b95a4232e67c0e30c50 SHA512 0787600d6ca9d46da1e66b27e5f3cc2c88020fa8bb9119c1455209680eb886245f05a7650727759f7624ec59e4b4cec7910f58e83b79d0f87b26375de17b13b2
diff --git a/net-misc/croc/croc-10.0.11.ebuild b/net-misc/croc/croc-10.0.11.ebuild
new file mode 100644
index 000000000000..edfe827fbac5
--- /dev/null
+++ b/net-misc/croc/croc-10.0.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -skip "Test(Comm|Send|PublicIP|LocalIP)" -work ./...
+}