summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/tiers
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/tiers')
-rw-r--r--net-misc/tiers/Manifest2
-rw-r--r--net-misc/tiers/files/tiers-1.1-gcc43.patch118
-rw-r--r--net-misc/tiers/files/tiers1.1-gccfixes.patch201
-rw-r--r--net-misc/tiers/metadata.xml7
-rw-r--r--net-misc/tiers/tiers-1.1.ebuild49
5 files changed, 377 insertions, 0 deletions
diff --git a/net-misc/tiers/Manifest b/net-misc/tiers/Manifest
new file mode 100644
index 000000000000..a2bbb90e196f
--- /dev/null
+++ b/net-misc/tiers/Manifest
@@ -0,0 +1,2 @@
+DIST tiers1.1.tar.gz 392532 SHA256 d7c44866fdfa70efe22f69942e1624ffeaa4ba1be47e335f8422f1b50a18c017 SHA512 b72a98aeeb3e1799536e1424e8f60bffcef59c61cc709232a670174c80d23fb4c3b60249c7ff2a33442b62b81a493b7ecef4bf0e950147fa8fe81bb9eabb9a08 WHIRLPOOL fbfbe71652239c2ca664340814b883187c037634012aa21ae4c4fb456185b2215dc97a3b5c03c017014f2fe5566dafece520a81f3a5483dcf238ffafd2245eaf
+DIST tiers2ns-lan.awk 3258 SHA256 675540db87c0ab24fb1a0b67fdd48d6b981de5d1bcb2da808ca69ed29d4bf583 SHA512 562204765e0e7c973e6d88c494e5aba9cd47d79c68309359cd232c34be6175f727411a64a6033a246a042987f1ad423008857eaf25c6254bd006c4a3ff4d083e WHIRLPOOL 4533e6811c783307e20d796d95c7aa0cd3adca7729ca24b001a1a6cb65c620e13c0a81fe28ead3a80ad5d317d893684579dabc567296a217842df835a7de13ab
diff --git a/net-misc/tiers/files/tiers-1.1-gcc43.patch b/net-misc/tiers/files/tiers-1.1-gcc43.patch
new file mode 100644
index 000000000000..4f167daf13ce
--- /dev/null
+++ b/net-misc/tiers/files/tiers-1.1-gcc43.patch
@@ -0,0 +1,118 @@
+--- tiers1.1b/src/tiers_create.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_create.cc 2009-01-21 03:57:39.000000000 -0400
+@@ -16,7 +16,7 @@
+ //////////////////////////////////////////////////////////////////////////////
+
+ // tiers.cc
+-#include <iostream.h>
++#include <iostream>
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers.cc 2009-01-21 03:57:22.000000000 -0400
+@@ -17,8 +17,9 @@
+
+ // tiers.cc
+
+-#include <iostream.h>
+-#include <limits.h>
++#include <iostream>
++#include <cstdlib>
++#include <climits>
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_misc.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_misc.cc 2009-01-21 04:07:21.000000000 -0400
+@@ -16,9 +16,9 @@
+ //////////////////////////////////////////////////////////////////////////////
+
+ // tiers_misc.cc
+-#include <iostream.h>
+-#include <math.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <cmath>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_main.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_main.cc 2009-01-21 04:08:13.000000000 -0400
+@@ -17,9 +17,9 @@
+
+ // tiers_main.cc
+
+-#include <iostream.h>
+-#include <stdlib.h> // for strtoul
+-#include <math.h> // for random
++#include <iostream>
++#include <cstdlib> // for strtoul
++#include <cmath> // for random
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_output.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_output.cc 2009-01-21 04:00:09.000000000 -0400
+@@ -17,7 +17,7 @@
+
+ // tiers_output.cc
+
+-#include <iostream.h>
++#include <iostream>
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+ #endif
+--- tiers1.1b/src/tiers_output_gnuplot.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_output_gnuplot.cc 2009-01-21 04:00:39.000000000 -0400
+@@ -17,7 +17,7 @@
+
+ // tiers_output_gnuplot.cc
+
+-#include <iostream.h>
++#include <iostream>
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+ #endif
+--- tiers1.1b/src/tiers_prims.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_prims.cc 2009-01-21 04:10:24.000000000 -0400
+@@ -17,9 +17,9 @@
+
+ // tiers_prims.cc
+
+-#include <iostream.h>
+-#include <math.h> // for random
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <cmath> // for random
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_red_intra.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_red_intra.cc 2009-01-21 04:01:21.000000000 -0400
+@@ -17,8 +17,8 @@
+
+ // tiers_red_intra.cc
+
+-#include <iostream.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_red_inter.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_red_inter.cc 2009-01-21 04:01:46.000000000 -0400
+@@ -17,8 +17,8 @@
+
+ // tiers_red_inter.cc
+
+-#include <iostream.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
diff --git a/net-misc/tiers/files/tiers1.1-gccfixes.patch b/net-misc/tiers/files/tiers1.1-gccfixes.patch
new file mode 100644
index 000000000000..db340cad1f04
--- /dev/null
+++ b/net-misc/tiers/files/tiers1.1-gccfixes.patch
@@ -0,0 +1,201 @@
+diff -urN tiers1.1/src/Makefile tiers1.1.new/src/Makefile
+--- tiers1.1/src/Makefile 1997-07-12 23:22:30.000000000 -0700
++++ tiers1.1.new/src/Makefile 2004-01-11 04:56:33.000000000 -0800
+@@ -31,7 +31,9 @@
+ # flags
+ #
+ #FLAGS= -fconserve-space -fno-inline -Wall -Winline -Wpointer-arith -g -DDEBUG
+-FLAGS= -g -fconserve-space
++FLAGS = $(CFLAGS) -fPIC #-g -fconserve-space
++CONFIGFILE = ./tiers_config
++FLAGS += -DCONFIGFILE="\"$(CONFIGFILE)\""
+
+ #
+ # tools
+diff -urN tiers1.1/src/tiers.cc tiers1.1.new/src/tiers.cc
+--- tiers1.1/src/tiers.cc 1997-03-04 13:54:18.000000000 -0800
++++ tiers1.1.new/src/tiers.cc 2004-01-11 04:56:33.000000000 -0800
+@@ -24,6 +24,7 @@
+ #include "tiers.hh"
+ #endif
+
++#include "tiers_vars.hh"
+
+
+ ////////////////////////////////////////////////////////////////////////
+@@ -506,4 +507,3 @@
+ }
+
+ // end of file
+-
+diff -urN tiers1.1/src/tiers.hh tiers1.1.new/src/tiers.hh
+--- tiers1.1/src/tiers.hh 1998-01-12 02:10:46.000000000 -0800
++++ tiers1.1.new/src/tiers.hh 2004-01-11 04:56:33.000000000 -0800
+@@ -20,6 +20,8 @@
+ #ifndef _TIERS_HH
+ #define _TIERS_HH
+
++using namespace std;
++
+
+ ////////////////////////////////////////////////////////////////////////
+ // Model
+@@ -264,46 +266,46 @@
+ // Defined in tiers_config.cc
+
+ // Type of output produced by the model, e.g. Model::GENERIC, Model::GNUPLOT
+-Model::OpType OP_TYPE;
++extern Model::OpType OP_TYPE;
+
+ // If set, TIERS_VERBOSE causes the output to contain the
+ // parameters used to generate the model and helpful headings
+ // If undefined, the output is a simple list of nodes and edges
+-bool TIERS_VERBOSE;
++extern bool TIERS_VERBOSE;
+
+ // If set, TIERS_LABEL_XXX causes the output to contain a label for
+ // each of the nodes of type XXX
+-bool TIERS_LABEL_WAN;
+-bool TIERS_LABEL_MAN;
+-bool TIERS_LABEL_LAN;
++extern bool TIERS_LABEL_WAN;
++extern bool TIERS_LABEL_MAN;
++extern bool TIERS_LABEL_LAN;
+
+
+ // If defined as true, the operation of the model is more verbose
+ // If undefined, the model should run with no debugging output
+-bool TIERS_DEBUG;
++extern bool TIERS_DEBUG;
+
+ // If defined as true, then an undirected list of edges is produced in the
+ // output, i.e. the edges (i,j) and (j,i) only appear once in the output
+ // Note that all LAN edges are assumed bidirectional
+-bool REMOVE_DUP_EDGES;
++extern bool REMOVE_DUP_EDGES;
+
+ // Set these true to apply proxmity tests to nodes in each network type
+-bool PROXIMITY_TEST_WAN;
+-bool PROXIMITY_TEST_MAN;
+-bool PROXIMITY_TEST_LAN;
++extern bool PROXIMITY_TEST_WAN;
++extern bool PROXIMITY_TEST_MAN;
++extern bool PROXIMITY_TEST_LAN;
+
+ // The size of a unit in WAN, MAN and LAN grids
+ // e.g. 1000km, 1km, 1m would be best, but the current values fit with
+ // typical int sizes
+-unsigned long int WAN_SCALE;
+-unsigned long int MAN_SCALE;
+-unsigned long int LAN_SCALE;
++extern unsigned long int WAN_SCALE;
++extern unsigned long int MAN_SCALE;
++extern unsigned long int LAN_SCALE;
+
+ // GRID is the size of the square grid on which points are placed
+-unsigned long int GRID;
++extern unsigned long int GRID;
+
+ // The comment character for output
+-char COM;
++extern char COM;
+
+
+ //
+@@ -311,13 +313,13 @@
+ //
+
+ // The output directory for results from gnuplot
+-char *title;
++extern char *title;
+
+ // The title for results from gnuplot
+-char *outputdir;
++extern char *outputdir;
+
+ // Create a unique identifier for each model
+-long int ModelId;
++extern long int ModelId;
+
+ // Forward declaration
+ unsigned long int max(unsigned long int A, unsigned long int B);
+diff -urN tiers1.1/src/tiers_config.cc tiers1.1.new/src/tiers_config.cc
+--- tiers1.1/src/tiers_config.cc 1997-07-13 02:55:53.000000000 -0700
++++ tiers1.1.new/src/tiers_config.cc 2004-01-11 04:58:36.000000000 -0800
+@@ -17,7 +17,8 @@
+
+ // tiers_config.cc
+
+-#include <fstream.h> // for ifstream
++#include <fstream> // for ifstream
++#include <iostream> // for ifstream
+ #include <string.h> // for strcpy
+ #include <stdlib.h> // for strtoul
+
+@@ -36,10 +37,13 @@
+ {
+ bool ret = true;
+
+- ifstream config_file("./tiers_config");
++#ifndef CONFIGFILE
++#error You need to define CONFIGFILE on the commandline
++#endif
++ ifstream config_file(CONFIGFILE);
+ if (!config_file)
+ {
+- cerr << "Tiers:: cannot open file './tiers_config'" << endl;
++ cerr << "Tiers:: cannot open file '" << CONFIGFILE << "'" << endl;
+ }
+
+ // Read the contents of the file in, skipping blank lines or lines which
+diff -urN tiers1.1/src/tiers_main.cc tiers1.1.new/src/tiers_main.cc
+--- tiers1.1/src/tiers_main.cc 1997-07-06 00:58:31.000000000 -0700
++++ tiers1.1.new/src/tiers_main.cc 2004-01-11 04:56:33.000000000 -0800
+@@ -25,11 +25,11 @@
+ #include "tiers.hh"
+ #endif
+
+-extern "C"
+-{
+- long int time(int dummy);
+- char * initstate(unsigned seed, char *state, int n);
+-}
++//extern "C"
++//{
++// long int time(int dummy);
++// char * initstate(unsigned seed, char *state, int n);
++//}
+
+ unsigned long int NW; // maximum number of WANs, currently 1
+ unsigned long int NM; // maximum number of MANs per WAN
+@@ -63,7 +63,7 @@
+ cout.setf( ios::unitbuf );
+
+ // TIERS_VERBOSE
+-#ifdef 0
++#ifdef FALSE
+ cout << "Main:: Processing arguments. Arguments are:"
+ << endl;
+ for (int i = 0; i < argc; i++)
+diff -urN tiers1.1/src/tiers_vars.hh tiers1.1.new/src/tiers_vars.hh
+--- tiers1.1/src/tiers_vars.hh 1969-12-31 16:00:00.000000000 -0800
++++ tiers1.1.new/src/tiers_vars.hh 2004-01-11 04:56:33.000000000 -0800
+@@ -0,0 +1,18 @@
++Model::OpType OP_TYPE;
++bool TIERS_VERBOSE;
++bool TIERS_LABEL_WAN;
++bool TIERS_LABEL_MAN;
++bool TIERS_LABEL_LAN;
++bool TIERS_DEBUG;
++bool REMOVE_DUP_EDGES;
++bool PROXIMITY_TEST_WAN;
++bool PROXIMITY_TEST_MAN;
++bool PROXIMITY_TEST_LAN;
++unsigned long int WAN_SCALE;
++unsigned long int MAN_SCALE;
++unsigned long int LAN_SCALE;
++unsigned long int GRID;
++char COM;
++char *title;
++char *outputdir;
++long int ModelId;
diff --git a/net-misc/tiers/metadata.xml b/net-misc/tiers/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/net-misc/tiers/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/tiers/tiers-1.1.ebuild b/net-misc/tiers/tiers-1.1.ebuild
new file mode 100644
index 000000000000..6bad16f7a604
--- /dev/null
+++ b/net-misc/tiers/tiers-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Random network topography generator"
+HOMEPAGE="http://www.isi.edu/nsnam/ns/ns-topogen.html#tiers"
+SRC_URI="http://www.isi.edu/nsnam/dist/topogen/${MY_P}.tar.gz
+ http://www.isi.edu/nsnam/dist/topogen/tiers2ns-lan.awk"
+
+LICENSE="mapm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+RDEPEND="virtual/awk
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${MY_P}-gccfixes.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -e '1a\#!/bin/sh' -e '1d' -e "s|-f |-f /usr/share/${PN}/|g" -i "${S}"/bin/strip4gnuplot3.5
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake CFLAGS="${CFLAGS}" CONFIGFILE="/etc/tiers-gnuplot.conf" EXEC="../bin/tiers-gnuplot" || die
+ # cleanup for a sec
+ rm *.o
+ emake CFLAGS="${CFLAGS}" CONFIGFILE="/etc/tiers.conf" EXEC="../bin/tiers" || die
+}
+
+src_install() {
+ dobin bin/tiers bin/tiers-gnuplot bin/strip4gnuplot3.5
+ insinto /etc
+ newins src/tiers_config.generic tiers.conf
+ newins src/tiers_config.gnuplot tiers-gnuplot.conf
+ insinto /usr/share/${PN}
+ doins bin/*.awk "${DISTDIR}"/tiers2ns-lan.awk
+ dodoc CHANGES COPYRIGHT README docs/*
+}