summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-24 00:39:23 +0100
committerSam James <sam@gentoo.org>2023-07-24 00:39:46 +0100
commit9320ad28319122fa54745533724a793be777d3d3 (patch)
tree463f199b06c353107e12f9dbdbc1edc35fb77347 /net-misc/streamlink/streamlink-9999.ebuild
parentdev-util/diffoscope: add 245 (diff)
downloadgentoo-9320ad28319122fa54745533724a793be777d3d3.tar.gz
gentoo-9320ad28319122fa54745533724a793be777d3d3.tar.bz2
gentoo-9320ad28319122fa54745533724a793be777d3d3.zip
net-misc/streamlink: add 6.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 6c6140e9a8da..7d0a43ab5bbb 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
@@ -28,13 +28,15 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
dev-python/certifi[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
@@ -50,6 +52,7 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
)
')