summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-01-19 23:34:58 +0100
committerPatrice Clement <monsieurp@gentoo.org>2021-01-20 00:09:20 +0100
commita5260d2d5ca5dacfbe4793bfba1a05db654bb67a (patch)
tree524f20d82abdf7bddad32f8b400bbdd3201a8776 /net-misc/spiped
parentapp-misc/tmux-xpanes: version bump. (diff)
downloadgentoo-a5260d2d5ca5dacfbe4793bfba1a05db654bb67a.tar.gz
gentoo-a5260d2d5ca5dacfbe4793bfba1a05db654bb67a.tar.bz2
gentoo-a5260d2d5ca5dacfbe4793bfba1a05db654bb67a.zip
net-misc/spiped: version bump.
Closes: https://bugs.gentoo.org/744091 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/Manifest1
-rw-r--r--net-misc/spiped/spiped-1.6.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/spiped/Manifest b/net-misc/spiped/Manifest
index 70597cde5b7f..9946dbce1cca 100644
--- a/net-misc/spiped/Manifest
+++ b/net-misc/spiped/Manifest
@@ -1 +1,2 @@
DIST spiped-1.6.0.tgz 94431 BLAKE2B e994115d5080e4f41d57d3ef88223c7dca373320266a3fe4f0420fb7aef6ecf329fad5a409ec31f53caaeb22d86d0c3a48060758ceee28d011676a12124fc057 SHA512 9bca8e7da31b86f956a653279f9346d8270a7e28a07d30b4a7104b21fbfbd1a81410e6a7dc0827127331a8f10226d5b8d2ddaacb94c9f76ecc6d15d728ead27a
+DIST spiped-1.6.1.tgz 115055 BLAKE2B d9ee65c10b183cc8d5451adeb65a728052378811e71ee40d7e6f121c00b6003d4b21cc9402b424aac15d115cdbdc158207ef3e6c60b93fab2a4ba63257fd2f1d SHA512 ec69cb49a19e4e5705526ec74ee683ac3923412bc5ca3a45fc8268699367421cd37354ccc03c18c2d48f06cdb8a4c4bce3ef3b60934997c6770547e02e6f66ae
diff --git a/net-misc/spiped/spiped-1.6.1.ebuild b/net-misc/spiped/spiped-1.6.1.ebuild
new file mode 100644
index 000000000000..c1cc245241ab
--- /dev/null
+++ b/net-misc/spiped/spiped-1.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+# Some tests fail.
+RESTRICT="test"
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}