summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-10-28 06:02:52 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-10-28 06:02:52 -0400
commit171a42c5910c1531868c991cea4e609311d45907 (patch)
tree44193545a357e4e6ba91e58647170eef470ab101 /net-misc/ipv6calc
parentnet-vpn/tor: version bumps to 0.4.6.8 and 0.4.7.2_alpha (diff)
downloadgentoo-171a42c5910c1531868c991cea4e609311d45907.tar.gz
gentoo-171a42c5910c1531868c991cea4e609311d45907.tar.bz2
gentoo-171a42c5910c1531868c991cea4e609311d45907.zip
net-misc/ipv6calc: version bump to 4.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-misc/ipv6calc')
-rw-r--r--net-misc/ipv6calc/Manifest1
-rw-r--r--net-misc/ipv6calc/ipv6calc-4.0.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/Manifest b/net-misc/ipv6calc/Manifest
index 85b5e43e4d75..5ec106f6042f 100644
--- a/net-misc/ipv6calc/Manifest
+++ b/net-misc/ipv6calc/Manifest
@@ -1,3 +1,4 @@
DIST ipv6calc-2.2.0.tar.gz 1546946 BLAKE2B 90dc600c1e83affd6138bfc73ac77160e35d2f745213059ed2b0f36d7a9049a7a659d0419e6f684661247c7714d3e9886fe0a6782f5dd35895c46f2583310dcd SHA512 6e9acde56e245ffae0903305659881eb763524336da285d5048b655728c7d7b031ae7b4190f01f663e3d7134defbb8987c8f47ddd75bf8c8368ec1b918ee42e3
DIST ipv6calc-3.1.1.tar.gz 1634300 BLAKE2B 941df0c0d649cf5879e1abfde1e4c0f41fcdbe4cb945552df42b9a39ec317dda7e25c85711f103e024bc3774e46f52d3754e6e0b004b098baeac3d863d3ec38e SHA512 0cf726fec47a592168bb0715dd96c16033fe85e1c462530ef6898236cf89199fede81a9ffc78b3210c9e007da03279c7d45aa00a7a9a7f00f5f9bc82b7cc1695
DIST ipv6calc-3.2.0.tar.gz 1645414 BLAKE2B b74406a867b03e22244c1890133ce9553c40b5a737bd1711783e94b7f3afc43cfcff26e12583552a4c0fcc9ecd51174fb20844bddac22732d08e995de9e0f5ef SHA512 f7cd3d8820acd06c016e6f439129516d61300ba1660fe3acfec319f4dbd73de77f0a339bef31fd42bb0a4ab2e68d0e4771b1526f3217d3504cb4605d7b9b0195
+DIST ipv6calc-4.0.0.tar.gz 1682616 BLAKE2B 5a26f6c4c8a9a2ea49c8762690c18e523ebde370817e71ae56f1cda211324695f046e85bba56f0b19e17869d72adb0ee8739fdbd4e8c4503d4a286107212eda4 SHA512 939dfcbe68c6e110acfe23f6f221471bda03ad165f5785bbc9aabd03b3192ab3cdb99df458db79edfa3c3d2f3202f1f2f189b7a9fd9a5ae27a7084de2fbd907d
diff --git a/net-misc/ipv6calc/ipv6calc-4.0.0.ebuild b/net-misc/ipv6calc/ipv6calc-4.0.0.ebuild
new file mode 100644
index 000000000000..42eca99cbb18
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-4.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="https://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="https://github.com/pbiering/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="geoip test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:=
+ geoip? ( >=dev-libs/geoip-1.4.7 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Digest-SHA1 )
+"
+
+#dev-perl/URI is needed for web interface, that is not installed now
+
+src_configure() {
+ # These options are broken. You can't disable them. That's
+ # okay because we want then force enabled.
+ # --disable-db-as-registry
+ # --disable-db-cc-registry
+ if use geoip; then
+ myconf=$(use_enable geoip)
+ myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ fi
+ econf \
+ --disable-bundled-getopt \
+ --disable-bundled-md5 \
+ --enable-shared \
+ --enable-dynamic-load \
+ --enable-db-ieee \
+ --enable-db-ipv4 \
+ --enable-db-ipv6 \
+ --disable-dbip \
+ --disable-dbip2 \
+ --disable-external \
+ --disable-ip2location \
+ ${myconf}
+}
+
+src_compile() {
+ emake distclean
+ # Disable default CFLAGS (-O2 and -g)
+ emake DEFAULT_CFLAGS=""
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]]; then
+ # Disable tests that fail as root
+ echo true > ipv6logstats/test_ipv6logstats.sh
+ fi
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog CREDITS README TODO USAGE
+}