summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/gns3-server
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/gns3-server')
-rw-r--r--net-misc/gns3-server/Manifest2
-rw-r--r--net-misc/gns3-server/gns3-server-1.3.2.ebuild44
-rw-r--r--net-misc/gns3-server/gns3-server-1.3.3.ebuild38
-rw-r--r--net-misc/gns3-server/metadata.xml11
4 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/gns3-server/Manifest b/net-misc/gns3-server/Manifest
new file mode 100644
index 000000000000..e7199bd11c24
--- /dev/null
+++ b/net-misc/gns3-server/Manifest
@@ -0,0 +1,2 @@
+DIST gns3-server-1.3.2.tar.gz 173570 SHA256 771dafcc9f437dd20c09cde9fbde63e301b6f263925de9abf186727a721123f8 SHA512 6913e50fadaa0b8cc814e1907c5c5d6d7c90aa1e75cdbcb74c7b6f69fdabf61c5baab856fe741241749840df17e8b7d9d502da1406b0806777fb922c4ac82928 WHIRLPOOL e35e7bff085018a391c97fe35180ed1419472f914c169deaa288cd98146bdcd82d9b8acd97db5fc7ea4f5b60e24dab9ae1a67314bfbaa5120ebacbaa978cabde
+DIST gns3-server-1.3.3.tar.gz 175790 SHA256 b2f493a4db42d6170dddd8f5baee1c075e3c5cae803b405bfbf2d2e1b0e56f65 SHA512 11af84864bc40a83af9b7a63abd3e2eaf5f6197755e49b3b1284cf7cf71bf0e3963d5e96a7f2410bc3b89087812069cabbc5c7653c5534463518d26250512d6c WHIRLPOOL 71a3cfea286cc5e657a464617609eca63dab119cceb56aaf99c45dca33300fa7570cd025e4f9717e36aec310b66bec4d41b2da5327a7e17807eab02c942efd76
diff --git a/net-misc/gns3-server/gns3-server-1.3.2.ebuild b/net-misc/gns3-server/gns3-server-1.3.2.ebuild
new file mode 100644
index 000000000000..44a863b107ce
--- /dev/null
+++ b/net-misc/gns3-server/gns3-server-1.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emulation/dynamips-0.2.12
+ >=dev-python/aiohttp-0.14.4[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
+ >=dev-python/raven-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # avoid file collisions caused by required tests
+ sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ ewarn "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
+ ewarn ""
+ ewarn "The following is a list of packages that can be added:"
+ ewarn "app-emulation/qemu, app-emulation/virtualbox, and net-analyzer/wireshark"
+ ewarn ""
+ ewarn "The following packages are currently unsupported:"
+ ewarn "iouyap and vpcs"
+}
diff --git a/net-misc/gns3-server/gns3-server-1.3.3.ebuild b/net-misc/gns3-server/gns3-server-1.3.3.ebuild
new file mode 100644
index 000000000000..3e96af493bb9
--- /dev/null
+++ b/net-misc/gns3-server/gns3-server-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emulation/dynamips-0.2.12
+ >=dev-python/aiohttp-0.14.4[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
+ >=dev-python/raven-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ ewarn "net-misc/gns3-server has several optional packages that must be merged manually for additional functionality."
+ ewarn ""
+ ewarn "The following is a list of packages that can be added:"
+ ewarn "app-emulation/qemu, app-emulation/virtualbox, and net-analyzer/wireshark"
+ ewarn ""
+ ewarn "The following packages are currently unsupported:"
+ ewarn "iouyap and vpcs"
+}
diff --git a/net-misc/gns3-server/metadata.xml b/net-misc/gns3-server/metadata.xml
new file mode 100644
index 000000000000..6553eda3e508
--- /dev/null
+++ b/net-misc/gns3-server/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">GNS3/gns3-server</remote-id>
+ </upstream>
+</pkgmetadata>