summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-08 20:17:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-08 20:17:50 +0100
commit2e6db7aca3449f4e15bbe917a0eacbe1859a8dbb (patch)
treee85cc11bc00f598a9d6ce45579d1e34212656725 /net-misc/dhcpcd
parenttmpfiles.eclass: add eapi 7 support (diff)
downloadgentoo-2e6db7aca3449f4e15bbe917a0eacbe1859a8dbb.tar.gz
gentoo-2e6db7aca3449f4e15bbe917a0eacbe1859a8dbb.tar.bz2
gentoo-2e6db7aca3449f4e15bbe917a0eacbe1859a8dbb.zip
net-misc/dhcpcd: Revbump to fix USE="-ipv6" build.
Closes: https://bugs.gentoo.org/677508 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/dhcpcd-7.1.1-r1.ebuild (renamed from net-misc/dhcpcd/dhcpcd-7.1.1.ebuild)4
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-7.1.1-disable_inet6_fix.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-7.1.1.ebuild b/net-misc/dhcpcd/dhcpcd-7.1.1-r1.ebuild
index 48ba26275d0c..c8f7876e7813 100644
--- a/net-misc/dhcpcd/dhcpcd-7.1.1.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-7.1.1-r1.ebuild
@@ -27,6 +27,10 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-disable_inet6_fix.patch #677508
+)
+
src_configure() {
local dev hooks=() rundir
use udev || dev="--without-dev --without-udev"
diff --git a/net-misc/dhcpcd/files/dhcpcd-7.1.1-disable_inet6_fix.patch b/net-misc/dhcpcd/files/dhcpcd-7.1.1-disable_inet6_fix.patch
new file mode 100644
index 000000000000..2fd3a17428fa
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-7.1.1-disable_inet6_fix.patch
@@ -0,0 +1,24 @@
+From 6db54edd1427823dcb3924be78c042915a825fb1 Mon Sep 17 00:00:00 2001
+From: Chris Clayton <chris2553@googlemail.com>
+Date: Fri, 8 Feb 2019 16:35:36 +0000
+Subject: fix build with --disable-inet6
+
+---
+ src/dhcpcd.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/dhcpcd.c b/src/dhcpcd.c
+index a2cd04e..6fe60ea 100644
+--- a/src/dhcpcd.c
++++ b/src/dhcpcd.c
+@@ -54,6 +54,7 @@ const char dhcpcd_copyright[] = "Copyright (c) 2006-2019 Roy Marples";
+ #include "dev.h"
+ #include "dhcp-common.h"
+ #include "dhcpcd.h"
++#include "dhcp.h"
+ #include "dhcp6.h"
+ #include "duid.h"
+ #include "eloop.h"
+--
+cgit v1.1
+