summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmas Spann <zappel@simple-co.de>2024-04-23 03:44:44 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-23 09:30:32 +0200
commitacb866495beff66bbe4bb560849a78c29d49b0cd (patch)
tree4bec429a5aab0be048c8362834015ac952c0888c /net-misc/croc
parentdev-python/bitstring: Add dev-python/hypothesis test dep (diff)
downloadgentoo-acb866495beff66bbe4bb560849a78c29d49b0cd.tar.gz
gentoo-acb866495beff66bbe4bb560849a78c29d49b0cd.tar.bz2
gentoo-acb866495beff66bbe4bb560849a78c29d49b0cd.zip
net-misc/croc: add 9.6.15
Signed-off-by: Armas Spann <zappel@simple-co.de> Closes: https://github.com/gentoo/gentoo/pull/36369 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/croc')
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-9.6.15.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index ed22cba32e44..4cb624145256 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,4 +1,6 @@
DIST croc-9.6.13-vendor.tar.xz 975216 BLAKE2B af70a58b6ae553029ff3c9b0e58c90d5d46ad7b9480e2fb7dd18a92c2b04854a68fde243b0dd149fdc7eba2c267e093510a93f63110f7fe073b25c95361e3d40 SHA512 f1200882ec634971c7c84b313d3a5bb2af533ef500f715d2908046fb9c481ec48fbda3cbb4a2ff93694fc19821a0e62e287b42b578aeca8ec19a3418c0b7bae0
DIST croc-9.6.13.tar.gz 512627 BLAKE2B a3bf8f844a68af6ef3fc23d82168b70c92fa26485a5bf76b6ea6a4b21b2a328e7318edcd5d38ac860bd5c1fb29c3ddf01583ce9b6bef0f2d7bf98b224f683552 SHA512 c0734f7f73d6bb4eac2558733d0d04d9793760e24b02a12fbadef5a67f88be4d9f2036933a6881c8da613a6c2d47b529b5a40e02830eff7f99319059cb0b61fe
+DIST croc-9.6.15-deps.tar.xz 30217856 BLAKE2B 87c34fa60f0bda194ca022648be2ce11da7b4b9a3f3a5f5b16a5127d5b25197ec99bdba1ef388c38b9e632ed4ef0f89a68e3b58368d9df7b07a1f3129b2b9145 SHA512 caa944dc9e8fb0d4883f4447c979282826e2364fe8b196e412861189953c23a09b6de38306aa00eabfeeb12fb4d3ab9e9794494da8ece10c3ee5a0cd72161d17
+DIST croc-9.6.15.tar.gz 512614 BLAKE2B 2a87593b5d944c2b5ea970d30f0b64b2a8325cca672421aaa58e6fd07e440aad88de6acad564fcb9963256a9f499421dd9343f51395babd724deeffe875cc6f7 SHA512 8ae76dc5029e7adc809b0083e147c57c7249e9fbb07f263a0b10d21539ebfc69c5d9d8e60811cca06bbb313ec9a3a143baaef73f77ca599dc102626dc9fccf29
DIST croc-9.6.9-vendor.tar.xz 974884 BLAKE2B d6d061fd8259126dc107de3efcae3a023c9a8db44ba96343350360c6d321d73720d1079d46927f65d9ea1001e6421751241d2fe1c04a4f450ff3c4dadc5c6be1 SHA512 2f4ab17ae0c00bc1ac097aeda9fc791b98d8cf6ad31644bdf600a4c321894dea9974155950723e9d19b15c011eef81ab27dae1b2bc2eb4517611bac77bde590f
DIST croc-9.6.9.tar.gz 512036 BLAKE2B cdd18f9b4460905742d31852ceafda19a3e9c57ef33e6b2e0a21105da9b7d0cac1dfca50f6b217d76be6368d6fb26b540709c165b5b9781ca8952003811e83ad SHA512 5abd9eac5ffd4fae711f8169c4344aa6b61647309aa74267b1442b94d3a9d7ea11962b993862e00c7df8a23a260c20c643d468930836df71995652a5abf8772b
diff --git a/net-misc/croc/croc-9.6.15.ebuild b/net-misc/croc/croc-9.6.15.ebuild
new file mode 100644
index 000000000000..ddb41e941b5e
--- /dev/null
+++ b/net-misc/croc/croc-9.6.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}