summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-08-28 15:41:00 -0500
committerBen Kohler <bkohler@gentoo.org>2022-08-28 15:41:45 -0500
commite7f443ab9d94395389b54a91dc258679ad4e02c7 (patch)
tree3dde3640349c4f4311cdcf31899654b12f49224a /net-misc/connman
parentmedia-libs/libdvbcsa: drop 1.1.0, EAPI-6-- (diff)
downloadgentoo-e7f443ab9d94395389b54a91dc258679ad4e02c7.tar.gz
gentoo-e7f443ab9d94395389b54a91dc258679ad4e02c7.tar.bz2
gentoo-e7f443ab9d94395389b54a91dc258679ad4e02c7.zip
net-misc/connman: add 1.42_pre20220828
Bug: https://bugs.gentoo.org/865621 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.42_pre20220828.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index c3af10912025..ffdff76ce3e4 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -1 +1,2 @@
DIST connman-363e0ed955f605fb0dc919b7ee149b6071af73ee.tar.gz 738158 BLAKE2B 05315470fe055b6b42330d3aa6e4286c551f1ce43a63e6952f0f0969d3639275eab62da0d90ff6fd756fcfca37e11d16d4ed834f0cf02e1b8cf75be742cc6a75 SHA512 e5a66134f4ee99d03aa4c77082817a4886750434e676eecb394ba1aac0475034cadec66aba27704b173151dce74e92f9e77065bcdef9576c9ed3d3cfc13a1d68
+DIST connman-cb05780d86c39cfb5e6d9ac2b288bf3244a95d57.tar.gz 738675 BLAKE2B d2c8ee587bdf045e4438a5c4c48475a5ba8ae390032dbdee44ed884273d741e290fcaeb5cee1025a7dec1f7f7034cf01d3e074d08004024dc541bff1b729627c SHA512 3d49f7fad6044c080a5805cc35dbecbdf916d66a2ace0246631936fbf46d80fcfff960df79a8471069caa00975dd74f5fcc17812811ce9c93919e2947ef23f6d
diff --git a/net-misc/connman/connman-1.42_pre20220828.ebuild b/net-misc/connman/connman-1.42_pre20220828.ebuild
new file mode 100644
index 000000000000..b63e300c6add
--- /dev/null
+++ b/net-misc/connman/connman-1.42_pre20220828.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools systemd tmpfiles
+
+COMMIT=cb05780d86c39cfb5e6d9ac2b288bf3244a95d57
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/network/connman/connman.git/snapshot/connman-${COMMIT}.tar.gz"
+ KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/connman/connman.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/libresolv-musl-fix.patch" )
+S=${WORKDIR}/${PN}-${COMMIT}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --runstatedir=/run \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable iwd) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process connman_resolvconf.conf
+}