summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 14:07:04 +0000
committerSam James <sam@gentoo.org>2021-02-08 14:54:01 +0000
commit2ffb133747fdd2144faac5ac7dc300a7ff562bf1 (patch)
treeb468bdc3dd8b01cacc86bab55c6e4de6ccaa48f7 /net-misc/chrony/chrony-9999.ebuild
parentnet-misc/chrony: add dev-libs/libtomcrypt support (diff)
downloadgentoo-2ffb133747fdd2144faac5ac7dc300a7ff562bf1.tar.gz
gentoo-2ffb133747fdd2144faac5ac7dc300a7ff562bf1.tar.bz2
gentoo-2ffb133747fdd2144faac5ac7dc300a7ff562bf1.zip
net-misc/chrony: sync live
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 182761799236..29a5fe41d5f6 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
inherit systemd tmpfiles toolchain-funcs
DESCRIPTION="NTP client and server programs"
-HOMEPAGE="https://chrony.tuxfamily.org/ https://git.tuxfamily.org/chrony/chrony.git"
+HOMEPAGE="https://chrony.tuxfamily.org/"
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -20,14 +20,14 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon debug html ipv6 libedit +nettle nss +ntp +phc +nts pps +refclock +rtc samba +seccomp +sechash selinux"
+IUSE="+caps +cmdmon debug html ipv6 libedit +nettle nss +ntp +phc +nts pps +refclock +rtc samba +seccomp +sechash selinux libtomcrypt"
REQUIRED_USE="
- sechash? ( || ( nettle nss ) )
+ sechash? ( || ( nettle nss libtomcrypt ) )
nettle? ( !nss )
!sechash? ( !nss )
!sechash? ( !nts? ( !nettle ) )
nts? ( nettle )
- "
+"
RESTRICT="test"
BDEPEND="nettle? ( virtual/pkgconfig )"
@@ -110,7 +110,7 @@ src_configure() {
$(usex rtc '' --disable-rtc)
$(usex samba --enable-ntp-signd '')
$(usex sechash '' --disable-sechash)
- ${EXTRA_ECONF}
+ $(usex libtomcrypt '' --disable-tomcrypt)
--chronysockdir="${EPREFIX}/run/chrony"
--docdir="${EPREFIX}/usr/share/doc/${PF}"
--mandir="${EPREFIX}/usr/share/man"
@@ -118,7 +118,7 @@ src_configure() {
--sysconfdir="${EPREFIX}/etc/chrony"
--with-hwclockfile="${EPREFIX}/etc/adjtime"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-tomcrypt
+ ${EXTRA_ECONF}
)
# print the ./configure call