summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild')
-rw-r--r--net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
new file mode 100644
index 000000000000..a6aef1ecd1c5
--- /dev/null
+++ b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_AUTOCONF="2.1"
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Proxy IMAP transactions between an IMAP client and an IMAP server"
+HOMEPAGE="http://www.imapproxy.org/"
+SRC_URI="mirror://sourceforge/squirrelmail/squirrelmail-imap_proxy-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="kerberos ssl +tcpd"
+
+RDEPEND="sys-libs/ncurses
+ kerberos? ( virtual/krb5 )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+S=${WORKDIR}/squirrelmail-imap_proxy-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-ldflags.patch
+ epatch "${FILESDIR}/${P}"-tinfo.patch
+
+ sed -i \
+ -e 's:in\.imapproxyd:imapproxyd:g' \
+ README Makefile.in include/imapproxy.h || die
+
+ #buffer oveflow
+ #http://lists.andrew.cmu.edu/pipermail/imapproxy-info/2010-June/000874.html
+ sed -i \
+ -e "/define BUFSIZE/s/4096/8192/" \
+ -e "/define MAXPASSWDLEN/s/64/8192/" \
+ include/imapproxy.h
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_with kerberos krb5) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd libwrap)
+}
+
+src_install() {
+ dosbin bin/imapproxyd bin/pimpstat
+
+ insinto /etc
+ doins scripts/imapproxy.conf
+
+ newinitd "${FILESDIR}"/imapproxy.initd imapproxy
+
+ dodoc ChangeLog README README.known_issues
+ use ssl && dodoc README.ssl
+
+ doman "${FILESDIR}"/*.8
+}