summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-05-25 19:22:51 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-01 10:10:02 +0200
commitf2239f5713c7b9dbb708b2036c243e75a5e4eb4f (patch)
tree726cc4f5ef4d47374d6cf6660c7dee12822ee32f /net-libs
parentmedia-fonts/noto: Fix VariableOrderWrong warning (diff)
downloadgentoo-f2239f5713c7b9dbb708b2036c243e75a5e4eb4f.tar.gz
gentoo-f2239f5713c7b9dbb708b2036c243e75a5e4eb4f.tar.bz2
gentoo-f2239f5713c7b9dbb708b2036c243e75a5e4eb4f.zip
net-libs/msgraph: New Package 0.2.3
Bug: https://github.com/gentoo/gentoo/pull/35307 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/msgraph/Manifest1
-rw-r--r--net-libs/msgraph/metadata.xml11
-rw-r--r--net-libs/msgraph/msgraph-0.2.3.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/msgraph/Manifest b/net-libs/msgraph/Manifest
new file mode 100644
index 000000000000..16d09fcda9fb
--- /dev/null
+++ b/net-libs/msgraph/Manifest
@@ -0,0 +1 @@
+DIST msgraph-0.2.3.tar.xz 95904 BLAKE2B 5c0476511784861e1a6e3f3cb4ecaa50ad494b484b8b60f9305aae95539e8d4e9c0e491298d5d1df0031f28a9c472eb6f197acf02a69625e904c4095263b831a SHA512 23a9c24dde6125a7e6fc8a9db61248423a78e2e50a95880a59662d5824fc3f171b2354ab6ae66c77c75fd1737b1d4b19b7a35f8c6fe9ba393c5b116f3c56128f
diff --git a/net-libs/msgraph/metadata.xml b/net-libs/msgraph/metadata.xml
new file mode 100644
index 000000000000..6dc85afd66c7
--- /dev/null
+++ b/net-libs/msgraph/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/msgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/msgraph/msgraph-0.2.3.ebuild b/net-libs/msgraph/msgraph-0.2.3.ebuild
new file mode 100644
index 000000000000..5a1127c64e68
--- /dev/null
+++ b/net-libs/msgraph/msgraph-0.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson
+
+DESCRIPTION="GLib-based library for accessing online serive APIs using MS Graph protocol."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/msgraph"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug gtk-doc +introspection man"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ dev-libs/json-glib
+ net-libs/rest
+ >=net-libs/libsoup-3.0:3.0
+ net-libs/gnome-online-accounts
+ >=net-libs/uhttpmock-0.11.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ dev-libs/gobject-introspection-common
+"
+BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}