summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-08-01 10:07:21 +0200
committerPacho Ramos <pacho@gentoo.org>2024-08-01 10:10:02 +0200
commitf1fae2dcc9ecfdd5c73fbd5f5de705365c1eab40 (patch)
tree242693085ab2bc0b0be2333029256af8603186a5 /net-libs
parentnet-libs/uhttpmock: Bump to 0.11.0 (diff)
downloadgentoo-f1fae2dcc9ecfdd5c73fbd5f5de705365c1eab40.tar.gz
gentoo-f1fae2dcc9ecfdd5c73fbd5f5de705365c1eab40.tar.bz2
gentoo-f1fae2dcc9ecfdd5c73fbd5f5de705365c1eab40.zip
net-libs/msgraph: Fix dependencies
Handle tests, and keyword only in the arch we tested Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/msgraph/msgraph-0.2.3.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/net-libs/msgraph/msgraph-0.2.3.ebuild b/net-libs/msgraph/msgraph-0.2.3.ebuild
index 5a1127c64e68..6154cb750591 100644
--- a/net-libs/msgraph/msgraph-0.2.3.ebuild
+++ b/net-libs/msgraph/msgraph-0.2.3.ebuild
@@ -10,17 +10,19 @@ HOMEPAGE="https://gitlab.gnome.org/GNOME/msgraph"
LICENSE="LGPL-2+"
SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="~amd64"
-IUSE="debug gtk-doc +introspection man"
+IUSE="debug gtk-doc +introspection man test"
+REQUIRED_USE="gtk-doc? ( introspection )"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.28.0:2
dev-libs/json-glib
- net-libs/rest
- >=net-libs/libsoup-3.0:3.0
- net-libs/gnome-online-accounts
- >=net-libs/uhttpmock-0.11.0
+ net-libs/rest:1.0
+ net-libs/libsoup:3.0
+ net-libs/gnome-online-accounts:=
+ >=net-libs/uhttpmock-0.11.0:1.0
introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
"
@@ -30,12 +32,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
dev-libs/gobject-introspection-common
"
-BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( net-libs/uhttpmock:1.0 )
+"
src_configure() {
local emesonargs=(
$(meson_use gtk-doc gtk_doc)
$(meson_use introspection)
+ $(meson_use test tests)
)
meson_src_configure
}