summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-02 22:10:00 +0200
committerSam James <sam@gentoo.org>2020-09-13 21:17:17 +0000
commitdc125b4004b189c1b09e45e1d9b803d574718c23 (patch)
treef47128a0da4e446fbb1094f345b213dd013019cc /net-libs
parentprofiles: Fix silly package.mask date (diff)
downloadgentoo-dc125b4004b189c1b09e45e1d9b803d574718c23.tar.gz
gentoo-dc125b4004b189c1b09e45e1d9b803d574718c23.tar.bz2
gentoo-dc125b4004b189c1b09e45e1d9b803d574718c23.zip
net-libs/libwebsockets: set LWS_DBUS_INCLUDE2
CMake only looks for dbus-arch-deps.h at /usr/lib64, so we have to manually set LWS_DBUS_INCLUDE2 for 32-bit systems where it is located at /usr/lib Closes: https://bugs.gentoo.org/740090 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17389 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libwebsockets/libwebsockets-4.0.20.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-libs/libwebsockets/libwebsockets-4.0.20.ebuild b/net-libs/libwebsockets/libwebsockets-4.0.20.ebuild
index 2fa0810a12e1..b0d538ff9060 100644
--- a/net-libs/libwebsockets/libwebsockets-4.0.20.ebuild
+++ b/net-libs/libwebsockets/libwebsockets-4.0.20.ebuild
@@ -82,5 +82,7 @@ src_configure() {
-DLWS_WITHOUT_TESTAPPS=ON
)
+ use dbus && mycmakeargs+=( -DLWS_DBUS_INCLUDE2="/usr/$(get_libdir)/dbus-1.0/include" )
+
cmake_src_configure
}