summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-24 05:00:09 +0000
committerSam James <sam@gentoo.org>2022-11-24 05:00:09 +0000
commitd55c1474a120e6dc547985856b48e2e5cdec7b91 (patch)
tree754ae4ea3bac7f2d6ba75d0327b1bf6859fba153 /net-libs
parentdev-vcs/git: add 2.39.0_rc0 (diff)
downloadgentoo-d55c1474a120e6dc547985856b48e2e5cdec7b91.tar.gz
gentoo-d55c1474a120e6dc547985856b48e2e5cdec7b91.tar.bz2
gentoo-d55c1474a120e6dc547985856b48e2e5cdec7b91.zip
net-libs/ntirpc: add 4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-4.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index 1af6249217bd..94020044102e 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1 +1,2 @@
DIST ntirpc-4.0.tar.gz 388389 BLAKE2B b997430a119c900cfd8792af530d7baec629d7afa076838ca22b83631a461df2f267c6b786582bbefc98db870d054f37c9e9c0c3201f9a130f3f3806168043c1 SHA512 7bafad650bcebbf53a9958abdcacb8dfa9ac46c9798ac39e82c2ae3215b3e5b5a6b916bb95e3c70e7bc1a09b26a46b00bad236b2400538e9695b1c347f0672d9
+DIST ntirpc-4.2.tar.gz 388418 BLAKE2B af875834515ae84d324302f2c0a36a7f34bb60ff95d2e30372f21541d558cec4337955fb72f1fbf43e3fcae75d706441dee658420bffe1f315578959405afb72 SHA512 fe241e3ac0e988d42425fe14c84970577693bd9ab1831069c753a18369150fb236fafea3d9b6c9d93faf93e918a93bf5367b914db819762c76e432ccffcb9328
diff --git a/net-libs/ntirpc/ntirpc-4.2.ebuild b/net-libs/ntirpc/ntirpc-4.2.ebuild
new file mode 100644
index 000000000000..4ef6001a06c1
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}