summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-03-25 14:05:29 -0400
committerCraig Andrews <candrews@gentoo.org>2022-03-25 14:13:46 -0400
commitb9553259be6b68e51f1f80df39b733515f53aa15 (patch)
tree8bf092bab9aac845ff6771d8238c352e804c3300 /net-libs
parentdev-php/twig: Drop old (diff)
downloadgentoo-b9553259be6b68e51f1f80df39b733515f53aa15.tar.gz
gentoo-b9553259be6b68e51f1f80df39b733515f53aa15.tar.bz2
gentoo-b9553259be6b68e51f1f80df39b733515f53aa15.zip
net-libs/ngtcp2: 0.2.1 version bump
Closes: https://bugs.gentoo.org/831419 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/metadata.xml3
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.2.1.ebuild49
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild21
4 files changed, 67 insertions, 7 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index c2d6b70d475d..0ef2c5efd921 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1,2 +1,3 @@
DIST ngtcp2-0.1.0.tar.xz 540132 BLAKE2B df59b4632110f118e0ae27c709fee24be65216d5461ad73901fb7f7450afe17a255acda10473a39ac45a34c2810728c50e39dcde9a71c48eb843d5d628b70b8c SHA512 935c37fe08bb625b39d4355322df54cedc180584c46b7816a84b2715f777a49590cd0434ed062fabec55df1a2c5332e7edf6335bd071599b053d6f404ce260b8
+DIST ngtcp2-0.2.1.tar.xz 554280 BLAKE2B 243599cde08eeb5833d4836cfe3a1b1ea3b9cd339d6f424899fe5bf10599c1e34a8002130c6b5b6378e99bd9c6ec87e2d8eebd6a439ed4f0df59238504ea6eb6 SHA512 8570f84eaa21190c2abd8140bbaa5495e06331cbc60efb42466eab218d3ac42f51810e0cf2a15bf81d16139de26728ee5009db66930e23bf6732252b7bf38737
DIST ngtcp2-0_pre20190912.tar.gz 302984 BLAKE2B 906b248b0c19395288ed2c5ad55c8d42a9df9d76458104785c1013b9ebfaf1b92a4b87ced8755377fcb627018cf8854be0e4687e4c8a23ae994e5a21f466f739 SHA512 91b93575143960af421e8bd37d686602905fa3093750cfbbe3af1b20d743318281d22162676dc451562768ca08b6d0767b1dc28f3f8f6733235ebd76015a05bb
diff --git a/net-libs/ngtcp2/metadata.xml b/net-libs/ngtcp2/metadata.xml
index 71f915056b8c..4b6987e8ad53 100644
--- a/net-libs/ngtcp2/metadata.xml
+++ b/net-libs/ngtcp2/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">ngtcp2/ngtcp2</remote-id>
</upstream>
+ <use>
+ <flag name="openssl">Provide SSL support using OpenSSL (requires <pkg>dev-libs/openssl</pkg>)</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/ngtcp2/ngtcp2-0.2.1.ebuild b/net-libs/ngtcp2/ngtcp2-0.2.1.ebuild
new file mode 100644
index 000000000000..a828f15d1ad2
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
index e1fef793bf0f..a828f15d1ad2 100644
--- a/net-libs/ngtcp2/ngtcp2-9999.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
inherit cmake-multilib
@@ -19,20 +19,27 @@ HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
LICENSE="MIT"
SLOT="0/0"
-IUSE="ssl test"
+IUSE="+gnutls openssl +ssl test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
BDEPEND="virtual/pkgconfig"
-DEPEND="ssl? ( >=dev-libs/openssl-1.1.1:0= )
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=(
- -DCMAKE_DISABLE_FIND_PACKAGE_OpenSSL=$(usex !ssl)
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
-DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
-DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
cmake_src_configure
}