summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-03 01:41:44 +0000
committerSam James <sam@gentoo.org>2025-01-03 01:41:44 +0000
commita15a740333017faf95f9f06cc1f86d12ea713e81 (patch)
treeb248de8219974baf7bc6f8df8ca6dffab865cdf6 /net-libs/nghttp3
parentnet-libs/ngtcp2: add note above REQUIRED_USE wrt tests (diff)
downloadgentoo-a15a740333017faf95f9f06cc1f86d12ea713e81.tar.gz
gentoo-a15a740333017faf95f9f06cc1f86d12ea713e81.tar.bz2
gentoo-a15a740333017faf95f9f06cc1f86d12ea713e81.zip
net-libs/nghttp3: fix build of tests w/ c23
Same as in a7dfda3569459f3ea16b905260e22a3115bfc595 for nghttp2. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/files/nghttp3-1.7.0-munit-c23.patch28
-rw-r--r--net-libs/nghttp3/nghttp3-1.7.0.ebuild6
2 files changed, 33 insertions, 1 deletions
diff --git a/net-libs/nghttp3/files/nghttp3-1.7.0-munit-c23.patch b/net-libs/nghttp3/files/nghttp3-1.7.0-munit-c23.patch
new file mode 100644
index 000000000000..93d208fa4215
--- /dev/null
+++ b/net-libs/nghttp3/files/nghttp3-1.7.0-munit-c23.patch
@@ -0,0 +1,28 @@
+https://github.com/nemequ/munit/pull/105
+--- a/tests/munit/munit.c
++++ b/tests/munit/munit.c
+@@ -858,23 +858,18 @@ static psnip_uint64_t munit_clock_get_elapsed(struct PsnipClockTimespec *start,
+
+ #if defined(_OPENMP)
+ # define ATOMIC_UINT32_T uint32_t
+-# define ATOMIC_UINT32_INIT(x) (x)
+ #elif defined(HAVE_STDATOMIC)
+ # include <stdatomic.h>
+ # define ATOMIC_UINT32_T _Atomic uint32_t
+-# define ATOMIC_UINT32_INIT(x) ATOMIC_VAR_INIT(x)
+ #elif defined(HAVE_CLANG_ATOMICS)
+ # define ATOMIC_UINT32_T _Atomic uint32_t
+-# define ATOMIC_UINT32_INIT(x) (x)
+ #elif defined(_WIN32)
+ # define ATOMIC_UINT32_T volatile LONG
+-# define ATOMIC_UINT32_INIT(x) (x)
+ #else
+ # define ATOMIC_UINT32_T volatile uint32_t
+-# define ATOMIC_UINT32_INIT(x) (x)
+ #endif
+
+-static ATOMIC_UINT32_T munit_rand_state = ATOMIC_UINT32_INIT(42);
++static ATOMIC_UINT32_T munit_rand_state = 42;
+
+ #if defined(_OPENMP)
+ static inline void munit_atomic_store(ATOMIC_UINT32_T *dest,
diff --git a/net-libs/nghttp3/nghttp3-1.7.0.ebuild b/net-libs/nghttp3/nghttp3-1.7.0.ebuild
index 435f7754e75c..70addd2e8479 100644
--- a/net-libs/nghttp3/nghttp3-1.7.0.ebuild
+++ b/net-libs/nghttp3/nghttp3-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,10 @@ REQUIRED_USE="
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-munit-c23.patch
+)
+
multilib_src_configure() {
local mycmakeargs=(
-DENABLE_LIB_ONLY=ON