summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-02 19:41:27 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-02 22:30:41 -0400
commit585cd569f744eed274da3e6c2bb608bd2539cdd3 (patch)
tree7b7ad0d6c2b9e92b49d7588737b12558b8d09796 /net-libs/libsoup
parentnet-vpn/corkscrew: Keyword 2.0-r1 riscv, #879167 (diff)
downloadgentoo-585cd569f744eed274da3e6c2bb608bd2539cdd3.tar.gz
gentoo-585cd569f744eed274da3e6c2bb608bd2539cdd3.tar.bz2
gentoo-585cd569f744eed274da3e6c2bb608bd2539cdd3.zip
net-libs/libsoup: Version bump to 3.2.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28116 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/libsoup')
-rw-r--r--net-libs/libsoup/Manifest1
-rw-r--r--net-libs/libsoup/libsoup-3.2.2.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index 8886aba0174d..45eb83e0b5b1 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,3 +1,4 @@
DIST libsoup-2.74.2.tar.xz 1497356 BLAKE2B b05e5d06e20a95042334c79e3a633ec43db0e7444b425f8577045fbdee7b78bd697e743f4283ed79265bbe538145a541ef2ef55636ae235667a89d00910d5bf2 SHA512 6f9da3296364e210103093cef9ef34fb40f694a8ef90966fc1fbd834c11f3db1031784a0901e9181bf3124e0682708148bd3598a31d60f1cce61eaae2e19ba7a
DIST libsoup-2.74.3.tar.xz 1504804 BLAKE2B 91f441197414314bb78cf15e7c13b54714e669145784812fb7a68cc41c8965ea29c53dc686d690e00f28f711be9f767038e5cc43b11aa0136f190dd2d41ec2a0 SHA512 72f8a055df984cb35105fe67f4ca67d3fb110d40a9cacb660fccd89f93b06bc32e25d94375dcc76608a245f7c5e081d968d7aaf5952eb16013d81c741247cb4c
DIST libsoup-3.2.1.tar.xz 1520736 BLAKE2B 57a040bab530e2a1bb67aea65291205c151bd3b490c200c2d2fd4ca77fab9f62e9fada5ea143c9581065a332be57d753dbe2cabb9228ca06a35d6327277e5fbf SHA512 e5f60fd700f4cda041d869eec50e787b2fbe9323949b90710405cff296e108bab6d1323ab96e89855c5396ce73c7b7574b424dbe957ae10b48740b272889be51
+DIST libsoup-3.2.2.tar.xz 1530460 BLAKE2B 8df66651a0bdcdb3337ced0031e4e8a32883241f6b7310a2b91396883368fa849d1e7dbab3766ec38ec05fdd81fafabd1f165cfe22a168e87db9a431ca86274d SHA512 1f2b49244f8bac4d112b39ac9c6a942acbc1ae1cff33262ed02e7682af3994cf6ba6741b365b3c80c45c6427d391599fa6f31df6caa4ffefe7d078ac373bad1b
diff --git a/net-libs/libsoup/libsoup-3.2.2.ebuild b/net-libs/libsoup/libsoup-3.2.2.ebuild
new file mode 100644
index 000000000000..9b2de0509056
--- /dev/null
+++ b/net-libs/libsoup/libsoup-3.2.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_MIN_API_VERSION="0.54" # requires gio-2.0.vapi generated from glib-2.70+
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="3.0"
+
+IUSE="+brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.69.1:2[${MULTILIB_USEDEP}]
+ net-libs/nghttp2:=[${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ sys-libs/zlib
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ >=net-libs/glib-networking-2.70_alpha[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? ( >=net-libs/gnutls-3.6.0[pkcs11] )
+"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+PATCHES=(
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+ # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+ sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ # But unnecessary while apache tests are disabled
+ #addpredict /usr/share/snmp/mibs/.index
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature gssapi)
+ -Dkrb5_config="${CHOST}-krb5-config"
+ $(meson_feature samba ntlm)
+ $(meson_feature brotli)
+ -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+ -Dtls_check=false # disables check, we still rdep on glib-networking
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature vala vapi)
+ $(meson_native_use_feature gtk-doc docs)
+ -Ddoc_tests=false
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ $(meson_feature sysprof)
+ $(meson_feature test pkcs11_tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/libsoup-3.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}