summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2017-07-04 21:24:47 -0400
committerChris Reffett <creffett@gentoo.org>2017-07-04 21:24:47 -0400
commitf780d21d0fde41c3c79875e0814a7478cfeb8c5a (patch)
tree4d7f9541a9e09cbdba1e32cbbffb825226aaee52 /net-libs/biblesync
parentapp-backup/restic: bump to 0.7.0 (diff)
downloadgentoo-f780d21d0fde41c3c79875e0814a7478cfeb8c5a.tar.gz
gentoo-f780d21d0fde41c3c79875e0814a7478cfeb8c5a.tar.bz2
gentoo-f780d21d0fde41c3c79875e0814a7478cfeb8c5a.zip
net-libs/biblesync: Add static useflag wrt bug 623808
Gentoo-Bug: 623808 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs/biblesync')
-rw-r--r--net-libs/biblesync/biblesync-1.1.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/biblesync/biblesync-1.1.2-r1.ebuild b/net-libs/biblesync/biblesync-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..8a9ea543fea2
--- /dev/null
+++ b/net-libs/biblesync/biblesync-1.1.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="A multicast protocol to support Bible software shared co-navigation"
+HOMEPAGE="http://www.crosswire.org/wiki/BibleSync"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+DEPEND="dev-util/cmake"
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_SHARED_LIBS=$(usex !static)"
+ )
+ cmake-utils_src_configure
+}