summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-06 20:05:07 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-06 20:05:07 -0400
commit668bd642ef7a8f91145101aca8c96e523f7783e9 (patch)
tree1d35ff34b0e1633b039a22f87eeb5dd305a466ea /net-libs/axtls
parentsys-libs/musl: version bump to 1.1.15 (diff)
downloadgentoo-668bd642ef7a8f91145101aca8c96e523f7783e9.tar.gz
gentoo-668bd642ef7a8f91145101aca8c96e523f7783e9.tar.bz2
gentoo-668bd642ef7a8f91145101aca8c96e523f7783e9.zip
net-libs/axtls: version bump to 1.5.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-libs/axtls')
-rw-r--r--net-libs/axtls/Manifest1
-rw-r--r--net-libs/axtls/axtls-1.5.4.ebuild177
2 files changed, 178 insertions, 0 deletions
diff --git a/net-libs/axtls/Manifest b/net-libs/axtls/Manifest
index 74b94912a489..6a5f8dc954bf 100644
--- a/net-libs/axtls/Manifest
+++ b/net-libs/axtls/Manifest
@@ -2,3 +2,4 @@ DIST axTLS-1.5.0.tar.gz 1302393 SHA256 7ff27d1eb1ad1630e1a3431278d72857c1124edd9
DIST axTLS-1.5.1.tar.gz 1305575 SHA256 860a2754c497109854889e78eb2efdf00661f3b5dbb5e130bd5d8441a2f6ea50 SHA512 4b35e151d222496f5e4ab9c849ca9b14a245590a07f07132eab2fa633dac4cf7abfe29344f643fa182c9c443a139d3230d4b3554d3ff0932410ab36ae3666d92 WHIRLPOOL c1072aa94a7916db38d26902bac175d17e4f8fe1a431956d0b366f9cd913c89c145d119c823d9c1bfa51d54aa191ca43386b4312bea3a16f61d9df4ff2eb6b68
DIST axTLS-1.5.2.tar.gz 1309632 SHA256 c4568cdf3e326c6fee2d7d16b4e13e05a29cecf49c1774c7858fe83cde01f8bb SHA512 138c1134c949fb85335454907c8fa74f18860d16371aba7d4d46faa4fb0e9cbf41d259cf72389f439d8d6436dc200951001a53e996793ba59254f5ddefe99999 WHIRLPOOL 36b889c4aa5e3c2c0da20a189ec7342db86b757acbb5c9c8a12262d95ceabb490ac97fa608efd66757e74e6347e0f5ff5bd5c76ac453d9dbdc115c45b8e35ad4
DIST axTLS-1.5.3.tar.gz 1309853 SHA256 367ce7918b9e7738d853d5eaaa9d4fbdb362c5b323d4c0622a72d891f6b8d8e6 SHA512 d37fb1341259b079ed234512a96656d67e005c50d9f8e0c856fb140c9da35267624e065134e0cc8310f70e5cf5d196c7dd34f01e2a7a5cc29e77e7ca46c25281 WHIRLPOOL 92de1a06da740adf0238550d36a75216bace6c7fb867e82d38f2ca2362dcf0e41810191933aa788ffda080367b6beb312f1a9a240ab687a6c4f324988d36a81c
+DIST axTLS-1.5.4.tar.gz 1296351 SHA256 24d50cc4f5908d06cfacb2a3916d91ed75c5b1441809e47bc45e1053d6ba5d91 SHA512 0e52ca22199b3c7eb45641c7fdbe607f79fcea25f12d1ee0535a6a7c7579ee42777d27ce6474866eca19287bd11a1de76f5c39f715eb06e9e4cf3324b31bbbb2 WHIRLPOOL 29d2b5e72165c28c0e9084677f44b52116ec5da5efabc2fed79479800cbfe43c5dd4bf7390951b5168a63af0acd1cb5635fecac7d4ef42d570a1ef6d5e7edb6f
diff --git a/net-libs/axtls/axtls-1.5.4.ebuild b/net-libs/axtls/axtls-1.5.4.ebuild
new file mode 100644
index 000000000000..ba142a9f9351
--- /dev/null
+++ b/net-libs/axtls/axtls-1.5.4.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib multilib-minimal savedconfig toolchain-funcs user
+
+################################################################################
+# axtls CONFIG MINI-HOWTO
+#
+# Note: axtls is highly configurable and uses mconf, like the linux kernel.
+# You can configure it in a couple of ways:
+#
+# 1) USE="-savedconfig" and set/unset the remaining flags to obtain the features
+# you want, and possibly a lot more.
+#
+# 2) You can create your own configuration file by doing
+#
+# FEATURES="keepwork" USE="savedconfig -*" emerge axtls
+# cd /var/tmp/portage/net-libs/axtls*/work/axTLS
+# make menuconfig
+#
+# Now configure axtls as you want. Finally save your config file:
+#
+# cp config/.config /etc/portage/savedconfig/net-libs/axtls-${PV}
+#
+# where ${PV} is the current version. You can then run emerge again with
+# your configuration by doing
+#
+# USE="savedconfig" emerge axtls
+#
+################################################################################
+
+MY_PN=${PN/tls/TLS}
+
+DESCRIPTION="Embedded client/server TLSv1 SSL library and small HTTP(S) server"
+HOMEPAGE="http://axtls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/axtls/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-code"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+IUSE="httpd cgi-lua cgi-php static static-libs doc"
+
+# TODO: add ipv6, and c#, java, lua, perl bindings
+# Currently these all have some issue
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="
+ httpd? (
+ cgi-lua? ( dev-lang/lua )
+ cgi-php? ( dev-lang/php[cgi] )
+ )"
+
+#Note1: static, cgi-* makes no sense if httpd is not given
+REQUIRED_USE="
+ static? ( httpd )
+ cgi-lua? ( httpd )
+ cgi-php? ( httpd )"
+
+AXTLS_GROUP="axtls"
+AXTLS_USER="axtls"
+
+pkg_setup() {
+ use httpd && {
+ ebegin "Creating axtls user and group"
+ enewgroup ${AXTLS_GROUP}
+ enewuser ${AXTLS_USER} -1 -1 -1 ${AXTLS_GROUP}
+ }
+}
+
+src_prepare() {
+ tc-export AR CC
+
+ epatch "${FILESDIR}/explicit-libdir-r1.patch"
+
+ #We want CONFIG_DEBUG to avoid stripping
+ #but not for debugging info
+ sed -i -e 's: -g::' config/Rules.mak || die
+ sed -i -e 's: -g::' config/makefile.conf || die
+
+ multilib_copy_sources
+}
+
+use_flag_config() {
+ cp "${FILESDIR}"/config config/.config || die
+
+ #Respect CFLAGS/LDFLAGS
+ sed -i -e "s:^CONFIG_EXTRA_CFLAGS_OPTIONS.*$:CONFIG_EXTRA_CFLAGS_OPTIONS=\"${CFLAGS}\":" \
+ config/.config || die
+ sed -i -e "s:^CONFIG_EXTRA_LDFLAGS_OPTIONS.*$:CONFIG_EXTRA_LDFLAGS_OPTIONS=\"${LDLAGS}\":" \
+ config/.config || die
+
+ #The logic is that the default config file enables everything and we disable
+ #here with sed unless a USE flags says to keep it
+ if use httpd; then
+ if ! use static; then
+ sed -i -e 's:^CONFIG_HTTP_STATIC_BUILD:# CONFIG_HTTP_STATIC_BUILD:' \
+ config/.config || die
+ fi
+ if ! use cgi-php && ! use cgi-lua; then
+ sed -i -e 's:^CONFIG_HTTP_HAS_CGI:# CONFIG_HTTP_HAS_CGI:' \
+ config/.config || die
+ fi
+ if ! use cgi-php; then
+ sed -i -e 's:,.php::' config/.config || die
+ fi
+ if ! use cgi-lua; then
+ sed -i -e 's:\.lua,::' \
+ -e 's:lua:php:' \
+ -e 's:^CONFIG_HTTP_ENABLE_LUA:# CONFIG_HTTP_ENABLE_LUA:' \
+ config/.config || die
+ fi
+ else
+ sed -i -e 's:^CONFIG_AXHTTPD:# CONFIG_AXHTTPD:' \
+ config/.config || die
+ fi
+
+ yes "n" | emake -j1 oldconfig > /dev/null || die
+}
+
+multilib_src_configure() {
+ #Per-ABI substitutions.
+ sed -i -e 's:^LIBDIR.*/lib:LIBDIR = $(PREFIX)/'"$(get_libdir):" \
+ Makefile || die
+
+ #Use CC as the host compiler for mconf
+ sed -i -e "s:^HOSTCC.*:HOSTCC=${CC}:" \
+ config/Rules.mak || die
+
+ if use savedconfig; then
+ restore_config config/.config
+ if [[ -f config/.config ]]; then
+ ewarn "Using saved config, all other USE flags ignored"
+ else
+ ewarn "No saved config, seeding with the default"
+ cp "${FILESDIR}"/config config/.config || die
+ fi
+ yes "" | emake -j1 oldconfig > /dev/null || die
+ else
+ use_flag_config
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use savedconfig; then
+ save_config config/.config
+ fi
+
+ emake PREFIX="${ED}/usr" install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/libaxtls.a || die
+ fi
+
+ # The build system needs to install before it builds docs
+ if multilib_is_native_abi && use doc; then
+ emake docs
+ dodoc -r docsrc/html
+ fi
+}
+
+multilib_src_install_all() {
+ if [[ -f "${ED}"/usr/bin/htpasswd ]]; then
+ mv "${ED}"/usr/bin/{,ax}htpasswd || die
+ fi
+
+ if use httpd; then
+ newinitd "${FILESDIR}"/axhttpd.initd axhttpd
+ newconfd "${FILESDIR}"/axhttpd.confd axhttpd
+ fi
+
+ docompress -x /usr/share/doc/${PF}/README
+ dodoc README
+}