summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-11-05 18:15:58 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-11-05 19:35:20 +0100
commit9a5aad2bf2e54dab53a598fa151baaa8dd1b1f0c (patch)
treedc4698c0cdd43775e70f4f6cd9a8e7a378978133 /net-irc
parentdev-db/influxdb: Version bump to 1.8.10 (diff)
downloadgentoo-9a5aad2bf2e54dab53a598fa151baaa8dd1b1f0c.tar.gz
gentoo-9a5aad2bf2e54dab53a598fa151baaa8dd1b1f0c.tar.bz2
gentoo-9a5aad2bf2e54dab53a598fa151baaa8dd1b1f0c.zip
net-irc/znc: fix build with SWIG 4.1.0 and USE=perl/python
Also always enable IPv6 as it doesn't require additional dependencies (pkgcheck warned of "UseFlagWithoutDeps"). Closes: https://bugs.gentoo.org/878587 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/files/znc-1.8.2-fix-swig.patch43
-rw-r--r--net-irc/znc/znc-1.8.2-r2.ebuild9
2 files changed, 48 insertions, 4 deletions
diff --git a/net-irc/znc/files/znc-1.8.2-fix-swig.patch b/net-irc/znc/files/znc-1.8.2-fix-swig.patch
new file mode 100644
index 000000000000..d07d136c5940
--- /dev/null
+++ b/net-irc/znc/files/znc-1.8.2-fix-swig.patch
@@ -0,0 +1,43 @@
+From fecdd9895894b3afe903021b0843a422eb4d3308 Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <alexey+znc@asokolov.org>
+Date: Sat, 5 Nov 2022 12:54:40 +0000
+Subject: [PATCH] Add support SWIG 4.1.0, drop support for < 4.0.1
+
+https://bugs.gentoo.org/878587
+---
+ CMakeLists.txt | 2 +-
+ modules/modperl/CMakeLists.txt | 1 -
+ modules/modpython/CMakeLists.txt | 1 -
+ 3 files changed, 1 insertion(+), 3 deletions(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -173,7 +173,7 @@ if(WANT_PYTHON AND NOT EXISTS
+ endif()
+ endif()
+ if(search_swig)
+- find_package(SWIG 3.0.0)
++ find_package(SWIG 4.0.1)
+ if(NOT SWIG_FOUND)
+ message(FATAL_ERROR
+ "Can't find SWIG, therefore Perl and Python aren't supported. "
+--- a/modules/modperl/CMakeLists.txt
++++ b/modules/modperl/CMakeLists.txt
+@@ -53,7 +53,6 @@ if(SWIG_FOUND)
+ "-I${PROJECT_SOURCE_DIR}/include"
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/.."
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/include"
+- -DZNC_EXPORT_LIB_EXPORT
+ -outdir "${CMAKE_CURRENT_BINARY_DIR}"
+ -o "${CMAKE_CURRENT_BINARY_DIR}/modperl_biglib.cpp"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modperl.i"
+--- a/modules/modpython/CMakeLists.txt
++++ b/modules/modpython/CMakeLists.txt
+@@ -50,7 +50,6 @@ if(SWIG_FOUND)
+ "-I${PROJECT_BINARY_DIR}/include"
+ "-I${PROJECT_SOURCE_DIR}/include"
+ "-I${CMAKE_CURRENT_SOURCE_DIR}/.."
+- -DZNC_EXPORT_LIB_EXPORT
+ -outdir "${CMAKE_CURRENT_BINARY_DIR}"
+ -o "${CMAKE_CURRENT_BINARY_DIR}/modpython_biglib.cpp"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modpython.i"
diff --git a/net-irc/znc/znc-1.8.2-r2.ebuild b/net-irc/znc/znc-1.8.2-r2.ebuild
index b9d4a004fac3..885291374ae4 100644
--- a/net-irc/znc/znc-1.8.2-r2.ebuild
+++ b/net-irc/znc/znc-1.8.2-r2.ebuild
@@ -30,7 +30,7 @@ LICENSE="Apache-2.0"
# "If you upgrade your ZNC version, you must recompile all your modules."
# - https://wiki.znc.in/Compiling_modules
SLOT="0/${PV}"
-IUSE="+ipv6 +icu nls perl python +ssl sasl tcl test +zlib"
+IUSE="+icu nls perl python +ssl sasl tcl test +zlib"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} icu )"
@@ -40,11 +40,11 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
perl? (
- >=dev-lang/swig-3.0.0
+ >=dev-lang/swig-4.0.1
>=dev-lang/perl-5.10
)
python? (
- >=dev-lang/swig-3.0.0
+ >=dev-lang/swig-4.0.1
>=dev-lang/perl-5.10
)
test? (
@@ -75,6 +75,7 @@ PATCHES=(
"${FILESDIR}"/${P}-add-libera.patch
"${FILESDIR}"/${P}-fix-python-3.10.patch
"${FILESDIR}"/${P}-fix-odr-violation.patch
+ "${FILESDIR}"/${P}-fix-swig.patch
)
pkg_setup() {
@@ -103,7 +104,7 @@ src_configure() {
-DWANT_SYSTEMD=yes # Causes -DSYSTEMD_DIR to be used.
-DSYSTEMD_DIR="$(systemd_get_systemunitdir)"
-DWANT_ICU="$(usex icu)"
- -DWANT_IPV6="$(usex ipv6)"
+ -DWANT_IPV6=yes
-DWANT_I18N="$(usex nls)"
-DWANT_PERL="$(usex perl)"
-DWANT_PYTHON="$(usex python)"