summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2017-12-17 20:35:02 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-12-17 20:35:02 +0000
commitffcfafee2a0495b273f947a8e08389e4358189fe (patch)
treee2801961091029d0612c120ddd5d6eb185840508 /net-im/gajim
parentdev-python/dbusmock: keyworded 0.16.9 for sparc, bug #620024 (thanks to Rolf ... (diff)
downloadgentoo-ffcfafee2a0495b273f947a8e08389e4358189fe.tar.gz
gentoo-ffcfafee2a0495b273f947a8e08389e4358189fe.tar.bz2
gentoo-ffcfafee2a0495b273f947a8e08389e4358189fe.zip
net-im/gajim: Block incompatible version of pyopenssl
Remove older revision of 0.16.8. Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/gajim-0.16.6-r1.ebuild1
-rw-r--r--net-im/gajim/gajim-0.16.8-r1.ebuild1
-rw-r--r--net-im/gajim/gajim-0.16.8.ebuild119
3 files changed, 2 insertions, 119 deletions
diff --git a/net-im/gajim/gajim-0.16.6-r1.ebuild b/net-im/gajim/gajim-0.16.6-r1.ebuild
index 6b89f29de4a7..3659853fb462 100644
--- a/net-im/gajim/gajim-0.16.6-r1.ebuild
+++ b/net-im/gajim/gajim-0.16.6-r1.ebuild
@@ -41,6 +41,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
dev-python/pyasn1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ !>=dev-python/pyopenssl-17.4.0[${PYTHON_USEDEP}]
>=dev-python/python-nbxmpp-0.5.3[${PYTHON_USEDEP}]
crypt? (
app-crypt/gnupg
diff --git a/net-im/gajim/gajim-0.16.8-r1.ebuild b/net-im/gajim/gajim-0.16.8-r1.ebuild
index f9965310b5b1..41717a20041c 100644
--- a/net-im/gajim/gajim-0.16.8-r1.ebuild
+++ b/net-im/gajim/gajim-0.16.8-r1.ebuild
@@ -41,6 +41,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
dev-python/pyasn1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ !>=dev-python/pyopenssl-17.4.0[${PYTHON_USEDEP}]
>=dev-python/python-nbxmpp-0.5.6[${PYTHON_USEDEP}]
crypt? ( >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
dbus? (
diff --git a/net-im/gajim/gajim-0.16.8.ebuild b/net-im/gajim/gajim-0.16.8.ebuild
deleted file mode 100644
index d23fd2187375..000000000000
--- a/net-im/gajim/gajim-0.16.8.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite,xml"
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils python-r1 versionator
-
-MY_PV=${PV/_/-}
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="https://www.gajim.org/"
-SRC_URI="
- https://www.gajim.org/downloads/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
-# test? ( https://dev.gentoo.org/~jlec/distfiles/${PN}-tests-${PV}.tar.xz )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="crypt dbus gnome gnome-keyring kde idle jingle libnotify networkmanager nls spell +srv test X xhtml zeroconf"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- libnotify? ( dbus )
- gnome? ( gnome-keyring )
- zeroconf? ( dbus )"
-
-COMMON_DEPEND="
- ${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40.1
- virtual/pkgconfig
- >=sys-devel/gettext-0.17-r1"
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyasn1[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/python-nbxmpp-0.5.6[${PYTHON_USEDEP}]
- crypt? (
- app-crypt/gnupg
- dev-python/pycrypto[${PYTHON_USEDEP}]
- )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-libs/dbus-glib
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- zeroconf? ( net-dns/avahi[dbus,gtk,python,${PYTHON_USEDEP}] )
- )
- gnome? (
- dev-python/libgnome-python[${PYTHON_USEDEP}]
- dev-python/egg-python[${PYTHON_USEDEP}]
- )
- gnome-keyring? ( dev-python/gnome-keyring-python[${PYTHON_USEDEP}] )
- idle? ( x11-libs/libXScrnSaver )
- jingle? ( net-libs/farstream:0.1[python,${PYTHON_USEDEP}] )
- kde? ( kde-apps/kwalletmanager )
- networkmanager? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- net-misc/networkmanager
- )
- spell? ( app-text/gtkspell:2 )
- srv? (
- || (
- dev-python/libasyncns-python[${PYTHON_USEDEP}]
- net-dns/bind-tools
- )
- )
- xhtml? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"
-
-S="${WORKDIR}"/${MY_P}
-
-src_prepare() {
- autotools-utils_src_prepare
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myeconfargs=(
- $(use_enable nls)
- $(use_with X x)
- --docdir="/usr/share/doc/${PF}"
- --libdir="$(python_get_sitedir)"
- --enable-site-packages
- )
- run_in_build_dir autotools-utils_src_configure
- }
- python_foreach_impl configuration
-}
-
-src_compile() {
- compilation() {
- run_in_build_dir autotools-utils_src_compile
- }
- python_foreach_impl compilation
-}
-
-src_test() {
- testing() {
- run_in_build_dir ${PYTHON} test/runtests.py --verbose 3 || die
- }
- python_foreach_impl testing
-}
-
-src_install() {
- installation() {
- run_in_build_dir autotools-utils_src_install
- python_optimize
- }
- python_foreach_impl installation
-}