summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-10 08:37:04 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-10 10:15:56 +0100
commitd61931870a4ebf43003e6419ab84b5cfe43370f1 (patch)
treedc5bcdb0821ae62c24893862d4b34f570f953b27 /net-im/fractal
parentxfce-extra/xfce4-notifyd: Bump to 0.9.4 (diff)
downloadgentoo-d61931870a4ebf43003e6419ab84b5cfe43370f1.tar.gz
gentoo-d61931870a4ebf43003e6419ab84b5cfe43370f1.tar.bz2
gentoo-d61931870a4ebf43003e6419ab84b5cfe43370f1.zip
net-im/fractal: Bump to 6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im/fractal')
-rw-r--r--net-im/fractal/Manifest1
-rw-r--r--net-im/fractal/fractal-6.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/net-im/fractal/Manifest b/net-im/fractal/Manifest
index c198802b9784..2b465894622c 100644
--- a/net-im/fractal/Manifest
+++ b/net-im/fractal/Manifest
@@ -1,3 +1,4 @@
DIST fractal-6.rc.tar.bz2 1408366 BLAKE2B f02f3679bdd062fffe577a935b23f1f5243a91990cf81a152b1cbd6a8eeded18981cc4a8d4fe90fc63216feabd930cc5eb2207e732fba8421d3243e9ed1c1705 SHA512 2337d54854d99a4de7ca2687d5e74c5310c17b20abdd6691de4927b9c5378723736e7b8e8c01e9da32bd8f65a12461b03db2cc18cf7e90095532075b8e60e50c
+DIST fractal-6.tar.bz2 1430986 BLAKE2B 2388771eb34b527ce758efc9a81a5134cb5558ba64bbdf2cbb4911e56698dff7fcf175280b1a8126ffe59189024dbdb3fb847a88e991b86adb81b5e0f64a4ef7 SHA512 78f5ae06117b8f7218084946c883022ec08ae213a433c17386cdf84a30dcb2796f957c13b5b21cef1e500df0b1a86794aff144698c014fdeb42b782bf5583280
DIST fractal-6_beta-crates.tar.xz 45123596 BLAKE2B 88bd065066367943dc84af70a514f79e96382d62fb47caf80844a0c5532cc065fe5aa72bc737f240d6f64cd5e9f123be467c9fef0fd64e8f7a4aa496e613a408 SHA512 23cfff457be78c6ba2e71342d54605adad28dd0a21dcf3d3415477a36e78c52c921fd92083551798b6fccb4569814a33606812752c5b9c4ca2952e94f7f2f596
DIST matrix-rust-sdk-19526cea6bce133fc48904838956846aeb966dc6.gh.tar.gz 1743912 BLAKE2B 48b6352fbad17eb1651e5ca57bca25ea64dacecf0e97b63502fa54fd86ac65728656e799c0b50fddec575d05aa408c8347815f30afbf78413e973c35e0d8768f SHA512 a330250bf25dcb4a4a4a8bfc3bdda1a19d389080fb6a4983f00cc9cddc2f12b7a8f652942a58b9ed78b9c52802f94fd391e3dfd6971add8a44dbf66460488a1b
diff --git a/net-im/fractal/fractal-6.ebuild b/net-im/fractal/fractal-6.ebuild
new file mode 100644
index 000000000000..fc47c41defd9
--- /dev/null
+++ b/net-im/fractal/fractal-6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [matrix-sdk-base]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-base'
+ [matrix-sdk-common]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-common'
+ [matrix-sdk-crypto]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-crypto'
+ [matrix-sdk-indexeddb]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-indexeddb'
+ [matrix-sdk-qrcode]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-qrcode'
+ [matrix-sdk-sqlite]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-sqlite'
+ [matrix-sdk-store-encryption]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-store-encryption'
+ [matrix-sdk-ui]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk-ui'
+ [matrix-sdk]='https://github.com/matrix-org/matrix-rust-sdk;19526cea6bce133fc48904838956846aeb966dc6;matrix-rust-sdk-%commit%/crates/matrix-sdk'
+)
+
+inherit cargo gnome2-utils meson
+
+MY_P=${P/_/.}
+DESCRIPTION="Matrix messaging app for GNOME written in Rust"
+HOMEPAGE="
+ https://wiki.gnome.org/Apps/Fractal
+ https://gitlab.gnome.org/World/fractal/
+"
+SRC_URI="
+ https://gitlab.gnome.org/World/fractal/-/archive/${PV/_/.}/${MY_P}.tar.bz2
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${P}_beta-crates.tar.xz
+ "
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD GPL-3+ ISC MIT
+ MPL-2.0 MPL-2.0 Unicode-DFS-2016 ZLIB
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ >=dev-libs/glib-2.72
+ >=gui-libs/gtk-4.10.0:4
+ >=gui-libs/libadwaita-1.4.0:1
+
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-bad-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+
+ >=gui-libs/gtksourceview-5.0.0:5
+ >=media-video/pipewire-0.3.0:=[gstreamer]
+ >=dev-libs/openssl-1.0.1:=
+ >=media-libs/libshumate-1.0.0:1.0
+ >=dev-db/sqlite-3.24.0:3
+ >=sys-apps/xdg-desktop-portal-1.14.1
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/secret-service
+"
+# clang needed by bindgen
+BDEPEND="
+ sys-devel/clang
+ >=virtual/rust-1.75.0
+"
+
+# Rust
+QA_FLAGS_IGNORED="usr/bin/fractal"
+
+src_configure() {
+ meson_src_configure
+ ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}