summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:09:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:15 +0100
commit5e86a7c81a6869cc2125659707438932b2528b02 (patch)
tree29d1dd2a73a8977127c9c263459466565bf909d7 /net-ftp/ftpbase
parentnet-dns/dnssec-validator: drop 2.2.3-r1 (diff)
downloadgentoo-5e86a7c81a6869cc2125659707438932b2528b02.tar.gz
gentoo-5e86a7c81a6869cc2125659707438932b2528b02.tar.bz2
gentoo-5e86a7c81a6869cc2125659707438932b2528b02.zip
net-ftp/ftpbase: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-ftp/ftpbase')
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r6.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r6.ebuild
new file mode 100644
index 000000000000..47fb950fa6a2
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01-r6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pam
+
+DESCRIPTION="File Transfer Protocol (FTP) base layout"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="pam zeroconf"
+
+DEPEND="
+ pam? ( sys-libs/pam )
+ zeroconf? ( net-dns/avahi )
+"
+
+RDEPEND="
+ acct-group/ftp
+ acct-user/ftp
+"
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers"
+
+ use pam && newpamd "${FILESDIR}"/ftp-pamd-include ftp
+
+ if use zeroconf; then
+ insinto /etc/avahi/services
+ doins "${FILESDIR}/ftp.service"
+ fi
+}