summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-15 04:40:52 -0400
committerTim Harder <radhermit@gentoo.org>2018-09-15 05:14:38 -0400
commitb76312bedbb6ac25ccc9696538be0fedeb7cc061 (patch)
treec036b3a6a768ea115acb39daf278a699771bfc90 /net-fs
parentsys-fs/fuse: version bumps to 2.9.8 and 3.2.6 (diff)
downloadgentoo-b76312bedbb6ac25ccc9696538be0fedeb7cc061.tar.gz
gentoo-b76312bedbb6ac25ccc9696538be0fedeb7cc061.tar.bz2
gentoo-b76312bedbb6ac25ccc9696538be0fedeb7cc061.zip
net-fs/sshfs: version bump to 3.5.0
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/sshfs/Manifest1
-rw-r--r--net-fs/sshfs/files/sshfs-3.5.0-rst2man.patch14
-rw-r--r--net-fs/sshfs/sshfs-3.5.0.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/net-fs/sshfs/Manifest b/net-fs/sshfs/Manifest
index e68c2fceb7fc..7026c7d9ef26 100644
--- a/net-fs/sshfs/Manifest
+++ b/net-fs/sshfs/Manifest
@@ -2,3 +2,4 @@ DIST sshfs-2.10.tar.gz 163076 BLAKE2B e443b3bb65c432d8d8e3d6d198e3e41363ff506dbc
DIST sshfs-2.8.tar.gz 153230 BLAKE2B c2d7116d72145dee1a31093ce3225e92681a8bc5c5cd8472ffb0f6e46c9dd8e6b99089b91466311d2cf437ceb0cab9eeead5cccb890763c8f0302fbc0f16bceb SHA512 a3c6a75137a4410a0c4e049ffdb6e219319add9673de32cf32a74c12ff4bb80f92a6e75088417a180a4dd01957deec39bd780a02140e8b0348f5868c92d67cfd
DIST sshfs-3.3.1.tar.xz 46076 BLAKE2B 719c04e383b35ed5ce380db1a5a77858444768f27ac45a09205f4854a03aaad04ce418582dc79e5a9d23ccf9e225838bbdc20b0538bb867cca9af919fb294e34 SHA512 d0b623859a5b98db48c0ac6703e148603b2240114e22216e314f798ce645b39bbe7119a4e3f2d32d7bb41e07b2015761313e8249097a21bef9ad83287df9b80a
DIST sshfs-3.3.2.tar.xz 46572 BLAKE2B 187fba299bfe4aaffab43eec39e508d99771cf6e182a709d64431975ef30718a918c58790b83aba05cf0028118cf63d42fa6f6fe3e227cb6b7fc70f2f15a4c75 SHA512 7aedb94358ef5d3c25ef054dd1f4ac147ab2917c8ca46c4b9af6bf0a26c7ef1ca139771f5e7bb9a98d8bda74c89151f2bee85707f630393273df38e7862febd6
+DIST sshfs-3.5.0.tar.xz 47564 BLAKE2B 9a6fb1cb347de2903fb67900253f8b28ecf3dd4c972210d4839d0ed7bbbe2dff1be2d847dbfc1727cdeeef74d4b32856aa6e3041b603dc1e3f865269524ddff7 SHA512 6ba7be4bcad401d99fb864f105a6c8fc8b7c832d5b25f18cba27eee422fe65ee7bda8982466d624792a1fb21528c0cb078a59db48e93da4880a36aad7b506b0c
diff --git a/net-fs/sshfs/files/sshfs-3.5.0-rst2man.patch b/net-fs/sshfs/files/sshfs-3.5.0-rst2man.patch
new file mode 100644
index 000000000000..ad58de4e5054
--- /dev/null
+++ b/net-fs/sshfs/files/sshfs-3.5.0-rst2man.patch
@@ -0,0 +1,14 @@
+Fallback to looking for rst2man.py executable as that's what docutils upstream
+defaults to installing.
+
+--- sshfs-3.5.0/meson.build
++++ sshfs-3.5.0/meson.build
+@@ -25,7 +25,7 @@
+ endif
+
+
+-rst2man = find_program('rst2man', required: false)
++rst2man = find_program('rst2man', 'rst2man.py', required: false)
+
+ cfg = configuration_data()
+
diff --git a/net-fs/sshfs/sshfs-3.5.0.ebuild b/net-fs/sshfs/sshfs-3.5.0.ebuild
new file mode 100644
index 000000000000..042873de9d7b
--- /dev/null
+++ b/net-fs/sshfs/sshfs-3.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+SLOT="0"
+
+CDEPEND=">=sys-fs/fuse-3.1.0:3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.4"
+DEPEND="${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+# requires root privs and specific localhost sshd setup
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${P}-rst2man.patch )
+
+DOCS=( AUTHORS ChangeLog.rst README.rst )