summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-30 04:16:24 +0100
committerSam James <sam@gentoo.org>2022-09-30 04:47:58 +0100
commit88eb91b9b2e706a464a0d0ebe53dfbb2c504f2b8 (patch)
tree9dbc50bd2b283fa83803b6e11f140cb9363a70b8 /net-fs
parentapp-text/letterize: fix build with clang16 (diff)
downloadgentoo-88eb91b9b2e706a464a0d0ebe53dfbb2c504f2b8.tar.gz
gentoo-88eb91b9b2e706a464a0d0ebe53dfbb2c504f2b8.tar.bz2
gentoo-88eb91b9b2e706a464a0d0ebe53dfbb2c504f2b8.zip
net-fs/samba: use canonical phase ordering
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.16.5.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-fs/samba/samba-4.16.5.ebuild b/net-fs/samba/samba-4.16.5.ebuild
index 6dc422deafb4..5682cc16258b 100644
--- a/net-fs/samba/samba-4.16.5.ebuild
+++ b/net-fs/samba/samba-4.16.5.ebuild
@@ -265,6 +265,12 @@ multilib_src_compile() {
waf-utils_src_compile
}
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ "${WAF_BINARY}" test || die "test failed"
+ fi
+}
+
multilib_src_install() {
waf-utils_src_install
@@ -327,12 +333,6 @@ multilib_src_install() {
keepdir /var/log/samba
}
-multilib_src_test() {
- if multilib_is_native_abi ; then
- "${WAF_BINARY}" test || die "test failed"
- fi
-}
-
pkg_postinst() {
tmpfiles_process samba.conf
}