summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-28 19:33:07 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-19 12:21:10 +0100
commit64a6be1aa26c3736e84f2956dd634a44dc2bb98b (patch)
tree8eb46a73da3dc30e4def8b68a824a0425b42c6a6 /net-dns
parentapp-office/projectlibre-bin: EAPI8 bump, version bump (v1.9.3) (diff)
downloadgentoo-64a6be1aa26c3736e84f2956dd634a44dc2bb98b.tar.gz
gentoo-64a6be1aa26c3736e84f2956dd634a44dc2bb98b.tar.bz2
gentoo-64a6be1aa26c3736e84f2956dd634a44dc2bb98b.zip
net-dns/dnstop: EAPI8 bump, update HOMEPAGE, SRC_URI, fix #717202
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/717202 Bug: https://bugs.gentoo.org/907753 [Paths in patch adjusted.] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnstop/dnstop-20140915-r3.ebuild39
-rw-r--r--net-dns/dnstop/files/dnstop-20140915-musl-fix.patch16
-rw-r--r--net-dns/dnstop/metadata.xml2
3 files changed, 57 insertions, 0 deletions
diff --git a/net-dns/dnstop/dnstop-20140915-r3.ebuild b/net-dns/dnstop/dnstop-20140915-r3.ebuild
new file mode 100644
index 000000000000..fd94f6164029
--- /dev/null
+++ b/net-dns/dnstop/dnstop-20140915-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Displays various tables of DNS traffic on your network"
+HOMEPAGE="https://github.com/measurement-factory/dnstop"
+SRC_URI="http://dns.measurement-factory.com/tools/dnstop/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+
+RDEPEND="sys-libs/ncurses:0
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-pkg-config.patch
+ "${FILESDIR}/${P}"-musl-fix.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -D_GNU_SOURCE
+ econf --enable-ipv6
+}
+
+src_install() {
+ dobin dnstop
+ doman dnstop.8
+ dodoc CHANGES
+}
diff --git a/net-dns/dnstop/files/dnstop-20140915-musl-fix.patch b/net-dns/dnstop/files/dnstop-20140915-musl-fix.patch
new file mode 100644
index 000000000000..ddd1687c469e
--- /dev/null
+++ b/net-dns/dnstop/files/dnstop-20140915-musl-fix.patch
@@ -0,0 +1,16 @@
+Fixes compilation with musl
+Patch by Natanael Copa
+https://gitlab.alpinelinux.org/alpine/aports/-/issues/2890
+https://bugs.gentoo.org/717202
+
+--- a/dnstop.c
++++ b/dnstop.c
+@@ -69,7 +69,7 @@
+ #define ETHERTYPE_IPV6 0x86DD
+ #endif
+
+-#if defined(__linux__) || defined(__GLIBC__) || defined(__GNU__)
++#if defined(__GLIBC__) || defined(__GNU__)
+ #define uh_dport dest
+ #define uh_sport source
+ #endif
diff --git a/net-dns/dnstop/metadata.xml b/net-dns/dnstop/metadata.xml
index 08133e9b29b5..806de5e7629e 100644
--- a/net-dns/dnstop/metadata.xml
+++ b/net-dns/dnstop/metadata.xml
@@ -5,5 +5,7 @@
<upstream>
<changelog>http://dns.measurement-factory.com/tools/dnstop/src/CHANGES</changelog>
<doc>http://dns.measurement-factory.com/tools/dnstop/dnstop.8.html</doc>
+ <remote-id type="github">measurement-factory/dnstop</remote-id>
+ <bugs-to>https://github.com/measurement-factory/dnstop/issues</bugs-to>
</upstream>
</pkgmetadata>