summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-11-06 12:35:39 -0600
committerBen Kohler <bkohler@gentoo.org>2018-11-06 12:41:24 -0600
commitbffe2ff0720d62d5933186ee85904fce3464ede7 (patch)
tree5d518c94bfd77c30da0cd03ba7b909d59c6bc6aa /net-dialup
parentdev-libs/gost-engine: Version 1.1.0.3_p20181031 (diff)
downloadgentoo-bffe2ff0720d62d5933186ee85904fce3464ede7.tar.gz
gentoo-bffe2ff0720d62d5933186ee85904fce3464ede7.tar.bz2
gentoo-bffe2ff0720d62d5933186ee85904fce3464ede7.zip
net-dialup/cutecom: bump to 0.51.0
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/cutecom/Manifest1
-rw-r--r--net-dialup/cutecom/cutecom-0.51.0.ebuild39
-rw-r--r--net-dialup/cutecom/metadata.xml15
3 files changed, 48 insertions, 7 deletions
diff --git a/net-dialup/cutecom/Manifest b/net-dialup/cutecom/Manifest
index af1cbe488cad..4a2956b190ba 100644
--- a/net-dialup/cutecom/Manifest
+++ b/net-dialup/cutecom/Manifest
@@ -1 +1,2 @@
DIST cutecom-0.40.0.tar.gz 813238 BLAKE2B 2bc4f653e482e722f644dbaa0d713c3d8b6575369ad98d596843be18a37e8865857b82dcaccb52af73f3aa6e4e433ce2e43efe6d681ed558eedc468cee120827 SHA512 63df993fee01d73c40180a6b92d49e5200ae14db0275690f59ff02cfd2b6f573623cf74fb6d5dcabc292314642bb9cf2d9bd274a4094917f70418c30209bb403
+DIST cutecom-v0.51.0.tar.bz2 1296457 BLAKE2B 407bbe12fb4303e98589720c3fe9bf96a4112c816e64a3a32227d07a64c1efbb5b33c364d1f3f06ff67c9bc935c0bf62de14849b554508eaffacda1f65e7fad9 SHA512 67857977ab6444509662be4d27059e3c4cb766a69b78d806f4cd3d6cb7306d53094337fb384133a616ae397ac4d4d7c86347285a2d68f88fbf105d73ebd97731
diff --git a/net-dialup/cutecom/cutecom-0.51.0.ebuild b/net-dialup/cutecom/cutecom-0.51.0.ebuild
new file mode 100644
index 000000000000..e818e647e9b4
--- /dev/null
+++ b/net-dialup/cutecom/cutecom-0.51.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="CuteCom is a serial terminal, like minicom, written in qt"
+HOMEPAGE="https://gitlab.com/neundorf/CuteCom"
+SRC_URI="https://gitlab.com/cutecom/cutecom/-/archive/v${PV}/cutecom-v${PV}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtserialport:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz"
+
+S="${WORKDIR}/cutecom-v${PV}"
+
+src_prepare() {
+ sed -i \
+ -e '/Path/d' \
+ -e '/Terminal/s/0/false/' \
+ "${PN}.desktop" || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu "${PN}.desktop"
+ doicon "distribution/${PN}.png"
+}
diff --git a/net-dialup/cutecom/metadata.xml b/net-dialup/cutecom/metadata.xml
index 8ad2379909d6..107ba45773b3 100644
--- a/net-dialup/cutecom/metadata.xml
+++ b/net-dialup/cutecom/metadata.xml
@@ -1,11 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>CuteCom is a graphical serial terminal, like minicom. It is aimed mainly at hardware
-developers or other people who need a terminal to talk to their devices.</longdescription>
- <upstream>
- <remote-id type="sourceforge">cutecom</remote-id>
- <remote-id type="github">neundorf/CuteCom</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <longdescription>CuteCom is a graphical serial terminal, like minicom. It is aimed mainly at hardware developers or other people who need a terminal to talk to their devices.</longdescription>
+ <upstream>
+ <remote-id type="gitlab">cutecom/cutecom</remote-id>
+ </upstream>
</pkgmetadata>