summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/xc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/xc')
-rw-r--r--net-dialup/xc/Manifest1
-rw-r--r--net-dialup/xc/files/xc-4.3.2-add-115200.patch12
-rw-r--r--net-dialup/xc/files/xc-4.3.2-fix-set_bps-overflow.patch14
-rw-r--r--net-dialup/xc/files/xc-4.3.2-gentoo.patch122
-rw-r--r--net-dialup/xc/files/xc-4.3.2-implicit-decl.patch22
-rw-r--r--net-dialup/xc/metadata.xml6
-rw-r--r--net-dialup/xc/xc-4.3.2-r3.ebuild44
-rw-r--r--net-dialup/xc/xc-4.3.2-r4.ebuild45
8 files changed, 266 insertions, 0 deletions
diff --git a/net-dialup/xc/Manifest b/net-dialup/xc/Manifest
new file mode 100644
index 000000000000..ed67e15da47d
--- /dev/null
+++ b/net-dialup/xc/Manifest
@@ -0,0 +1 @@
+DIST xc-4.3.2.tar.gz 162098 SHA256 7e90ff0b89b646e1c8625fc675e6b33d244ab332a052ddd2daed825719e59461 SHA512 89de05a82f54ffd89a6950f9cb4aea732573ac1b15a27aaba4e25293a5d0b763052287700e4499f7f2adf9acc952ecea572239c8403c86c5871efd363d68710a WHIRLPOOL 98a62921c553d7507cdc052d01f50a99d62c8221149ad7a09a25faf6af4d139ee4f0a74433a0f4f8c053c29aafc5f70294551efa13830aa20516a9d40af028b4
diff --git a/net-dialup/xc/files/xc-4.3.2-add-115200.patch b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
new file mode 100644
index 000000000000..c8238565ac0b
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-add-115200.patch
@@ -0,0 +1,12 @@
+add support for 115200 baud
+
+--- xc-4.3.2/xcport.c
++++ xc-4.3.2/xcport.c
+@@ -107,6 +107,7 @@
+ {"38400",38400,B38400},
+ {"57600",57600,B50},
+ #endif
++ {"115200",115200,B115200},
+ {"0", 0, B0}
+ };
+
diff --git a/net-dialup/xc/files/xc-4.3.2-fix-set_bps-overflow.patch b/net-dialup/xc/files/xc-4.3.2-fix-set_bps-overflow.patch
new file mode 100644
index 000000000000..5934aa2f6d77
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-fix-set_bps-overflow.patch
@@ -0,0 +1,14 @@
+diff -Naurp xc-4.3.2.orig/xcmain.c xc-4.3.2/xcmain.c
+--- xc-4.3.2.orig/xcmain.c 1996-11-24 01:35:41.000000000 -0500
++++ xc-4.3.2/xcmain.c 2014-04-18 19:58:26.267227496 -0400
+@@ -696,8 +696,8 @@ static void
+ SET_bps()
+ {
+ if (statflag){
+- char br[6];
+- sprintf(br, "%d", mrate( NULL ));
++ char br[11];
++ snprintf(br, 11, "%d", mrate( NULL ));
+ fprintf(tfp, statfmt, "bps", "Bits per Second", br);
+ return;
+ }
diff --git a/net-dialup/xc/files/xc-4.3.2-gentoo.patch b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
new file mode 100644
index 000000000000..7c0c559958d9
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-gentoo.patch
@@ -0,0 +1,122 @@
+--- xc-4.3.2/Makefile
++++ xc-4.3.2/Makefile
+@@ -5,21 +5,24 @@
+
+ SHELL = /bin/sh
+
++DESTDIR =
++
+ #WARN = -Wall -ansi -pedantic -Wshadow -Wmissing-prototypes
+
+ #machine = -m486
+-CC = gcc
+-GCCOPT = -pipe -O2 -fno-strength-reduce -fomit-frame-pointer $(machine)
++#CC = gcc
++GCCOPT = -fno-strength-reduce
+ #GCCOPT = -O -g
+-CDEFS = -D_POSIX_SOURCE=1
++CDEFS = -D_XOPEN_SOURCE
+-CFLAGS = $(WARN) $(CDEFS) $(GCCOPT)
++CFLAGS += $(WARN) $(CDEFS) $(GCCOPT)
+
+-prefix = /usr/local
++prefix = /usr
+ bindir = $(prefix)/bin
+ libdir = $(prefix)/lib/xc
+-mandir = /usr/man/man1
++mandir = /usr/share/man
++man1dir = $(mandir)/man1
+ catdir = /var/catman/cat1
+-manown = -o root -g man
++manown = -o root -g root
+ binown = -o root -g root
+
+ export CC CFLAGS manown binown
+@@ -37,7 +39,7 @@
+ # gs -sDEVICE=ljet4 -dNOPAUSE -sOutputFile=$@ $<
+
+ INSTALL = install
+-LDFLAGS = -ltermcap editline/libedit.a
++LIBS += -lncurses editline/libedit.a
+ NROFF = groff -mandoc
+
+ # defines for use with cextract under Linux
+@@ -56,7 +58,7 @@
+ @echo "Now you may execute 'make install'"
+
+ xc: $(OBJS) eline
+- $(CC) $(CFLAGS) $(OBJS) -o xc $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o xc $(LIBS)
+
+ uninstall:
+ rm -f $(bindir)/xc $(mandir)/xc.1 $(catdir)/xc.1.*
+@@ -64,10 +66,9 @@
+
+ install: ./bin/xc ./bin/crc xc.1 crc.1
+ @echo " "
+- $(INSTALL) $(binown) -m 755 -s ./bin/xc $(bindir)
+- $(INSTALL) $(binown) -m 755 -s ./bin/crc $(bindir)
+- $(INSTALL) $(manown) -m 644 xc.1 $(mandir)
+- $(INSTALL) $(manown) -m 644 crc.1 $(mandir)
++ $(INSTALL) -d -m755 $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
++ $(INSTALL) $(binown) -m 755 xc crc $(DESTDIR)$(bindir)
++ $(INSTALL) $(manown) -m 644 xc.1 crc.1 $(DESTDIR)$(man1dir)
+ @echo " "
+ @echo " "
+ @echo "You will want to manually install 'phonelist' and"
+--- xc-4.3.2/xcsubs.c
++++ xc-4.3.2/xcsubs.c
+@@ -23,7 +23,6 @@
+ *tgetstr(), *tgoto();
+ int LI, /* One less than screen length in termcap entry */
+ CO; /* Screen width */
+-speed_t ospeed; /* Used by termcap lib */
+ static char tc[LG_BUFF]; /* termcap buffer */
+ static char tbuf[LG_BUFF], *CD, *CF, *CL, *CM, *CN, *AE, *SE, *SO, *ME;
+ char *CE, PC; /* used by termcap -- padding character */
+
+limit the 32bit crc to 32bits
+
+add simple usage
+
+--- xc-4.3.2/crc.c
++++ xc-4.3.2/crc.c
+@@ -152,7 +152,7 @@ char *name;
+ }
+ crc32 = oldcrc32; oldcrc = oldcrc32 = ~oldcrc32;
+
+- printf("%08lx %7ld ", oldcrc, charcnt);
++ printf("%08lx %7ld ", oldcrc & 0xffffffff, charcnt);
+ if (Block == 128)
+ printf("%5ld+%3ld ", charcnt/Block, charcnt%Block);
+ if (Block == 1024)
+@@ -170,6 +170,10 @@ char **argv;
+ {
+ register errors = 0;
+
++ if (argc == 1) {
++ puts("Usage: crc [-x|-k] <files>\n -x pad to 128 bytes\n -k pad to 1024 bytes");
++ exit(0);
++ }
+ if (argc > 1) {
+ if (!strcmp(argv[1], "-x")) {
+ Block = 128;
+--- xc-4.3.2/editline/Makefile.orig 2013-03-02 21:15:29.667344872 +0400
++++ xc-4.3.2/editline/Makefile 2013-03-02 21:15:38.434344313 +0400
+@@ -34,7 +34,7 @@
+ LDFLAGS = -ltermcap
+
+ ## Set ranlib as appropriate:
+-RANLIB = ranlib
++RANLIB ?= ranlib
+ #RANLIB = echo
+
+ ## End of configuration.
+@@ -70,6 +70,6 @@
+
+ libedit.a: $(OBJECTS)
+ @rm -f $@
+- ar r $@ $(OBJECTS)
++ $(AR) r $@ $(OBJECTS)
+ $(RANLIB) $@
+
diff --git a/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
new file mode 100644
index 000000000000..556392d8b189
--- /dev/null
+++ b/net-dialup/xc/files/xc-4.3.2-implicit-decl.patch
@@ -0,0 +1,22 @@
+--- xc-4.3.2/crc.c
++++ xc-4.3.2/crc.c
+@@ -5,6 +5,8 @@
+ * Crc - 32 BIT ANSI X3.66 CRC checksum files
+ */
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #define OK 0
+ #define ERROR (-1)
+ #define LINT_ARGS
+--- xc-4.3.2/xcterm.c
++++ xc-4.3.2/xcterm.c
+@@ -4,6 +4,8 @@
+ #define XCTERM_C 1
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/net-dialup/xc/metadata.xml b/net-dialup/xc/metadata.xml
new file mode 100644
index 000000000000..946425b89ea5
--- /dev/null
+++ b/net-dialup/xc/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+
+</pkgmetadata>
diff --git a/net-dialup/xc/xc-4.3.2-r3.ebuild b/net-dialup/xc/xc-4.3.2-r3.ebuild
new file mode 100644
index 000000000000..4bd01b85a68d
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Modem dialout & serial terminal program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+
+LICENSE="xc-radley"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-implicit-decl.patch
+ epatch "${FILESDIR}"/${P}-add-115200.patch
+
+ sed -i \
+ -e "/^libdir/s:/lib/:/$(get_libdir)/:" \
+ -e "/strip/d" \
+ Makefile || die
+ # bug 459796
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake WARN="" all
+}
+
+src_install() {
+ default
+ insinto /usr/$(get_libdir)/xc
+ doins phonelist xc.init dotfiles/.[a-z]*
+}
diff --git a/net-dialup/xc/xc-4.3.2-r4.ebuild b/net-dialup/xc/xc-4.3.2-r4.ebuild
new file mode 100644
index 000000000000..ea3c9accb43f
--- /dev/null
+++ b/net-dialup/xc/xc-4.3.2-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Modem dialout & serial terminal program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/serialcomm/dialout/${P}.tar.gz"
+
+LICENSE="xc-radley"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-implicit-decl.patch
+ epatch "${FILESDIR}"/${P}-add-115200.patch
+ epatch "${FILESDIR}"/${P}-fix-set_bps-overflow.patch
+
+ sed -i \
+ -e "/^libdir/s:/lib/:/$(get_libdir)/:" \
+ -e "/strip/d" \
+ Makefile || die
+ # bug 459796
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake WARN="" all
+}
+
+src_install() {
+ default
+ insinto /usr/$(get_libdir)/xc
+ doins phonelist xc.init dotfiles/.[a-z]*
+}