summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/wvdial/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/wvdial/files')
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-as-needed.patch15
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-destdir.patch35
-rw-r--r--net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch20
3 files changed, 70 insertions, 0 deletions
diff --git a/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch b/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch
new file mode 100644
index 000000000000..06c3ddd58a81
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-as-needed.patch
@@ -0,0 +1,15 @@
+--- wvdial-1.60/Makefile.in 2008-12-14 17:18:25.000000000 +0100
++++ wvdial-1.60/Makefile.in 2008-12-14 17:20:13.000000000 +0100
+@@ -15,10 +15,12 @@
+ ifeq ($(PC_LIBS),)
+ $(error WvStreams does not appear to be installed)
+ endif
+ LIBS+=$(PC_LIBS)
+
++wvdial-LIBS+= -luniconf
++
+ BINDIR=${prefix}/bin
+ MANDIR=${prefix}/share/man
+ PPPDIR=${DESTDIR}/etc/ppp/peers
+
+ include wvrules.mk
diff --git a/net-dialup/wvdial/files/wvdial-1.61-destdir.patch b/net-dialup/wvdial/files/wvdial-1.61-destdir.patch
new file mode 100644
index 000000000000..61f8cf74264a
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-destdir.patch
@@ -0,0 +1,35 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2010-05-27 13:08:26 +0000
++++ Makefile.in 2010-05-27 13:08:41 +0000
+@@ -3,7 +3,7 @@
+ WVPACKAGE_TARNAME=@PACKAGE_TARNAME@
+ WVPACKAGE_VERSION=@PACKAGE_VERSION@
+
+-prefix=/usr/local
++prefix=${DESTDIR}/usr
+ WVSTREAMS_INC=
+ WVSTREAMS_LIB=
+ WVSTREAMS_BIN=$(prefix)/bin
+@@ -23,7 +23,7 @@
+
+ BINDIR=${prefix}/bin
+ MANDIR=${prefix}/share/man
+-PPPDIR=/etc/ppp/peers
++PPPDIR=${DESTDIR}/etc/ppp/peers
+
+ include wvrules.mk
+
+
+=== modified file 'config.defaults.mk'
+--- config.defaults.mk 2010-05-27 13:08:26 +0000
++++ config.defaults.mk 2010-05-27 13:43:03 +0000
+@@ -13,7 +13,7 @@
+ LIBS_PAM=-lpam
+ LIBS_TCL=
+
+-prefix=/usr/local
++prefix=${DESTDIR}/usr
+ datadir=${prefix}/share
+ includedir=${prefix}/include
+ infodir=${prefix}/share/info
+
diff --git a/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch b/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch
new file mode 100644
index 000000000000..4c0c83709dd0
--- /dev/null
+++ b/net-dialup/wvdial/files/wvdial-1.61-parallel-make.patch
@@ -0,0 +1,20 @@
+--- wvdial-1.61/wvrules-posix.mk
++++ wvdial-1.61/wvrules-posix.mk
+@@ -85,12 +85,15 @@
+ $(AR) s $1
+ endef
+
+-CC: FORCE
++CC:
+ @CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS_SRC)/gen-cc CC c
+
+-CXX: FORCE
++CXX:
+ @CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
+ $(WVSTREAMS_SRC)/gen-cc CXX cc
+
++#All files must depend on the above two rules. This is a godawful hack.
++$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX
++
+ wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS)