summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-06 12:36:15 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-06 12:36:51 +0200
commit8345db6c4b37cf5673bae67b4a8e58f31e0e9e4a (patch)
tree2b2477b6c23911201ab814e2180adaa00c9fd4b2 /net-analyzer/xprobe
parentdev-util/howdoi: version bump 2.0.5 (diff)
downloadgentoo-8345db6c4b37cf5673bae67b4a8e58f31e0e9e4a.tar.gz
gentoo-8345db6c4b37cf5673bae67b4a8e58f31e0e9e4a.tar.bz2
gentoo-8345db6c4b37cf5673bae67b4a8e58f31e0e9e4a.zip
net-analyzer/xprobe: Fix compiling with sys-devel/clang
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Closes: https://bugs.gentoo.org/740654 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/xprobe')
-rw-r--r--net-analyzer/xprobe/files/xprobe-0.3-cxx11.patch11
-rw-r--r--net-analyzer/xprobe/xprobe-0.3-r1.ebuild36
2 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/xprobe/files/xprobe-0.3-cxx11.patch b/net-analyzer/xprobe/files/xprobe-0.3-cxx11.patch
new file mode 100644
index 000000000000..7ec38a9c2756
--- /dev/null
+++ b/net-analyzer/xprobe/files/xprobe-0.3-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/src/defines.h.in
++++ b/src/defines.h.in
+@@ -24,7 +24,7 @@
+
+ #define VERSION "@VERSION@"
+ #define BANNER \
+-"\nXprobe2 v."VERSION\
++"\nXprobe2 v." VERSION \
+ " Copyright (c) 2002-2005 fyodor@o0o.nu, ofir@sys-security.com, meder@o0o.nu"\
+ "\n"
+
diff --git a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
new file mode 100644
index 000000000000..209b65fecc78
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+HOMEPAGE="http://sys-security.com/blog/xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-cxx11.patch
+)
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ sed -i -e 's:strip:true:' src/Makefile.in || die
+ sed -i -e 's:ar cr:$(AR) cr:g' $(find -name '*Makefile*') || die
+
+ tc-export AR
+}
+
+src_install() {
+ default
+ dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
+}