summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 22:34:49 +0000
committerSam James <sam@gentoo.org>2021-04-12 23:07:36 +0000
commit04250e593d11cacad1521f6256e121899337b507 (patch)
tree0dbe3b21da8d58a8c2b724b5621b0ab6e76f6f5f /net-analyzer/tcpstat
parentnet-analyzer/ipguard: add missing pkgconfig (B)DEPEND (diff)
downloadgentoo-04250e593d11cacad1521f6256e121899337b507.tar.gz
gentoo-04250e593d11cacad1521f6256e121899337b507.tar.bz2
gentoo-04250e593d11cacad1521f6256e121899337b507.zip
net-analyzer/tcpstat: add missing pkgconfig (B)DEPEND
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpstat')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild b/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
index 859524d5c260..6be8bb24a4b0 100644
--- a/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
+++ b/net-analyzer/tcpstat/tcpstat-1.5_p8.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Reports network interface statistics"
@@ -10,6 +11,7 @@ SRC_URI="
https://www.frenchfries.net/paul/tcpstat/${P/_p*}.tar.gz
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 4).debian.tar.xz
"
+S="${WORKDIR}"/${P/_p*}
LICENSE="BSD-2"
SLOT="0"
@@ -20,10 +22,11 @@ DEPEND="
net-libs/libpcap
sys-libs/db:*
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt )
+
PATCHES=(
"${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
"${FILESDIR}"/${P}-ipv6.patch
@@ -31,7 +34,6 @@ PATCHES=(
"${FILESDIR}"/${P}-off-by-one.patch
"${FILESDIR}"/${P}-unused.patch
)
-S=${WORKDIR}/${P/_p*}
src_prepare() {
eapply $(
@@ -39,8 +41,8 @@ src_prepare() {
do echo "${WORKDIR}"/debian/patches/${patch}
done
) ${PATCHES[@]}
- eapply_user
+ eapply_user
eautoreconf
}