summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-28 01:21:56 +0000
committerSam James <sam@gentoo.org>2021-05-28 01:21:56 +0000
commit1fdae415e6c8455ce64be9d92a5350749f861668 (patch)
tree671252ca7a2f4126db879523880e592f67242fe0 /net-analyzer/nfdump
parentprofiles/arch/arm64: stable-mask app-text/dblatex[inkscape] (diff)
downloadgentoo-1fdae415e6c8455ce64be9d92a5350749f861668.tar.gz
gentoo-1fdae415e6c8455ce64be9d92a5350749f861668.tar.bz2
gentoo-1fdae415e6c8455ce64be9d92a5350749f861668.zip
net-analyzer/nfdump: add 1.6.23
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/Manifest1
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.23.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index 9fe8c8fe0681..e70f758c6b1f 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1,2 +1,3 @@
DIST nfdump-1.6.21.tar.gz 561617 BLAKE2B 61a52cb7ee724c47f93e0ce8dd0515306c16b94d8b351f9543deecc2b28c813f09f0e4ba621f2561760924af683ffd527d00936fbc5f91f83d6f727d6cf9e5d9 SHA512 c9162b7a6653267cd4d66a2d75bb2c3d65c431bb29ee549bac2a208fe7f2bc871bb91dfa6d89d6f18cd69f1d435dd25ba1c5dfe6e10b0efc4a582f2e67913a34
DIST nfdump-1.6.22.tar.gz 563266 BLAKE2B f985a8f8bcbb7ff3ab98d4f01449b121e92914bc47ec7fa07c1a7a068f6722447228b0166d0f2e966c0bab2c93e34133743e8dff7d8dc41a1c70ffac64fbbf6e SHA512 3508e54b4c4785a79118147779300eebd9485532e157b37ed6487255dacaa49959d425c8fc489caa98ff559a4859b9e456e97a6c8a06a1029eb904aa1f9efb61
+DIST nfdump-1.6.23.tar.gz 568879 BLAKE2B ca844f87e02fb3761d5b470cac11beada9873b0c7e3e9ca7ccc7899d57f0cfd96329698ac84467a55d683e83ce16c2b114a571845c7cb6069addcdd5d4a43903 SHA512 e3f79af69a170985fcbd1757fab86e90840d040cf7a6214c7f9851ed59695d3844a15269904c3ba989b6b6ed2ddf29fd19a493165d3037e49aa2bb69b831f168
diff --git a/net-analyzer/nfdump/nfdump-1.6.23.ebuild b/net-analyzer/nfdump/nfdump-1.6.23.ebuild
new file mode 100644
index 000000000000..6790afe4e55d
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.23.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow"
+
+REQUIRED_USE="?? ( jnat nsel )"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ ftconv? ( net-analyzer/flow-tools )
+ nfpcapd? ( net-libs/libpcap )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-compiler.patch
+ "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use doc; then
+ doxygen -u doc/Doxyfile.in || die
+ fi
+}
+
+src_configure() {
+ # --without-ftconf is not handled well, bug #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfpcapd && echo --enable-nfpcapd) \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable debug devel) \
+ $(use_enable jnat) \
+ $(use_enable nsel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow) \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/nfcapd.initd nfcapd
+ newconfd "${FILESDIR}"/nfcapd.confd nfcapd
+
+ if use doc; then
+ dodoc -r doc/html
+ fi
+}