summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/hping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/Manifest1
-rw-r--r--net-analyzer/hping/files/bytesex.h.patch18
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-tcl.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch26
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105.patch45
-rw-r--r--net-analyzer/hping/hping-3_pre20051105-r3.ebuild75
-rw-r--r--net-analyzer/hping/hping-3_pre20051105-r5.ebuild75
-rw-r--r--net-analyzer/hping/metadata.xml6
11 files changed, 300 insertions, 0 deletions
diff --git a/net-analyzer/hping/Manifest b/net-analyzer/hping/Manifest
new file mode 100644
index 000000000000..b4282eeaa87c
--- /dev/null
+++ b/net-analyzer/hping/Manifest
@@ -0,0 +1 @@
+DIST hping3-20051105.tar.gz 584001 SHA256 f5a671a62a11dc8114fa98eade19542ed1c3aa3c832b0e572ca0eb1a5a4faee8 SHA512 3b3faa836e70054c8f9f004d876b7eb5f668b64826a6aaf8ca3685619111d9df4eb494a7d38b83cea6cb5f0bd164956461039bf4f73f7c7e90d80cede639b2b3 WHIRLPOOL 2043ac3d71d795a34abe0fc58f525b54e25ca0b8fadb7b2e88d8a6f5d6f4744bda4471f74c96212a78f58510572c1079683ca57650428924eb6223ee110ea6c1
diff --git a/net-analyzer/hping/files/bytesex.h.patch b/net-analyzer/hping/files/bytesex.h.patch
new file mode 100644
index 000000000000..872321d41bfd
--- /dev/null
+++ b/net-analyzer/hping/files/bytesex.h.patch
@@ -0,0 +1,18 @@
+--- a/bytesex.h
++++ b/bytesex.h
+@@ -9,11 +9,15 @@
+
+ #if defined(__i386__) \
+ || defined(__alpha__) \
++ || defined(__arm__) \
++ || defined(__x86_64__) \
++ || defined(__ia64__) \
+ || (defined(__mips__) && (defined(MIPSEL) || defined (__MIPSEL__)))
+ #define BYTE_ORDER_LITTLE_ENDIAN
+ #elif defined(__mc68000__) \
+ || defined (__sparc__) \
+ || defined (__sparc) \
++ || defined (__hppa__) \
+ || defined (__PPC__) \
+ || defined (__BIG_ENDIAN__) \
+ || (defined(__mips__) && (defined(MIPSEB) || defined (__MIPSEB__)))
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
new file mode 100644
index 000000000000..39814bff0d8c
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -50,11 +50,11 @@
+ $(RANLIB) $@
+
+ hping3: byteorder.h $(OBJ)
+- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
++ $(CC) -o hping3 $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
+ @echo
+
+ hping3-static: byteorder.h $(OBJ)
+- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
++ $(CC) -static -o hping3-static $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
+
+ byteorder.h:
+ ./configure
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
new file mode 100644
index 000000000000..807399cb553c
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
@@ -0,0 +1,16 @@
+When anything libtcl (bug #247282) this will fail, and we're only finding out
+the version of the library anyway, so why not use TCL_VER, which is found using
+a slightly less fishy method. -JeR
+
+--- a/configure
++++ b/configure
+@@ -98,8 +98,7 @@
+ fi
+ if [ -n $USE_TCL ]
+ then
+- LIBPOSTFIX=`ls -1 /usr/local/lib/ /usr/lib | grep 'libtcl[0-9]' | grep so | sed -e 's/\.so.*//g' -e 's/libtcl//g' | sort -r | head -1`
+- TCL_LIB="-ltcl${LIBPOSTFIX} -lm -lpthread"
++ TCL_LIB="-ltcl${TCL_VER} -lm -lpthread"
+ fi
+
+ #
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch b/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
new file mode 100644
index 000000000000..2c3e01bf697a
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
@@ -0,0 +1,11 @@
+--- a/scan.c
++++ b/scan.c
+@@ -456,7 +456,7 @@
+ continue;
+ /* time to copy headers in a safe place */
+ p = packet+linkhdr_size+iphdrlen;
+- memcpy(&icmp, p, sizeof(subtcp));
++ memcpy(&icmp, p, sizeof(icmp));
+ p += sizeof(icmp);
+ memcpy(&subip, p, sizeof(ip));
+ p += sizeof(ip);
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
new file mode 100644
index 000000000000..1fb734e349b4
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -63,7 +63,7 @@
+ #
+ for TCLPATH_TRY in "/usr/bin/" "/usr/local/bin/" "/bin/"
+ do
+- for TCLVER_TRY in "8.4" "8.3" "8.2" "8.1" "8.0"
++ for TCLVER_TRY in "8.6" "8.5" "8.4" "8.3" "8.2" "8.1" "8.0"
+ do
+ if [ -z $TCLSH ]
+ then
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch b/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch
new file mode 100644
index 000000000000..8cd7065c8393
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch
@@ -0,0 +1,26 @@
+Fix for https://bugs.gentoo.org/show_bug.cgi?id=486664
+
+--- a/configure
++++ b/configure
+@@ -65,10 +65,10 @@
+ do
+ for TCLVER_TRY in "8.6" "8.5" "8.4" "8.3" "8.2" "8.1" "8.0"
+ do
+- if [ -z $TCLSH ]
++ if [ -z "$TCLSH" ]
+ then
+ TCLSH_TRY=${TCLPATH_TRY}tclsh${TCLVER_TRY}
+- if [ -f $TCLSH_TRY ]
++ if [ -f "$TCLSH_TRY" ]
+ then
+ TCLSH=$TCLSH_TRY
+ echo "===> Found Tclsh in: $TCLSH"
+@@ -76,7 +76,7 @@
+ fi
+ done
+ done
+-if [ -f $TCLSH ]
++if [ -f "$TCLSH" ]
+ then
+ TCL_VER=`echo puts \\$tcl_version | $TCLSH -`
+ USE_TCL='-DUSE_TCL'
diff --git a/net-analyzer/hping/files/hping-3_pre20051105.patch b/net-analyzer/hping/files/hping-3_pre20051105.patch
new file mode 100644
index 000000000000..e3133f2b6b42
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105.patch
@@ -0,0 +1,45 @@
+--- a/libpcap_stuff.c
++++ b/libpcap_stuff.c
+@@ -17,7 +17,7 @@
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+ #include <pcap.h>
+-#include <net/bpf.h>
++#include <pcap-bpf.h>
+
+ #include "globals.h"
+
+--- a/script.c
++++ b/script.c
+@@ -24,7 +24,7 @@
+
+ #include <sys/ioctl.h>
+ #include <pcap.h>
+-#include <net/bpf.h>
++#include <pcap-bpf.h>
+
+ #include "release.h"
+ #include "hping2.h"
+--- a/configure
++++ b/configure
+@@ -93,7 +93,7 @@
+ else
+ USE_TCL=""
+ TCL_LIB=""
+- echo "==> WARNING: no Tcl header files found!"
++ echo "==> WARNING: no Tcl header files found."
+ fi
+ fi
+ if [ -n $USE_TCL ]
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -52,9 +52,6 @@
+ hping3: byteorder.h $(OBJ)
+ $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
+ @echo
+- ./hping3 -v
+- @echo "use \`make strip' to strip hping3 binary"
+- @echo "use \`make install' to install hping3"
+
+ hping3-static: byteorder.h $(OBJ)
+ $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
diff --git a/net-analyzer/hping/hping-3_pre20051105-r3.ebuild b/net-analyzer/hping/hping-3_pre20051105-r3.ebuild
new file mode 100644
index 000000000000..336fe95512f9
--- /dev/null
+++ b/net-analyzer/hping/hping-3_pre20051105-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${PN}${PV//_pre/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc sparc x86"
+IUSE="tcl"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="net-libs/libpcap
+ tcl? ( dev-lang/tcl:0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}.patch \
+ "${FILESDIR}"/bytesex.h.patch \
+ "${FILESDIR}"/${P}-tcl.patch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-libtcl.patch \
+ "${FILESDIR}"/${P}-scan-overflow.patch
+
+ # Correct hard coded values
+ sed -i Makefile.in \
+ -e '/^CC=/d' \
+ -e '/^AR=/d' \
+ -e '/^RANLIB=/d' \
+ -e 's:/usr/local/lib:/usr/$(LIBDIR):g' \
+ -e 's:-O2:$(CFLAGS):' \
+ || die "sed Makefile.in failed"
+
+ # Change name from hping2 to hping3
+ sed -i docs/hping3.8 \
+ -e 's|HPING2|HPING|g' \
+ -e 's|hping2|hping|g' \
+ || die "sed hping3.8 failed"
+}
+
+src_configure() {
+ tc-export CC
+
+ # Not an autotools type configure:
+ sh configure $(use tcl || echo --no-tcl) || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ DEBUG="" \
+ "CFLAGS=${CFLAGS}" \
+ "AR=$(tc-getAR)" \
+ "RANLIB=$(tc-getRANLIB)" \
+ "LIBDIR=$(get_libdir)" \
+ || die "emake failed"
+}
+
+src_install () {
+ dosbin hping3
+ dosym /usr/sbin/hping3 /usr/sbin/hping
+ dosym /usr/sbin/hping3 /usr/sbin/hping2
+
+ newman docs/hping3.8 hping.8
+
+ dodoc INSTALL NEWS README TODO AUTHORS BUGS CHANGES
+}
diff --git a/net-analyzer/hping/hping-3_pre20051105-r5.ebuild b/net-analyzer/hping/hping-3_pre20051105-r5.ebuild
new file mode 100644
index 000000000000..76538df88a7c
--- /dev/null
+++ b/net-analyzer/hping/hping-3_pre20051105-r5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${PN}${PV//_pre/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="tcl"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="net-libs/libpcap
+ tcl? ( dev-lang/tcl:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}.patch \
+ "${FILESDIR}"/bytesex.h.patch \
+ "${FILESDIR}"/${P}-tcl.patch \
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-libtcl.patch \
+ "${FILESDIR}"/${P}-scan-overflow.patch \
+ "${FILESDIR}"/${P}-tclsh-proper-escaping.patch # bug #486664
+
+ # Correct hard coded values
+ sed -i Makefile.in \
+ -e '/^CC=/d' \
+ -e '/^AR=/d' \
+ -e '/^RANLIB=/d' \
+ -e 's:/usr/local/lib:/usr/$(LIBDIR):g' \
+ -e 's:-O2:$(CFLAGS):' \
+ || die
+
+ # Change name from hping2 to hping3
+ sed -i docs/hping3.8 \
+ -e 's|HPING2|HPING|g' \
+ -e 's|hping2|hping|g' \
+ || die
+}
+
+src_configure() {
+ tc-export CC
+
+ # Not an autotools type configure:
+ sh configure $(usex tcl '' --no-tcl) || die
+}
+
+src_compile() {
+ emake \
+ DEBUG="" \
+ "CFLAGS=${CFLAGS}" \
+ "AR=$(tc-getAR)" \
+ "RANLIB=$(tc-getRANLIB)" \
+ "LIBDIR=$(get_libdir)"
+}
+
+src_install () {
+ dosbin hping3
+ dosym /usr/sbin/hping3 /usr/sbin/hping
+ dosym /usr/sbin/hping3 /usr/sbin/hping2
+
+ newman docs/hping3.8 hping.8
+
+ dodoc AUTHORS BUGS CHANGES INSTALL NEWS README TODO
+}
diff --git a/net-analyzer/hping/metadata.xml b/net-analyzer/hping/metadata.xml
new file mode 100644
index 000000000000..9ca15ca788e8
--- /dev/null
+++ b/net-analyzer/hping/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
+