summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-08-09 17:37:28 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-08-11 11:07:55 +0200
commit9faff04c392041e0536602a5cb543f9eb4956c2c (patch)
tree5c36f487e38062661c98bc7c65bb638a115b5bf9 /net-analyzer/gsad
parentnet-analyzer/gvmd: fix OpenRC script (diff)
downloadgentoo-9faff04c392041e0536602a5cb543f9eb4956c2c.tar.gz
gentoo-9faff04c392041e0536602a5cb543f9eb4956c2c.tar.bz2
gentoo-9faff04c392041e0536602a5cb543f9eb4956c2c.zip
net-analyzer/gsad: fix OpenRC script
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32234 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/gsad')
-rw-r--r--net-analyzer/gsad/files/gsad-22.init8
-rw-r--r--net-analyzer/gsad/files/gsad-daemon.conf2
-rw-r--r--net-analyzer/gsad/gsad-22.5.1-r2.ebuild (renamed from net-analyzer/gsad/gsad-22.5.1-r1.ebuild)2
3 files changed, 5 insertions, 7 deletions
diff --git a/net-analyzer/gsad/files/gsad-22.init b/net-analyzer/gsad/files/gsad-22.init
index 9a93713bd591..f416990b19a4 100644
--- a/net-analyzer/gsad/files/gsad-22.init
+++ b/net-analyzer/gsad/files/gsad-22.init
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
: ${GSAD_USER:=gvm}
@@ -8,10 +8,8 @@
name="Greenbone Security Assistant (GSA)"
command="/usr/bin/gsad"
-command_args="--foreground ${GSAD_OPTIONS} ${GSAD_LISTEN_ADDRESS} ${GSAD_LISTEN_PORT} ${GVMD_LISTEN_ADDRESS} ${GVMD_LISTEN_PORT} ${GSAD_GNUTLS_PRIORITIES}"
-command_background="true"
command_user="${GSAD_USER}:${GSAD_GROUP}"
-pidfile="/run/gsad/gsad.pid"
+command_args="${GSAD_OPTIONS} ${GSAD_LISTEN_ADDRESS} ${GSAD_LISTEN_PORT} ${GVMD_LISTEN_ADDRESS} ${GVMD_LISTEN_PORT} ${GSAD_GNUTLS_PRIORITIES}"
retry="${GSAD_TIMEOUT}"
depend() {
@@ -20,5 +18,5 @@ depend() {
}
start_pre() {
- checkpath -d /run/gsad
+ checkpath -d --owner ${GSAD_USER} /var/run/gsad
}
diff --git a/net-analyzer/gsad/files/gsad-daemon.conf b/net-analyzer/gsad/files/gsad-daemon.conf
index f7c7ee514e50..e74b409cc84a 100644
--- a/net-analyzer/gsad/files/gsad-daemon.conf
+++ b/net-analyzer/gsad/files/gsad-daemon.conf
@@ -1,7 +1,7 @@
# Greenbone Security Assistant command args
# e.g. --foreground | e.g. --no-redirect
-GSAD_OPTIONS="--no-redirect"
+GSAD_OPTIONS="--no-redirect --http-only"
# GSAD listen adress
GSAD_LISTEN_ADDRESS="--listen=127.0.0.1"
diff --git a/net-analyzer/gsad/gsad-22.5.1-r1.ebuild b/net-analyzer/gsad/gsad-22.5.1-r2.ebuild
index 49e02618b234..7055f5038584 100644
--- a/net-analyzer/gsad/gsad-22.5.1-r1.ebuild
+++ b/net-analyzer/gsad/gsad-22.5.1-r2.ebuild
@@ -98,7 +98,7 @@ src_install() {
${PN}.service
insinto /etc/gvm/sysconfig
- doins "${FILESDIR}/${PN}-daemon.conf"
+ newins "${FILESDIR}/${PN}-daemon.conf" "${PN}-daemon.conf"
newinitd "${FILESDIR}/${PN}-22.init" "${PN}"
newconfd "${FILESDIR}/${PN}-daemon.conf" "${PN}"