summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 20:34:45 +0000
committerSam James <sam@gentoo.org>2021-03-15 20:58:40 +0000
commitd3f1239fca123e53cb804d70811e4dbd34380cc1 (patch)
treea07f362d373093d60dca5c608b30e382cb1bdfac /net-analyzer/fwlogwatch
parentnet-analyzer/dnstracer: tiny style changes in 1.10 (diff)
downloadgentoo-d3f1239fca123e53cb804d70811e4dbd34380cc1.tar.gz
gentoo-d3f1239fca123e53cb804d70811e4dbd34380cc1.tar.bz2
gentoo-d3f1239fca123e53cb804d70811e4dbd34380cc1.zip
net-analyzer/fwlogwatch: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/fwlogwatch')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
index 93b1e6a2a352..bd1e751f1e73 100644
--- a/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A packet filter and firewall log analyzer"
HOMEPAGE="http://fwlogwatch.inside-security.de/"
@@ -18,13 +18,15 @@ RDEPEND="
geoip? ( dev-libs/geoip )
zlib? ( sys-libs/zlib )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/flex
nls? ( sys-devel/gettext )
"
src_prepare() {
+ default
+
if use nls; then
strip-linguas -i po/
local lingua pofile
@@ -62,7 +64,7 @@ src_configure() {
src_compile() {
emake \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
use nls && emake -C po
@@ -72,6 +74,7 @@ src_install() {
emake \
LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
install
+
use nls && emake \
LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
install-i18n