summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-10 13:39:10 +0000
committerSam James <sam@gentoo.org>2023-03-10 13:55:10 +0000
commit04dbfe60bb23a22b1521b632556efa81d34fa77e (patch)
tree08be4df4918b5556c5f550f2e1f03b5ba86ba94e /net-analyzer/fprobe
parentnet-misc/sock: EAPI 8, fix configure w/ clang 16 (diff)
downloadgentoo-04dbfe60bb23a22b1521b632556efa81d34fa77e.tar.gz
gentoo-04dbfe60bb23a22b1521b632556efa81d34fa77e.tar.bz2
gentoo-04dbfe60bb23a22b1521b632556efa81d34fa77e.zip
net-analyzer/fprobe: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/899924 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/fprobe')
-rw-r--r--net-analyzer/fprobe/fprobe-1.1-r6.ebuild (renamed from net-analyzer/fprobe/fprobe-1.1-r5.ebuild)13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-analyzer/fprobe/fprobe-1.1-r5.ebuild b/net-analyzer/fprobe/fprobe-1.1-r6.ebuild
index 1aee1c4aa4f3..b873e1f9619b 100644
--- a/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
+++ b/net-analyzer/fprobe/fprobe-1.1-r6.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
DESCRIPTION="libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
-HOMEPAGE="http://fprobe.sourceforge.net"
+HOMEPAGE="https://fprobe.sourceforge.net"
SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -20,6 +22,13 @@ PATCHES=(
"${FILESDIR}"/fprobe-1.1-setgroups.patch
)
+src_prepare() {
+ default
+
+ # Clang 16, bug #899924
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable debug) \