summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/2ping
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/2ping')
-rw-r--r--net-analyzer/2ping/2ping-1.2.3.ebuild37
-rw-r--r--net-analyzer/2ping/2ping-2.0.ebuild37
-rw-r--r--net-analyzer/2ping/2ping-2.1.1.ebuild31
-rw-r--r--net-analyzer/2ping/Manifest3
-rw-r--r--net-analyzer/2ping/files/2pingd36
-rw-r--r--net-analyzer/2ping/files/2pingd.conf2
-rw-r--r--net-analyzer/2ping/metadata.xml17
7 files changed, 163 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-1.2.3.ebuild b/net-analyzer/2ping/2ping-1.2.3.ebuild
new file mode 100644
index 000000000000..ad1efe1932b9
--- /dev/null
+++ b/net-analyzer/2ping/2ping-1.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crc ipv6 md5 sha server"
+
+# The 2ping script itself checks if these optional deps are available.
+DEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ virtual/perl-IO
+ virtual/perl-Time-HiRes
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ md5? ( virtual/perl-Digest-MD5 )
+ sha? ( virtual/perl-Digest-SHA )
+ crc? ( dev-perl/Digest-CRC )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc ChangeLog README
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}
diff --git a/net-analyzer/2ping/2ping-2.0.ebuild b/net-analyzer/2ping/2ping-2.0.ebuild
new file mode 100644
index 000000000000..ad1efe1932b9
--- /dev/null
+++ b/net-analyzer/2ping/2ping-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crc ipv6 md5 sha server"
+
+# The 2ping script itself checks if these optional deps are available.
+DEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ virtual/perl-IO
+ virtual/perl-Time-HiRes
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ md5? ( virtual/perl-Digest-MD5 )
+ sha? ( virtual/perl-Digest-SHA )
+ crc? ( dev-perl/Digest-CRC )
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc ChangeLog README
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}
diff --git a/net-analyzer/2ping/2ping-2.1.1.ebuild b/net-analyzer/2ping/2ping-2.1.1.ebuild
new file mode 100644
index 000000000000..1b9cd45e5459
--- /dev/null
+++ b/net-analyzer/2ping/2ping-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-module
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crc ipv6 md5 sha server"
+
+# The 2ping script itself checks if these optional deps are available.
+DEPEND="
+ >=dev-lang/perl-5.6.0:=
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ virtual/perl-IO
+ virtual/perl-Time-HiRes
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ md5? ( virtual/perl-Digest-MD5 )
+ sha? ( virtual/perl-Digest-SHA )
+ crc? ( dev-perl/Digest-CRC )
+"
+
+RDEPEND="${DEPEND}"
diff --git a/net-analyzer/2ping/Manifest b/net-analyzer/2ping/Manifest
new file mode 100644
index 000000000000..6284dfe0a386
--- /dev/null
+++ b/net-analyzer/2ping/Manifest
@@ -0,0 +1,3 @@
+DIST 2ping-1.2.3.tar.gz 28755 SHA256 1d0c3f30c99f1437f799f6ba9d0b49d60468cd78c03feb7bea0dde7eff22d3b5
+DIST 2ping-2.0.tar.gz 33048 SHA256 c6c9c16969cd6b0541a2b0d5d8b1694f176ba7e32448bfa500f6ff8763cf75df SHA512 2bbf5347bc5fc354c8c2c8b8cca00a5c4375d48b984273d91bfe0bf62d0592990a55ac5afcecfa3ed46bf59d58607b505339f07e987d0c084889ab0f41368a2a WHIRLPOOL f3f383f05e891c48dcf23e12670834f3093caf27f8d8525960a8fec6854b497cf940e27370bd4ec95fba0771e64ae59d842acff505c222ba2d87468a74f4ad75
+DIST 2ping-2.1.1.tar.gz 27232 SHA256 20fc09dbbc7fa37b90bfa415bad801697bd56c16c653cda551bfadbad3936f65 SHA512 d290fc2cf03dd40a38f72d9f46abfc0ef2e3c65f420b53d00c299b442ad3d9312f459317f6125d3d9b2de888a1292f5f56f49de6de6b869f1dc325b24e20de19 WHIRLPOOL 9273991e2ddd4f68da4f31e9a282d45a05d993079dd86873ca6822904f0fb0c7fc25fe691c89239020d317feea901409ce13f5a6dfce53fdc10f66437b1eb0ed
diff --git a/net-analyzer/2ping/files/2pingd b/net-analyzer/2ping/files/2pingd
new file mode 100644
index 000000000000..a1cf292ac5fe
--- /dev/null
+++ b/net-analyzer/2ping/files/2pingd
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON="/usr/bin/2ping"
+PIDFILE="/var/run/2ping"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting 2ping server"
+ start-stop-daemon --start \
+ --background --make-pidfile \
+ --pidfile "${PIDFILE}" \
+ --exec "${DAEMON}" -- \
+ --listen -q ${OPTS} \
+ >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping 2ping server"
+ start-stop-daemon --stop --pidfile "${PIDFILE}"
+ eend $?
+}
+
+restart() {
+ ebegin "Restarting 2ping server"
+ start-stop-daemon --stop --pidfile "${PIDFILE}"
+ sleep 1
+ start-stop-daemon --start --exec "${DAEMON}" --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/net-analyzer/2ping/files/2pingd.conf b/net-analyzer/2ping/files/2pingd.conf
new file mode 100644
index 000000000000..12c263d3d054
--- /dev/null
+++ b/net-analyzer/2ping/files/2pingd.conf
@@ -0,0 +1,2 @@
+#Pass any extra 2ping server options here
+#OPTS="--ipv6"
diff --git a/net-analyzer/2ping/metadata.xml b/net-analyzer/2ping/metadata.xml
new file mode 100644
index 000000000000..ea661e700f0a
--- /dev/null
+++ b/net-analyzer/2ping/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription>
+ A bi-directional ping utility
+ </longdescription>
+ <use>
+ <flag name='crc'>Enable crc check.</flag>
+ <flag name='md5'>Enable md5 hash check.</flag>
+ <flag name='sha'>Enable sha1 or sha256 check.</flag>
+ <flag name='server'>Install the server init scripts.</flag>
+ </use>
+</pkgmetadata>