summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBlake Batson <bbatson101@gmail.com>2024-10-11 11:44:15 -0400
committerPacho Ramos <pacho@gentoo.org>2024-11-27 22:10:00 +0100
commita20d9625a53dc7ad5fa5c402bba0697fd591d61d (patch)
tree9657703a855fcf90b984a477e0e7eaffc01ed38d /media-video
parentsys-libs/libmodulemd: replace gtk-doc use for glib (diff)
downloadgentoo-a20d9625a53dc7ad5fa5c402bba0697fd591d61d.tar.gz
gentoo-a20d9625a53dc7ad5fa5c402bba0697fd591d61d.tar.bz2
gentoo-a20d9625a53dc7ad5fa5c402bba0697fd591d61d.zip
media-video/aravis: replace gtk-doc use for glib
Signed-off-by: Blake Batson <bbatson101@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38618 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/aravis/aravis-0.8.5-r1.ebuild (renamed from media-video/aravis/aravis-0.8.5.ebuild)13
-rw-r--r--media-video/aravis/aravis-9999.ebuild13
2 files changed, 16 insertions, 10 deletions
diff --git a/media-video/aravis/aravis-0.8.5.ebuild b/media-video/aravis/aravis-0.8.5-r1.ebuild
index 5b917f730ca2..da52864b35b9 100644
--- a/media-video/aravis/aravis-0.8.5.ebuild
+++ b/media-video/aravis/aravis-0.8.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ fi
LICENSE="LGPL-2+"
SLOT="0"
-IUSE="gtk-doc fast-heartbeat gstreamer introspection packet-socket test usb viewer"
+IUSE="doc fast-heartbeat gstreamer introspection packet-socket test usb viewer"
RESTRICT="!test? ( test )"
GST_DEPEND="
@@ -29,14 +29,17 @@ GST_DEPEND="
BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
- gtk-doc? (
+ doc? (
dev-util/gtk-doc
app-text/docbook-xml-dtd:4.3
)
introspection? ( dev-libs/gobject-introspection:= )
"
DEPEND="
- dev-libs/glib:2[gtk-doc?]
+ dev-libs/glib:2
+ doc? (
+ dev-libs/glib:2[gtk-doc(+),doc(+)]
+ )
dev-libs/libxml2:2
sys-libs/zlib
gstreamer? ( ${GST_DEPEND} )
@@ -56,7 +59,7 @@ fi
src_configure() {
local emesonargs=(
- $(meson_feature gtk-doc documentation)
+ $(meson_feature doc documentation)
$(meson_use fast-heartbeat)
$(meson_feature gstreamer gst-plugin)
$(meson_feature introspection)
diff --git a/media-video/aravis/aravis-9999.ebuild b/media-video/aravis/aravis-9999.ebuild
index f2dd9137fe00..5a36a90e452d 100644
--- a/media-video/aravis/aravis-9999.ebuild
+++ b/media-video/aravis/aravis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,7 @@ LICENSE="LGPL-2+"
SLOT="0"
# FIXME: As of right now tests are always built, once that changes a USE flag
# should be added. c.f. https://github.com/AravisProject/aravis/issues/286
-IUSE="gtk-doc fast-heartbeat gstreamer introspection packet-socket usb viewer"
+IUSE="doc fast-heartbeat gstreamer introspection packet-socket usb viewer"
GST_DEPEND="
media-libs/gstreamer:1.0
@@ -29,14 +29,17 @@ GST_DEPEND="
BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
- gtk-doc? (
+ doc? (
dev-util/gtk-doc
app-text/docbook-xml-dtd:4.3
)
introspection? ( dev-libs/gobject-introspection:= )
"
DEPEND="
- dev-libs/glib:2[gtk-doc?]
+ dev-libs/glib:2
+ doc? (
+ dev-libs/glib:2[gtk-doc(+),doc(+)]
+ )
dev-libs/libxml2:2
sys-libs/zlib
gstreamer? ( ${GST_DEPEND} )
@@ -56,7 +59,7 @@ fi
src_configure() {
local emesonargs=(
- $(meson_use gtk-doc documentation)
+ $(meson_use doc documentation)
$(meson_use fast-heartbeat)
$(meson_use gstreamer gst-plugin)
$(meson_use introspection)