summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-01-07 19:25:49 -0800
committerJohn Helmert III <ajak@gentoo.org>2024-01-07 19:34:23 -0800
commit86c7a89fadfab885b302e7d12a50b36ea17fd291 (patch)
treeab32e0d2b5895497fbd326d31327c01e732212ae /media-video
parentsys-fs/ext4magic: fix building with musl #716136 (diff)
downloadgentoo-86c7a89fadfab885b302e7d12a50b36ea17fd291.tar.gz
gentoo-86c7a89fadfab885b302e7d12a50b36ea17fd291.tar.bz2
gentoo-86c7a89fadfab885b302e7d12a50b36ea17fd291.zip
media-video/subtitleripper: treeclean
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleripper/Manifest1
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch21
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch25
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch28
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch28
-rw-r--r--media-video/subtitleripper/metadata.xml11
-rw-r--r--media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild58
7 files changed, 0 insertions, 172 deletions
diff --git a/media-video/subtitleripper/Manifest b/media-video/subtitleripper/Manifest
deleted file mode 100644
index cc60804cbe89..000000000000
--- a/media-video/subtitleripper/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST subtitleripper-0.3-4.tgz 47299 BLAKE2B e1a25adf55727463cc7aa57e2d005597c92212b1cb1f7edd7a20c5701444967d96af268f3b6feaf6ac29aa2f9dcfe2e0248593f5197228d1d0bbff9fad67c315 SHA512 6d25a43b5b1bf8a6c69200c8bab995265356d1235a872bb641d30dbf27b765be9280325b4dd8aa625c25a865563bd7525dd277682d5baeff3c54951da7b9a86a
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
deleted file mode 100644
index 8dc2b24f9f6a..000000000000
--- a/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naurp subtitleripper-orig/vobsub.c subtitleripper/vobsub.c
---- subtitleripper-orig/vobsub.c 2003-12-08 03:28:02.000000000 -0600
-+++ subtitleripper/vobsub.c 2009-05-30 19:09:13.266973499 -0600
-@@ -56,7 +56,7 @@ extern ssize_t getline(char **, size_t *
- /* FIXME This should go into a general purpose library or even a
- separate file. */
- static ssize_t
--getline (char **lineptr, size_t *n, FILE *stream)
-+get_line (char **lineptr, size_t *n, FILE *stream)
- {
- size_t res = 0;
- int c;
-@@ -753,7 +753,7 @@ vobsub_parse_one_line(vobsub_t *vob, FIL
- do {
- size_t line_reserve = 0;
- char *line = NULL;
-- line_size = getline(&line, &line_reserve, fd);
-+ line_size = get_line(&line, &line_reserve, fd);
- if (line_size < 0) {
- if (line)
- free(line);
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
deleted file mode 100644
index e9869b3bd5dd..000000000000
--- a/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -NrU5 subtitleripper.orig/spudec.c subtitleripper/spudec.c
---- subtitleripper.orig/spudec.c 2009-05-20 03:06:23.000000000 -0600
-+++ subtitleripper/spudec.c 2009-05-20 03:07:47.000000000 -0600
-@@ -34,17 +34,18 @@
-
- #ifdef _HAVE_ZLIB_
- #include <zlib.h>
- #endif
-
-+#ifdef _HAVE_PNG_
-+#include <png.h>
-+#endif
-+
- #ifdef _HAVE_LIB_PPM_
- #include <netpbm/ppm.h>
- #endif
-
--#ifdef _HAVE_PNG_
--#include "png.h"
--#endif
-
- static void spudec_handle_rest(spudec_handle_t *this);
-
- // read a big endian 16 bit value
- static inline unsigned int get_be16(const unsigned char *p)
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
deleted file mode 100644
index 7efe223460fc..000000000000
--- a/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: subtitleripper/Makefile
-===================================================================
---- subtitleripper.orig/Makefile
-+++ subtitleripper/Makefile
-@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
- # Target
- subtitle2pgm: subtitle2pgm.o spudec.o
- @echo "Linking $@"
-- @$(CC) $(LIBS) $^ -o $@
-+ @$(CC) $^ -o $@ $(LIBS)
-
- subtitle2vobsub: subtitle2vobsub.o vobsub.o
- @echo "Linking $@"
-- @$(CC) $(LIBS) $^ -o $@
-+ @$(CC) $^ -o $@ $(LIBS)
-
- srttool: srttool.o
- @echo "Linking $@"
-- @$(CC) $(LIBS) -g $^ -o $@
-+ @$(CC) -g $^ -o $@ $(LIBS)
-
- vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
- @echo "Linking $@"
-- @$(CC) $(LIBS) -g $^ -o $@
-+ @$(CC) -g $^ -o $@ $(LIBS)
-
- .PHONY: clean dist rpm
- clean:
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
deleted file mode 100644
index 2af11d257929..000000000000
--- a/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: subtitleripper/Makefile
-===================================================================
---- subtitleripper.orig/Makefile
-+++ subtitleripper/Makefile
-@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
- # Target
- subtitle2pgm: subtitle2pgm.o spudec.o
- @echo "Linking $@"
-- @$(CC) $^ -o $@ $(LIBS)
-+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
-
- subtitle2vobsub: subtitle2vobsub.o vobsub.o
- @echo "Linking $@"
-- @$(CC) $^ -o $@ $(LIBS)
-+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
-
- srttool: srttool.o
- @echo "Linking $@"
-- @$(CC) -g $^ -o $@ $(LIBS)
-+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
-
- vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
- @echo "Linking $@"
-- @$(CC) -g $^ -o $@ $(LIBS)
-+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
-
- .PHONY: clean dist rpm
- clean:
diff --git a/media-video/subtitleripper/metadata.xml b/media-video/subtitleripper/metadata.xml
deleted file mode 100644
index f3ed2a707fcf..000000000000
--- a/media-video/subtitleripper/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">subtitleripper</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
deleted file mode 100644
index ec6c555bf7ed..000000000000
--- a/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_PV="$(ver_rs 2 "-")"
-
-DESCRIPTION="DVD Subtitle Ripper for Linux"
-HOMEPAGE="http://subtitleripper.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-
-RDEPEND=">=media-libs/netpbm-10.41.0
- media-libs/libpng
- sys-libs/zlib
- >=app-text/gocr-0.39"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-linkingorder.patch
- "${FILESDIR}"/${P}-libpng.patch
- "${FILESDIR}"/${P}-glibc210.patch
- "${FILESDIR}"/${P}-respect-ldflags.patch
-)
-
-src_prepare() {
- # PPM library is libnetppm
- sed -i -e "s:ppm:netpbm:g" Makefile || die
- # fix for bug 210435
- sed -i -e "s:#include <ppm.h>:#include <netpbm/ppm.h>:g" \
- spudec.c subtitle2pgm.c || die
- # we will install the gocrfilters into /usr/share/subtitleripper
- sed -i -e 's:~/sourceforge/subtitleripper/src/:/usr/share/subtitleripper:' \
- pgm2txt || die
-
- default
-
- # respect CC
- sed -i -e "s:CC =.*:CC = $(tc-getCC):" \
- -e "/^CFLAGS/s: = :& ${CFLAGS} :" "${S}"/Makefile
-}
-
-src_install() {
- dobin pgm2txt srttool subtitle2pgm subtitle2vobsub vobsub2pgm
-
- insinto /usr/share/subtitleripper
- doins gocrfilter_*.sed
-
- dodoc ChangeLog README*
-}