summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-06 22:40:54 +0000
committerSam James <sam@gentoo.org>2022-02-06 22:40:54 +0000
commit59de33093462eccf9d71bff5fb81a248109c9e1a (patch)
tree623d13beaca2bca5981eb3276c0c07ce4aaa63ed /media-video
parentapp-misc/rpick: Stabilize 0.8.7 amd64, #832811 (diff)
downloadgentoo-59de33093462eccf9d71bff5fb81a248109c9e1a.tar.gz
gentoo-59de33093462eccf9d71bff5fb81a248109c9e1a.tar.bz2
gentoo-59de33093462eccf9d71bff5fb81a248109c9e1a.zip
media-video/ffmpeg: add mips, x86 (i486) to atomic workaround
See https://forums.gentoo.org/viewtopic-t-1147131.html. The MIPS case was reported to me on IRC by mrhansen and I'd forgot (I was sure I had!) that I hadn't updated the ebuild for it. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-5.0.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild b/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
index 5dbd2c460106..35cb418bf783 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
@@ -456,7 +456,7 @@ multilib_src_configure() {
)
local extra_libs
- if use arm || use ppc ; then
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
# bug #782811
# bug #790590
extra_libs+="$(test-flags-CCLD -latomic) "
diff --git a/media-video/ffmpeg/ffmpeg-5.0.ebuild b/media-video/ffmpeg/ffmpeg-5.0.ebuild
index a6be1e984dff..80468d5d74a1 100644
--- a/media-video/ffmpeg/ffmpeg-5.0.ebuild
+++ b/media-video/ffmpeg/ffmpeg-5.0.ebuild
@@ -456,7 +456,7 @@ multilib_src_configure() {
)
local extra_libs
- if use arm || use ppc ; then
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
# bug #782811
# bug #790590
extra_libs+="$(test-flags-CCLD -latomic) "
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index a6be1e984dff..80468d5d74a1 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -456,7 +456,7 @@ multilib_src_configure() {
)
local extra_libs
- if use arm || use ppc ; then
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
# bug #782811
# bug #790590
extra_libs+="$(test-flags-CCLD -latomic) "