summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-09-18 02:22:01 +0530
committerMatt Turner <mattst88@gentoo.org>2022-09-30 15:05:48 -0400
commit589176e316d803ef69d4d3712129c9e8ecbdf0f6 (patch)
tree1fc3afab56c345aa62bbe70fc67d1ea86db66664 /media-video/totem
parentx11-libs/libwnck: Version bump to 43.0 (diff)
downloadgentoo-589176e316d803ef69d4d3712129c9e8ecbdf0f6.tar.gz
gentoo-589176e316d803ef69d4d3712129c9e8ecbdf0f6.tar.bz2
gentoo-589176e316d803ef69d4d3712129c9e8ecbdf0f6.zip
media-video/totem: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27311 Signed-off-by: brahmajit das <listout@protonmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-video/totem')
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/files/43.0-gst-inspect-sandbox.patch30
-rw-r--r--media-video/totem/totem-43.0.ebuild128
3 files changed, 159 insertions, 0 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 08aa7abe8948..9098875f44d7 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,2 @@
DIST totem-42.0.tar.xz 2476952 BLAKE2B 45eac2e586c3c17eab9f570812ae2c79812859635d1ef6df1d0d2c526436558dbab9581699ce86d3e2cd3048f5d65bbd1927c3faa5f7575a5468d0813ce68bcc SHA512 67872d06a7d691a23b97255c5ee5f8d90a1fdf2b36f064f26c10fb4958733772eea456aab4f0fe2c89d23ec987cf5b9c2383c97ba5bec45247953296f1cd6c4b
+DIST totem-43.0.tar.xz 2486304 BLAKE2B 3b43ad2cbf40472bff3b7369001b9b7784ef52244812d9aae493fffa99982a8f24770d0f5063f0b1f1fd320d6b2cec5e702ded9ccfaece51f7bdf9d862b96230 SHA512 b35d32ebadf4b9900ab234f07f8a7128edbc15593e1447c22f3c7a653fcbd4a2df9d45484e2decce5dd5ab67849fca1003a1ded338a0af0930b6560ee4f764ae
diff --git a/media-video/totem/files/43.0-gst-inspect-sandbox.patch b/media-video/totem/files/43.0-gst-inspect-sandbox.patch
new file mode 100644
index 000000000000..6b545ebcdf8f
--- /dev/null
+++ b/media-video/totem/files/43.0-gst-inspect-sandbox.patch
@@ -0,0 +1,30 @@
+# From abb91b315f407b7e180bc00eb96f1cd6bb0ab25d Mon Sep 17 00:00:00 2001
+# From: Gilles Dartiguelongue <eva@gentoo.org>
+# Date: Thu, 7 Jun 2018 23:47:48 +0200
+# Subject: [PATCH] Make gst-inspect calls optional at build-time
+#
+# Crashes on Gentoo due to plugins trying to access dri nodes which are sandboxed
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -6,3 +6,4 @@ option('with-plugins', type: 'combo', choices: ['all', 'none', 'auto'], value: '
+ option('enable-gtk-doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+ option('profile', type: 'combo', choices: ['default', 'development'], value: 'default', description: 'Build profiles')
+ option('inspector-page', type:'boolean', value: false, description: 'Whether to build the optional GTK inspector page')
++option('gst-inspect', type: 'boolean', value: true, description: 'build-time test of available gstreamer plugins')
+--- a/src/backend/meson.build
++++ b/src/backend/meson.build
+@@ -1,5 +1,6 @@
+ backend_inc = include_directories('.')
+
++if get_option('gst-inspect')
+ gst_inspect = find_program(
+ 'gst-inspect-1.0',
+ join_paths(gst_dep.get_pkgconfig_variable('toolsdir'), 'gst-inspect-1.0'),
+@@ -32,6 +33,7 @@ foreach plugin: gst_good_plugins
+ assert(r.returncode() == 0,
+ 'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-good. Please install it.')
+ endforeach
++endif
+
+ sources = files(
+ 'bacon-time-label.c',
diff --git a/media-video/totem/totem-43.0.ebuild b/media-video/totem/totem-43.0.ebuild
new file mode 100644
index 000000000000..5786f84eb326
--- /dev/null
+++ b/media-video/totem/totem-43.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome.org gnome2-utils meson virtualx xdg python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos https://gitlab.gnome.org/GNOME/totem/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="gtk-doc +python test"
+# see bug #359379
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.72.0:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/libhandy-1.5.0:1
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0[pango]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-libs/grilo-0.3.0:0.3[playlist]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=dev-libs/totem-pl-parser-3.26.5:0=[introspection]
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=dev-libs/gobject-introspection-1.54:=
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/grilo-plugins:0.3
+ media-plugins/gst-plugins-gtk:1.0[opengl]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/adwaita-icon-theme
+ dev-libs/libportal:0=[gtk]
+ python? (
+ x11-libs/pango[introspection]
+ >=dev-libs/libpeas-1.1.0[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-lang/perl
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.5 )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# perl for pod2man
+# Prevent dev-python/pylint dep, bug #482538
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue)
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Drop pointless samplepython plugin from build
+ sed -e '/samplepython/d' -i src/plugins/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Denable-easy-codec-installation=yes
+ -Denable-python=$(usex python yes no)
+ -Dlibportal=enabled
+ -Dwith-plugins=all # in 3.34.1 only builtin and python plugins are left, and python is extra controlled by enable-python
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dprofile=default
+ -Dinspector-page=false
+ -Dgst-inspect=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0= # bug 812170
+ meson_src_install
+ if use python ; then
+ python_optimize "${ED}"/usr/$(get_libdir)/totem/plugins/
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx meson_src_test
+}