summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2022-01-13 13:59:09 +0200
committerSam James <sam@gentoo.org>2022-01-14 13:56:07 +0000
commitcc00a665f6f530f46069d28707a63775f518423d (patch)
tree8108804bb5394045a13c2bf663a87eb86aa7108f /media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
parentsys-process/htop: Stabilize 3.1.2-r1 ppc64, #831174 (diff)
downloadgentoo-cc00a665f6f530f46069d28707a63775f518423d.tar.gz
gentoo-cc00a665f6f530f46069d28707a63775f518423d.tar.bz2
gentoo-cc00a665f6f530f46069d28707a63775f518423d.zip
media-video/ffmpeg: fix mixed strip usage
Even though stripping is disabled for compiled binaries (--disable-stripping), some configure phase test binaries get stripped and this causes Clang builds to use the GNU strip instead of LLLVM strip. Fix this by specifying to configure the proper version of strip to be used via --strip="$(tc-getSTRIP)" Bug: https://bugs.gentoo.org/831128 Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/23770 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild b/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
index d28411d2bd94..d0fcdc2e9005 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.1-r1.ebuild
@@ -472,6 +472,7 @@ multilib_src_configure() {
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
--nm="$(tc-getNM)" \
+ --strip="$(tc-getSTRIP)" \
--ranlib="$(tc-getRANLIB)" \
--pkg-config="$(tc-getPKG_CONFIG)" \
--optflags="${CFLAGS}" \