summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-08 00:08:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 18:28:08 +0100
commite6408e70b2daa530fdb49e3d9f62a00eb4a94891 (patch)
tree78717a53bafeeba258f6172d3b54cbf498ebfe60 /media-video/avidemux
parentmedia-libs/avidemux-core: Sorting, fix DESCRIPTION (diff)
downloadgentoo-e6408e70b2daa530fdb49e3d9f62a00eb4a94891.tar.gz
gentoo-e6408e70b2daa530fdb49e3d9f62a00eb4a94891.tar.bz2
gentoo-e6408e70b2daa530fdb49e3d9f62a00eb4a94891.zip
media-video/avidemux: Sorting, line breaks
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/avidemux-9999.ebuild42
1 files changed, 24 insertions, 18 deletions
diff --git a/media-video/avidemux/avidemux-9999.ebuild b/media-video/avidemux/avidemux-9999.ebuild
index 2e985fe5726f..6b3b95e51a5a 100644
--- a/media-video/avidemux/avidemux-9999.ebuild
+++ b/media-video/avidemux/avidemux-9999.ebuild
@@ -3,26 +3,24 @@
EAPI=6
-inherit cmake-utils qmake-utils xdg-utils
-
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/${PN}"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="debug opengl nls nvenc qt5 sdl vaapi vdpau xv"
-
if [[ ${PV} == *9999* ]] ; then
MY_P="${P}"
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
-
inherit git-r3
else
MY_P="${PN}_${PV}"
SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
+inherit cmake-utils qmake-utils xdg-utils
+
+DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+SLOT="2.6"
+IUSE="debug nls nvenc opengl qt5 sdl vaapi vdpau xv"
COMMON_DEPEND="
~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?,nvenc?]
@@ -54,21 +52,29 @@ src_prepare() {
done
# Fix icon name -> avidemux-2.6.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
+ sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || \
+ die "Icon name fix failed."
# The desktop file is broken. It uses avidemux2 instead of avidemux3
# so it will actually launch avidemux-2.5 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die "Desktop file fix failed."
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt'$(usex qt5 5 4)':' ${PN}2.desktop || die "Desktop file fix failed."
+ sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || \
+ die "Desktop file fix failed."
+ if use qt5; then
+ sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt5:' ${PN}2.desktop || \
+ die "Desktop file fix failed."
+ fi
- # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || die "Desktop file fix failed."
+ # QA warnings: missing trailing ';' and 'Application' is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || \
+ die "Desktop file fix failed."
# Now rename the desktop file to not collide with 2.5.
mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
- # Remove "Build Option" dialog because it doesn't reflect what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
+ # Remove "Build Option" dialog because it doesn't reflect
+ # what the GUI can or has been built with. (Bug #463628)
+ sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
+ die "Couldn't remove \"Build Option\" dialog."
}
src_configure() {